Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.

"clavier" français / anglais

#1Messageil y a 6 jours

bonjour à tou.te.s
sur 2 pc différents mais avec à priori os et logiciels égaux
j'utilise xdotool
et si je lance

xdotool type "aaaammmm"
sur l'un des pc on affche

aaaammmm
sur l'autre

qqqq;;;;
comme si c'était un clavier anglais
je dois regarder quoi pour corriger cela ?
merci d'avance
@+

"clavier" français / anglais

#2Messageil y a 6 jours

:bjr:
Salut,
Avec Xfce :
Paramètres --> Clavier --> Dispositions --> choisir : Français .
:gsourire:

"clavier" français / anglais

#3Messageil y a 6 jours

oui, mais non.
choix du clavier déjà en français.
si je tape dans un "terminal" «aaaammmm» ça baigne, c'est bien en français
@+

"clavier" français / anglais

#4Messageil y a 6 jours

Si ça marche sur le PC 1 regarde déjà si les paramètres (dans Xdotool) du PC 2 sont identiques ?
Apparemment ils devraient être différents ? Non ? Puisque ça ne marche pas !!

Sinon :saispas: attends que quelqu'un de plus pointu passe par là !!
Je ne sais pas si beaucoup de personnes utilisent un simulateur de clavier ??
Salut
Désolé :desole:

"clavier" français / anglais

#5Messageil y a 5 jours

pas sûr que des paramètres existent dans xdotool,
enfin, je n'en ai pas trouvé et on n'en parle nulle part
et j'ai tenté avec d'autres programmes équivalents : c'est la même chose

"clavier" français / anglais

#6Messageil y a 5 jours

Salut,

C'est un bug qui date de plusieurs années et que le développeur n'a jamais pu trouver, vérifie quand même la config du clavier sur le PC qui marche, et compare la avec celle du PC où ça ne marche pas.

Pour afficher la config clavier :

setxkbmap -print

"clavier" français / anglais

#7Messageil y a 4 jours

pas tout à fait la même chose (va savoir pourquoi ? ),
mais ça ne doit pas jouer (?)

pc ok :

setxkbmap -print

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(azerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+fr(oss)+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};
};

xdotool type "aaaammm"
affiche:

aaaammm
pc ko :

setxkbmap -print

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(azerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+fr(oss)+inet(evdev)+terminate(ctrl_alt_bksp)"	};
	xkb_geometry  { include "pc(pc105)"	};
};

xdotool type "aaaammmm"

qqqq;;;;
un "contournement" est possible ?

"clavier" français / anglais

#8Messageil y a 4 jours

Tu as essayé de faire en root loadkeys fr ? Cette commande devrait forcer le mappage FR pour toute la session.
Regarde aussi le retour de cat /etc/vconsole.conf des deux machines.

"clavier" français / anglais

#9Messageil y a 4 jours

sur les 2 machines, cat /etc/vconsole.conf

KEYMAP=fr
FONT=
FONT_MAP=
loadkeys fr en root, semble ne rien changer

"clavier" français / anglais

#10Messageil y a 4 jours

Bon, clairement, c'est un défaut lié à xdotool qui semble assez récurent. De ce que j'en ai lu, ce programme rajoute une surcouche à setxkbmap et semble perturber le serveur X.
As tu le même pilote sur les deux machines ?
Regarde et compare avec mhwd -li et inxi -G.
Honnêtement, je ne connais pas ce programme.

"clavier" français / anglais

#11Messageil y a 4 jours

pc ko :
mhwd -li

 Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
             video-ati            2017.03.24                true            PCI
Warning: No installed USB configs!
inxi -G

Graphics:
  Device-1: AMD Mullins [Radeon R3 Graphics] driver: radeon v: kernel
  Display: x11 server: X.Org 1.20.3 driver: radeon resolution: 1366x768~60Hz
  OpenGL: renderer: AMD MULLINS (DRM 2.50.0 4.19.1-1-MANJARO LLVM 7.0.0)
  v: 4.5 Mesa 18.2.4
pc ok :
mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
Warning: No installed USB configs!
inxi -G

Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
  driver: i915 v: kernel
  Display: x11 server: X.org 1.20.3 driver: none
  resolution: <xdpyinfo missing>
  OpenGL: renderer: Mesa DRI Intel Bay Trail v: 4.2 Mesa 18.2.4
clairement, c'est un défaut lié à xdotool
ah je ne crois pas du tout : j'ai testé avec un petit programme ( go ? python ? ... je ne sais plus )
qui simule lui aussi, et le résultat était le même
Modifié en dernier par bul le 09 Nov 2018, 10:22, modifié 1 fois.

"clavier" français / anglais

#12Messageil y a 4 jours

As tu un fichier ~/.xbindkeysrc ? Ou peut-être un autre du genre ?
As essayer de supprimer ou renommer puis se reconnecter.
Dans le wiki d'Arch, ils en parlent un peu à la fin .
Where the "xdotool" command would work in commandline, if the "+ Release" is removed it will fail with xbindkeys.

Là où la commande "xdotool" fonctionnerait en ligne de commande, si "+ Release" est supprimé, elle échouera avec xbindkeys.

"clavier" français / anglais

#13Messageil y a 4 jours

As tu un fichier ~/.xbindkeysrc ?
ni sur l'un ni sur l'autre pc
pas compris cette histoire de + Release ?

"clavier" français / anglais

#14Messageil y a 4 jours

j'ai retrouvé mon petit exemple en python :

›python -B
Python 3.7.1 (default, Oct 22 2018, 10:41:28) 
[GCC 8.2.1 20180831] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import pyautogui
>>> pyautogui.typewrite('aaaammmm')
qqqq;;;;
sur l'autre pc, ça baigne, on affiche bien «aaaammmm»
à priori pas vraiment lié à xdotool, non ?

"clavier" français / anglais

#15Messageil y a 4 jours

tu peux aussi vérifier ce point :
https://forum.manjaro.org/t/switching-s ... e/61807/10

edit /etc/locale.gen (fr_FR.UTF-8 UTF-8, fr_FR ISO-8859-1 , and fr_FR@euro ISO-8859-15) AND comment English - for some reason if you leave English there it won’t work, not sure why

run sudo locale-gen - although I ran this in the beginning, this needs to be run once English is commented in the previous step, otherwise it will keep English as the default even if you manually change the default
set the locale using sudo localectl set-locale LANG=fr_FR.UTF-8
reboot and everything is in French
Modifié en dernier par stephane le 09 Nov 2018, 11:31, modifié 2 fois.

"clavier" français / anglais

#16Messageil y a 4 jours

tu ne devrais plus avoir video-ati et etre en video-linux
ah ? bonne piste ! pourquoi pas.
on fait cela comment ?

"clavier" français / anglais

#17Messageil y a 4 jours

pour la video

pc ko :

mhwd -l
pour le clavier
vérifier
/etc/locale.gen
fr_FR.UTF-8 UTF-8, fr_FR ISO-8859-1 , and fr_FR@euro ISO-8859-15)
et commentaire pour anglais ( si tu le laisse tu aura un souci )

puis

sudo locale-gen
sudo localectl set-locale LANG=fr_FR.UTF-8
et reboot

"clavier" français / anglais

#18Messageil y a 4 jours

mhwd -l

> 0000:00:01.0 (0300:1002:9850) Display controller ATI Technologies Inc:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI
puis :

›sudo locale-gen
Generating locales...
  fr_FR.UTF-8... done
  fr_FR.ISO-8859-1... done
  fr_FR.ISO-8859-15@euro... done
Generation complete.
›sudo localectl set-locale LANG=fr_FR.UTF-8
›
reboot... et pareil, doit manquer un petit quelque chose ?

"clavier" français / anglais

#19Messageil y a 4 jours

il reste d'ailleurs des "non free"
mhwd -la

> All PCI configs:
-------------------------------------------------------
                  NAME     VERSION     FREEDRIVER  TYPE
-------------------------------------------------------
...        video-catalyst  2017.03.12  false       PCI
...    video-nvidia-390xx  2018.08.09  false       PCI
             video-nvidia  2018.08.09  false       PCI
...    video-nvidia-340xx  2018.08.09  false       PCI
...
Warning: No USB configs found!
je n'ai laissé que ceux-là dans la copie d'écran

"clavier" français / anglais

#20Messageil y a 4 jours

peut tu fournir pour le pc Ko

sudo inxi -GSCxxx
normalement tu devrais avoir la version Xorg 1.20.3

Répondre