Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.
Répondre

Installer une version non disponible dans les repos manjaro

#1Messageil y a 2 mois

Bonjour,

J'utilise depuis pas mal de temps maintenant le logiciel lsd pour lister les fichiers et dossiers depuis mon terminal.

Depuis la dernière maj, le logiciel bug pas mal. D'après le github le problème est régler dans la version 0.14

Pouvez vous me dire comment je peut installer la nouvelle version sans devoir attendre les maj de manjaro pour en bénéficier ?

Merci d'avance

Lien du github : https://github.com/Peltoche/lsd/releases

Installer une version non disponible dans les repos manjaro

#2Messageil y a 2 mois

prendre la version git dans aur lsd-git (pour l'instant même avec arch c'est la version 0.13)

Installer une version non disponible dans les repos manjaro

#3Messageil y a 2 mois

Merci pour ta réponse.

J'avais tester cette version sauf qu'elle est tag 0.2.0 donc une ancienne version ( une des premières )
Je doit installer en dépendance nerd font 300 Mb sans oublier d'autre dépendances. ( 400 mb au total :maisnon::roll: )

En testing il y a la bonne version mais bon passer en testing juste pour ça bof

edit : erreur lors de l'install de AUR

==> Recherche des erreurs d’empaquetage…
==> ERREUR : Fichier commençant par un point trouvé à la racine du paquet « /var/tmp/pamac-build-cyber/lsd-git/pkg/lsd-git/.crates.toml ».

Installer une version non disponible dans les repos manjaro

#4Messageil y a 2 mois

les paquets -git n'ont pas de version : elle est dynamique et calculée uniquement à la construction sur ta machine : c'est obligatoirement le dernier commit du dépôt git.

0.13 en unstable chez manjaro ... si tu parles d'un miroir archlinux , il n'y a aucun problème à la télécharger depuis ton navigateur web puis tenter (dépendances arch ne sont pas synchro avec manjaro) un pacman -U paquet_téléchargé

Installer une version non disponible dans les repos manjaro

#5Messageil y a 2 mois

Pour le paquet git j'ai vu lors de la compilation qu'il ma pris la dernière version mais j'ai eu le message d'erreur que j'ai marquer et cela peut importe comment je fait.

En ce qui concerne l’installation via pacman -U il me dit qu'il n'y a pas de vérification ainsi que d'autres choses puis me retourne une erreur et stop.

En ce qui concerne l'information pour le paquet, j'ai pris le lien de recherche de paquet testing sur manjaro

https://repology.org/projects/?search=l ... es_newest=

Mais d'après ce que j'ai compris ce n'est pas uniquement manjaro :lol:

Répondre