Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.
Répondre

Équivalant sudo apt-get autoremove (Mangaro) ?

#1Messageil y a 1 an

Bonjour,

Je cherche l'équivalant de sudo apt-get autoremove sous Manjaro (les habitudes Ubuntu sont dures à perdre).
J'ai trouvé ce lien : viewtopic.php?t=7587
Il y est précisé qu'il faut exécuter la commande :

pacman -Rsn nom_du_paquet
Mais pour :

sudo apt-get autoremove
Il n'y a aucun nom de paquet à indiquer, autoremove supprime tout !

Cordialement.

Équivalant sudo apt-get autoremove (Mangaro) ?

#2Messageil y a 1 an

:bjr:

Avec les paquets nous avons des orphelins
c'est paquets orphelins sont des paquets installés comme dépendances donc installés par l'installation d'une application et non par l'utilisateur

pacman -Rs supprime une application et éventuellement ces orphelins (éventuellement car une dépendance peut-être utile aussi pour une autre application)

Si nous utilisons toujours l'option s nous avons pas ou très peu d'orphelins (une suppression d'une application avec pamac graphique ne supprime pas les orphelins)

Avec pamac graphique, nous avons une page "orphelins" pour tous les supprimer d'un coup
Avec pamac cli (dans un terminal), nous avons une commande pour supprimer tous les orphelins pamac remove -o

Avec pacman il faut passer plusieurs paramètres - on trouve la commande dans les wiki et très souvent dans ce forum (il faut chercher orphelins et non autoremove) (généralement on se fait un alias car pas simple à retenir)

On peut trouver dans le wiki des correspondances entre les linux

Équivalant sudo apt-get autoremove (Mangaro) ?

#3Messageil y a 11 mois

:bjr:

Merci pour ta réponse. :bien

Équivalant sudo apt-get autoremove (Mangaro) ?

#4Messageil y a 11 mois

attention avec cette commande ,
il faut toujours voir avant la liste

sudo pacman -Qdt
car un jour tu va supprimer des éléments de base

Équivalant sudo apt-get autoremove (Mangaro) ?

#5Messageil y a 1 semaine

papajoke a écrit : il y a 1 an Avec pamac graphique, nous avons une page "orphelins" pour tous les supprimer d'un coup
Avec pamac cli (dans un terminal), nous avons une commande pour supprimer tous les orphelins pamac remove -o
Bonjour,

Je n'ai jamais fais pamac remove -o depuis un an.
Je viens donc de la lancer pour voir, il ne m'a même pas été demandé mon mot de passe ?
Je n'ai rien supprimé pour l'instant, y-a-t-il un risque à répondre "o" ? "N" j'ai répondu par défaut Entrée

[caille@caille-n76vb ~]$ pamac remove -o
Préparation...
Vérification des dépendances...

À désinstaller  (116):
  libwnck                    2.31.0-3                                                        community
  startup-notification       0.12-7                 (Orphelin de : libwnck)                  extra
  python-jsonschema          3.2.0-4                                                         community
  python-importlib-metadata  3.7.2-1                (Orphelin de : python-jsonschema)        community
  python-zipp                3.4.1-1                (Orphelin de : python-jsonschema)        community
  python-pyrsistent          0.17.3-3               (Orphelin de : python-jsonschema)        community
  python-attrs               20.3.0-3               (Orphelin de : python-jsonschema)        extra
  python-pytoml              0.1.21-6                                                        community
  gtest                      1.10.0-3                                                        community
  linux-latest               5.10-1                                                          
  doxygen                    1.9.1-1                                                         extra
  opera-ffmpeg-codecs        88.0.4324.192-1                                                 community
  plasma-desktop-primex      5.21.2-1                                                        extra
  polkit-kde-agent           5.21.3-1               (Orphelin de : plasma-desktop-primex)    extra
  accountsservice            0.6.55-3               (Orphelin de : plasma-desktop-primex)    extra
  mozilla-common             1.4-6                                                           extra
  unzip                      6.0-14                                                          extra
  kcalendarcore              5.80.0-1                                                        extra
  perl-pod-parser            1.63-1                                                          community
  eigen                      3.3.9-1                                                         extra
  pepper-flash               32.0.0.465-1                                                    
  hugin                      2020.0.0-1                                                      community
  libpano13                  2.9.19-5               (Orphelin de : hugin)                    community
  enblend-enfuse             4.2-6                  (Orphelin de : hugin)                    community
  vigra                      1.11.1-30              (Orphelin de : hugin)                    community
  gsl                        2.6-2                  (Orphelin de : hugin)                    extra
  xmlto                      0.0.28-4                                                        extra
  lib32-alsa-oss             1.1.8-2                                                         multilib
  gobject-introspection      1.66.1-3                                                        extra
  python-mako                1.1.4-1                (Orphelin de : gobject-introspection)    extra
  python-beaker              1.11.0-6               (Orphelin de : gobject-introspection)    extra
  python-markupsafe          1.1.1-7                (Orphelin de : gobject-introspection)    extra
  libmediawiki               5.37.0-3                                                        extra
  wxgtk2                     3.0.5.1-2                                                       extra
  libxnvctrl                 460.56-1                                                        extra
  akonadi-contacts           20.12.3-1                                                       extra
  grantleetheme              20.12.3-1              (Orphelin de : akonadi-contacts)         extra
  libakonadi                 20.12.3-1              (Orphelin de : akonadi-contacts)         extra
  libkleo                    20.12.3-1              (Orphelin de : akonadi-contacts)         extra
  kpimtextedit               20.12.3-1              (Orphelin de : akonadi-contacts)         extra
  kmime                      20.12.3-1              (Orphelin de : akonadi-contacts)         extra
  intltool                   0.51.0-6                                                        extra
  libpeas                    1.28.0-3                                                        extra
  libgee06                   0.6.8-1                                                         community
  gconf                      3.2.6+11+g07808097-7                                            community
  lib32-lz4                  1.9.3-1                                                         multilib
  js60                       60.9.0-2                                                        
  lib32-libindicator-gtk2    12.10.1-8                                                       multilib
  libindicator-gtk2          12.10.1-9              (Orphelin de : lib32-libindicator-gtk2)  community
  fontforge                  20201107-1                                                      extra
  potrace                    1.16-2                 (Orphelin de : fontforge)                extra
  libuninameslist            20200413-2             (Orphelin de : fontforge)                extra
  breezy                     3.1.0.8-1                                                       extra
  python-patiencediff        0.2.1-3                (Orphelin de : breezy)                   extra
  python-configobj           5.0.6.r110.g3e2f4cc-1  (Orphelin de : breezy)                   community
  xorg-font-utils            7.6-6                                                           
  xorg-mkfontscale           1.2.1-2                (Orphelin de : xorg-font-utils)          extra
  xorg-bdftopcf              1.1-2                  (Orphelin de : xorg-font-utils)          extra
  xorg-font-util             1.3.2-2                (Orphelin de : xorg-font-utils)          extra
  xorg-server-xvfb           1.20.10-3                                                       extra
  python-sip4                4.19.25-1                                                       extra
  folks                      0.14-4                                                          extra
  evolution-data-server      3.38.4-1               (Orphelin de : folks)                    extra
  libgweather                3.36.1-2               (Orphelin de : folks)                    extra
  libgdata                   0.18.1-1               (Orphelin de : folks)                    extra
  libphonenumber             8.12.19-2              (Orphelin de : folks)                    extra
  gnome-online-accounts      3.38.1-1               (Orphelin de : folks)                    extra
  python-asn1crypto          1.4.0-3                                                         extra
  qtav                       1.13.0-1                                                        extra
  extra-cmake-modules        5.80.0-1                                                        extra
  cmake                      3.19.7-1               (Orphelin de : extra-cmake-modules)      extra
  rhash                      1.4.1-1                (Orphelin de : extra-cmake-modules)      extra
  libuv                      1.41.0-1               (Orphelin de : extra-cmake-modules)      extra
  mercurial                  5.7.1-1                                                         extra
  vulkan-headers             1:1.2.172-1                                                     extra
  libkvkontakte              5.0.0-3                                                         extra
  kdewebkit                  5.80.0-1               (Orphelin de : libkvkontakte)            extra
  texi2html                  5.0-6                                                           extra
  lib32-libidn               1.36-1                                                          multilib
  telepathy-glib             0.24.2-2                                                        extra
  glade                      3.38.2-1                                                        extra
  pamac-tray-icon-plasma     0.1.2-4                                                         extra
  js68                       68.12.0-1                                                       extra
  xorg-fonts-alias           1.0.3-3                                                         
  lib32-libdbusmenu-gtk2     16.04.0-4                                                       multilib
  lib32-gtk2                 2.24.33-1              (Orphelin de : lib32-libdbusmenu-gtk2)   multilib
  lib32-libdbusmenu-glib     16.04.0-4              (Orphelin de : lib32-libdbusmenu-gtk2)   multilib
  libdbusmenu-gtk2           16.04.0-4              (Orphelin de : lib32-libdbusmenu-gtk2)   community
  go                         2:1.16.2-1                                                      community
  gmime3                     3.2.7-1                                                         extra
  itstool                    1:2.0.6-2                                                       extra
  vala                       0.50.4-1                                                        extra
  gtk-doc                    1.33.2-1               (Orphelin de : vala)                     extra
  python-pygments            2.8.1-1                (Orphelin de : vala)                     community
  python-anytree             2.8.0-3                (Orphelin de : vala)                     extra
  glib2-docs                 2.66.7-1               (Orphelin de : vala)                     core
  libytnef                   1.9.3+7+g24fe30e-2                                              extra
  gsound                     1.0.2-5                                                         extra
  meson                      0.57.1-1                                                        extra
  ninja                      1.10.2-1               (Orphelin de : meson)                    community
  mingw-w64-gcc              10.2.0-2                                                        community
  mingw-w64-winpthreads      8.0.0-1                (Orphelin de : mingw-w64-gcc)            community
  mingw-w64-crt              8.0.0-1                (Orphelin de : mingw-w64-gcc)            community
  mingw-w64-headers          8.0.0-1                (Orphelin de : mingw-w64-gcc)            community
  mingw-w64-binutils         2.35.1-1               (Orphelin de : mingw-w64-gcc)            community
  boost                      1.75.0-2                                                        extra
  software-center-web-jak    1.0.2-1                                                         community
  python2-pyxdg              0.26-8                                                          extra
  mhwd-nvidia-340xx          340.108-1                                                       
  pygtk                      2.24.0-14                                                       community
  python2-gobject2           2.28.7-6.1             (Orphelin de : pygtk)                    community
  python2-cairo              1.18.2-4               (Orphelin de : pygtk)                    extra
  libglade                   2.6.4-7                (Orphelin de : pygtk)                    extra
  encfs                      1.9.5-2                                                         community
  tinyxml2                   7.1.0-1                (Orphelin de : encfs)                    community
  linux-latest-bbswitch      5.10-1                                                          

Taille totale libérée: 2,8 Go

Appliquer la transaction ? [o/N] 

Transaction annulée.
[caille@caille-n76vb ~]$ sudo pacman -Qdt
[sudo] Mot de passe de caille : 
akonadi-contacts 20.12.3-1
boost 1.75.0-2
breezy 3.1.0.8-1
doxygen 1.9.1-1
eigen 3.3.9-1
encfs 1.9.5-2
extra-cmake-modules 5.80.0-1
folks 0.14-4
fontforge 20201107-1
gconf 3.2.6+11+g07808097-7
glade 3.38.2-1
gmime3 3.2.7-1
go 2:1.16.2-1
gobject-introspection 1.66.1-3
gsound 1.0.2-5
gtest 1.10.0-3
hugin 2020.0.0-1
intltool 0.51.0-6
itstool 1:2.0.6-2
js60 60.9.0-2
js68 68.12.0-1
kcalendarcore 5.80.0-1
lib32-alsa-oss 1.1.8-2
lib32-libdbusmenu-gtk2 16.04.0-4
lib32-libidn 1.36-1
lib32-libindicator-gtk2 12.10.1-8
lib32-lz4 1.9.3-1
libgee06 0.6.8-1
libkvkontakte 5.0.0-3
libmediawiki 5.37.0-3
libpeas 1.28.0-3
libwnck 2.31.0-3
libxnvctrl 460.56-1
libytnef 1.9.3+7+g24fe30e-2
linux-latest 5.10-1
linux-latest-bbswitch 5.10-1
mercurial 5.7.1-1
meson 0.57.1-1
mhwd-nvidia-340xx 340.108-1
mingw-w64-gcc 10.2.0-2
mozilla-common 1.4-6
opera-ffmpeg-codecs 88.0.4324.192-1
pamac-tray-icon-plasma 0.1.2-4
pepper-flash 32.0.0.465-1
perl-pod-parser 1.63-1
plasma-desktop-primex 5.21.2-1
pygtk 2.24.0-14
python-asn1crypto 1.4.0-3
python-jsonschema 3.2.0-4
python-pytoml 0.1.21-6
python-sip4 4.19.25-1
python2-pyxdg 0.26-8
qtav 1.13.0-1
software-center-web-jak 1.0.2-1
telepathy-glib 0.24.2-2
texi2html 5.0-6
unzip 6.0-14
vala 0.50.4-1
vulkan-headers 1:1.2.172-1
wxgtk2 3.0.5.1-2
xmlto 0.0.28-4
xorg-font-utils 7.6-6
xorg-fonts-alias 1.0.3-3
xorg-server-xvfb 1.20.10-3
[caille@caille-n76vb ~]$ 

Équivalant sudo apt-get autoremove (Mangaro) ?

#6Messageil y a 1 semaine

Bonjour, je n'utilise pas pamac mais les orphelins peuvent être listés également à l'aide de pacman : pacman -Qdt Ensuite on passe à la suppression : sudo pacman -Rs paquet1 paquet2

Il est fréquent de recevoir un avertissement de type :
paquet8 peut nécessiter paquet1
Tu peux ignorer ce message sans aucun risque, pacman indique juste qu'il aurait pu être, éventuellement, installé "explicitement" (manuellement) comme dépendance optionnelle de "paquet 8". :wink:

En gros, le "paquet8" n'installe pas le "paquet1" par défaut mais c'est l'utilisateur qui en prend l'initiative. pacman est particulièrement bien conçu et lorsque tu t'apprêtes à faire une con :censure: rie, il te prévient : "paquet1 est requis par..."
Répondre