Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.

mise à jour du système (confit de dépendance)

#1Messageil y a 7 mois

Hello tout le monde Je vous écris car je ne trouve vraiment plus de solution,j'essaie de faire la mise à jour sur mon pc que je n'ai pas allumé depuis presque 8 mois.
À la fin Linux me trouve des conflits entre des paquets dont manjaro-hello et manjaro-hello -dev.

je n'arrive pas à trouver de solution c'est pour ça que je me tourne vers vous en espérant que vous pourrez me guider ou me conseiller.

Merci d'avance a ceux qui prendront du temps pour m'aider. 😊

mise à jour du système (confit de dépendance)

#2Messageil y a 7 mois

Hello,

D'après ce que ma dit le chef ce matin, 8 mois c'est très long pour faire des majs d'une rolling release.
Au niveau de la maj tu la faite en TTY ?

mise à jour du système (confit de dépendance)

#3Messageil y a 7 mois

fais nous un retour précis
de la commande

sudo pacman -Syyu
et des messages d'erreurs en retour

mise à jour du système (confit de dépendance)

#4Messageil y a 7 mois

[sudo] Mot de passe de billy : 
:: Synchronisation des bases de données de paquets...
erreur : échec de récupération du fichier « core.db » depuis manjaro.mirrors.uk2.net : Resolving timed out after 10518 milliseconds
erreur : échec de récupération du fichier « core.db » depuis www.mirrorservice.org : Resolving timed out after 10521 milliseconds
 core                                                                        149,7 KiB   846K/s 00:00 [############################################################] 100%
 extra                                                                      1843,8 KiB  1455K/s 00:01 [############################################################] 100%
 community                                                                     5,1 MiB  1471K/s 00:04 [############################################################] 100%
 multilib                                                                    184,4 KiB  1418K/s 00:00 [############################################################] 100%
:: Début de la mise à jour complète du système...
 recherche des conflits entre paquets...
erreur : un conflit de paquets impossible à résoudre a été détecté
erreur : la préparation de la transaction a échoué (conflit de dépendances)
:: manjaro-hello et manjaro-hello-dev sont en conflit
10
administration/modération

mise à jour du système (confit de dépendance)

#5Messageil y a 7 mois

:salut:
Tu peux déinstaller manjaro-hello-dev avant maj

mise à jour du système (confit de dépendance)

#6Messageil y a 7 mois

peut tu m'envoyer la ligne de commande svp

mise à jour du système (confit de dépendance)

#7Messageil y a 7 mois

:salut:

sudo pacman -R manjaro-hello-dev

mise à jour du système (confit de dépendance)

#8Messageil y a 7 mois

[billy@billy-laptop ~]$ sudo pacman -R manjaro-hello-dev
[sudo] Mot de passe de billy : 
erreur : impossible de trouver la cible : manjaro-hello-dev
[billy@billy-laptop ~]$
Dernière modification par Erwan le 13 Jan 2019, 17:44, modifié 1 fois.
Raison :ajout balises code

mise à jour du système (confit de dépendance)

#9Messageil y a 7 mois

Pour la maj il me semble qu'il n'arrive pas a récupérer certaines db ( core.db )
Du coup perso je ferais

sudo pacman-mirrors -f0 && sudo pacman -Syyu
A mon avis pacman veux installer la version dev à la place de l'autre.
Du coup ça serais plutôt

sudo pacman -R manjaro-hello
Dernière modification par Cyberdr3am le 13 Jan 2019, 17:43, modifié 1 fois.

mise à jour du système (confit de dépendance)

#10Messageil y a 7 mois

Ton retour de mise à jour, ci dessus n'est pas complet, donc difficile de deviner :wink: Essaies ceci : sudo pacman -R manjaro-hello

mise à jour du système (confit de dépendance)

#11Messageil y a 7 mois

[billy@billy-laptop ~]$ sudo pacman-mirrors -f0
[sudo] Mot de passe de billy : 
usage: pacman-mirrors [-h] [-g] [-m {rank,random}]
                      [-b {stable,testing,unstable}] [-c COUNTRY] [-d CHEMIN]
                      [-o FICHIER] [-t SECONDES] [--no-update] [-i] [-v]
pacman-mirrors: error: unrecognized arguments: -f0
[billy@billy-laptop ~]$ sudo pacman -R manjaro-hello
erreur : impossible de trouver la cible : manjaro-hello
[billy@billy-laptop ~]$ 
sa ne marche tjr pas :desole:

mise à jour du système (confit de dépendance)

#12Messageil y a 7 mois

voici le retour complet


[billy@billy-laptop ~]$ sudo pacman -Syyu
:: Synchronisation des bases de données de paquets...
 core                     149,7 KiB  1018K/s 00:00 [######################] 100%
 extra                   1843,8 KiB  1437K/s 00:01 [######################] 100%
 community                  5,1 MiB  1390K/s 00:04 [######################] 100%
 multilib                 184,4 KiB   922K/s 00:00 [######################] 100%
:: Début de la mise à jour complète du système...
:: Remplacer apache-ant par extra/ant ? [O/n] 
:: Remplacer ca-certificates-cacert par core/ca-certificates ? [O/n] 
:: Remplacer compositeproto par extra/xorgproto ? [O/n] 
:: Remplacer damageproto par extra/xorgproto ? [O/n] 
:: Remplacer dmxproto par extra/xorgproto ? [O/n] 
:: Remplacer fixesproto par extra/xorgproto ? [O/n] 
:: Remplacer fontsproto par extra/xorgproto ? [O/n] 
:: Remplacer fuse par extra/fuse2 ? [O/n] 
:: Remplacer gcc-libs-multilib par core/gcc-libs ? [O/n] 
:: Remplacer gcc-multilib par core/gcc ? [O/n] 
:: Remplacer gnome-themes-standard par extra/gnome-themes-extra ? [O/n] 

:: Remplacer inputproto par extra/xorgproto ? [O/n] 
:: Remplacer kbproto par extra/xorgproto ? [O/n] 
:: Remplacer lib32-elfutils par multilib/lib32-libelf ? [O/n] 
:: Remplacer lib32-libdbus par multilib/lib32-dbus ? [O/n] 



:: Remplacer libx264 par extra/x264 ? [O/n] 
:: Remplacer manjaro-documentation par extra/manjaro-documentation-en ? [O/n] 
:: Remplacer manjaro-welcome par extra/manjaro-hello ? [O/n] 
:: Remplacer manjaro-welcome par extra/manjaro-hello-dev ? [O/n] 
avertissement : menulibre : la version locale (1:2.1.0-1) est plus récente que community (2.2.0-2)
:: Remplacer mime-types par extra/mailcap ? [O/n] 
:: Remplacer pacman-mirrorlist par core/pacman-mirrors ? [O/n] 
:: Remplacer pkg-config par core/pkgconf ? [O/n] 
avertissement : plymouth : la version locale (1:0.8.8-2) est plus récente que extra (0.9.4.r36.g0cd0613-1)
:: Remplacer python2-crypto par community/python2-pycryptodome ? [O/n] 
:: Remplacer randrproto par extra/xorgproto ? [O/n] 
:: Remplacer recordproto par extra/xorgproto ? [O/n] 
:: Remplacer renderproto par extra/xorgproto ? [O/n] 
:: Remplacer rfkill par core/util-linux ? [O/n] 
:: Remplacer scrnsaverproto par extra/xorgproto ? [O/n] 

:: Remplacer vertex-themes par community/vertex-theme ? [O/n] 
:: Remplacer videoproto par extra/xorgproto ? [O/n] 
:: Remplacer wxgtk par extra/wxgtk2 ? [O/n] 
:: Remplacer xextproto par extra/xorgproto ? [O/n] 
:: Remplacer xf86dgaproto par extra/xorgproto ? [O/n] 
:: Remplacer xf86miscproto par extra/xorgproto ? [O/n] 
:: Remplacer xf86vidmodeproto par extra/xorgproto ? [O/n] 
:: Remplacer xineramaproto par extra/xorgproto ? [O/n] 
:: Remplacer xproto par extra/xorgproto ? [O/n] 
résolution des dépendances...

recherche des conflits entre paquets...
erreur : un conflit de paquets impossible à résoudre a été détecté
erreur : la préparation de la transaction a échoué (conflit de dépendances)
:: manjaro-hello et manjaro-hello-dev sont en conflit
[billy@billy-laptop ~]$

mise à jour du système (confit de dépendance)

#13Messageil y a 7 mois

Pense à mettre tes retours entre balises code. Ça fait 2 fois que je corrige tes messages. Il suffit de cliquer sur le bouton </> et de coller entre les balises.
Donne :

pacman -Ss manjaro-hello |grep install

mise à jour du système (confit de dépendance)

#14Messageil y a 7 mois

désolé pour les messages précédants
voila la reponce du terminal

[billy@billy-laptop ~]$ pacman -Ss manjaro-hello |grep install
[billy@billy-laptop ~]$ pacman -Ss manjaro-hello 
extra/manjaro-hello 0.6.1-1
    A tool providing access to documentation and support for new Manjaro users.
extra/manjaro-hello-dev 0.5.99-1
    A tool providing access to documentation and support for new Manjaro users.
[billy@billy-laptop ~]$ 

mise à jour du système (confit de dépendance)

#15Messageil y a 7 mois

Bon, il y a un gros soucis. Manjaro-hello-dev est dans le système de fichier, mais n'est pas installé normalement.
On va essayer sudo pacman -S manjaro-hello --overwrite '*'

mise à jour du système (confit de dépendance)

#16Messageil y a 7 mois

[billy@billy-laptop ~]$ sudo pacman -S manjaro-hello --overwrite '*'
[sudo] Mot de passe de billy : 
Désolé, essayez de nouveau.
[sudo] Mot de passe de billy : 
pacman : option non reconnue « --overwrite »

mise à jour du système (confit de dépendance)

#17Messageil y a 7 mois

il est sur ancienne version de pacman avant la 5.0
l'option -f devrait être possible

peux tu nous fournir

inxi -Fxxx
Dernière modification par stephane le 13 Jan 2019, 18:22, modifié 1 fois.

mise à jour du système (confit de dépendance)

#18Messageil y a 7 mois

oui mon os a au minimum 5 ans si c'est trop la merde je veut pas vous embêter j’installerais un kali demain soir

mise à jour du système (confit de dépendance)

#19Messageil y a 7 mois

Ouch :o
Bon, essayons sudo pacman -S --force manjaro-hello

mise à jour du système (confit de dépendance)

#20Messageil y a 7 mois

billy671 a écrit :
il y a 7 mois
oui mon os a au minimum 5 ans si c'est trop la merde je veut pas vous embêter j’installerais un kali demain soir
Tu peux aussi tout simplement réinstaller Manjaro depuis une iso récente. Là on est sur un cas atypique et je suis curieux de voir si on peut y arriver.

Répondre