Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

Fichier « /boot/vmlinuz-4.4-x86_64 » non disponible

#1Messageil y a 1 mois

Bonjour,

Après une grosse mise à jour, mon Manjaro ne démarre plus. J'ai l'erreur suivante :

erreur : fichier « /boot/vmlinuz-4.4-x86_64 » non disponible.
erreur : le noyau doit d'abord être chargé.

Appuyez sur une touche pour continuer.
Quand j'appuie sur une touche, il retourne à Grub.

En faisant des recherches, je suis tombé sur un forum Ubuntu qui parle de boot-repair. J'ai booté sur un LiveUSB Manjaro, mais je n'ai pas trouvé de boot-repair, ni en pré-installé, ni dans les dépôts.

Quelle serait la solution à mon problème sur Manjaro ?

Fichier « /boot/vmlinuz-4.4-x86_64 » non disponible

#2Messageil y a 1 mois

bonjour,

on manque d'infos ! je suppose que simplement tu n'as plus ce noyau...
Utilises-tu un grub manjaro ? sinon il ne doit pas être à jour (attention grub base débian est incompatible avec manjaro)
Si grub manjaro, même chose, il faut le mettre à jour (manjaro-chroot )

Dans tous les cas, pas de boot-repair :wink:

Fichier « /boot/vmlinuz-4.4-x86_64 » non disponible

#3Messageil y a 1 mois

J'ai un Grub Manjaro et n'utilise que Manjaro. Je n'ai pas mon ordi sous la main. Je vais voir ce que je peux faire avec manjaro-chroot plus tard.

Merci

Fichier « /boot/vmlinuz-4.4-x86_64 » non disponible

#4Messageil y a 1 mois

bonjour

pour les infos ,
tu démarres sur la clé USB ( pas le disque ) ,
tu ouvre un terminal et tu nous retourne

inxi -Fxxxza
tu peux déjà tenter la chose suivante

manjaro-chroot -a ( choisi 1 si une seule ligne )
mkinitcpio -P
exit ( quitte chroot *obligatoire*)
et redémarre
Dernière modification par stephane le 06 Déc 2019, 19:05, modifié 1 fois.

Fichier « /boot/vmlinuz-4.4-x86_64 » non disponible

#5Messageil y a 1 mois

stephane a écrit :
il y a 1 mois
bonjour

pour les infos ,
tu démarres sur la clé USB ( pas le disque ) ,
tu ouvre un terminal et tu nous retourne

inxi -Fxxxza
Il me retourne une erreur illegal option -a

Sans le a :

System:    Host: manjaro Kernel: 4.4.19-1-MANJARO x86_64 (64 bit gcc: 6.1.1)
           Desktop: Xfce 4.12.3 (Gtk 2.24.30) info: xfce4-panel dm: lightdm Distro: Manjaro Linux
Machine:   System: ASUSTeK (portable) product: X302LJ v: 1.0
           Mobo: ASUSTeK model: X302LJ v: 1.0 UEFI: American Megatrends v: X302LJ.204 date: 08/24/2015
Battery    BAT0: charge: 27.3 Wh 91.8% condition: 29.7/38.0 Wh (78%) volts: 7.6/7.6
           model: ASUSTeK ASUS Li-ion serial: N/A status: Charging cycles: 58
CPU:       Dual core Intel Core i5-5200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8783
           clock speeds: min/max: 500/2700 MHz 1: 2247 MHz 2: 2387 MHz 3: 2337 MHz 4: 2336 MHz
Graphics:  Card-1: Intel HD Graphics 5500 bus-ID: 00:02.0 chip-ID: 8086:1616
           Card-2: NVIDIA GK208M [GeForce 920M] bus-ID: 04:00.0 chip-ID: 10de:1299
           Display Server: X.Org 1.17.4 driver: intel Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           GLX Version: 3.0 Mesa 12.0.1 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:160c
           Sound: Advanced Linux Sound Architecture v: k4.4.19-1-MANJARO
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
           IF: enp2s0 state: down mac: <filter>
           Card-2: Broadcom BCM43142 802.11b/g/n driver: wl bus-ID: 03:00.0 chip-ID: 14e4:4365
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 1004.2GB (0.6% used)
           ID-1: USB /dev/sda model: USB_Flash_Disk size: 4.0GB serial: 041101100002E97A-0:0
           ID-2: /dev/sdb model: ST1000LM024_HN size: 1000.2GB serial: S32XJ9DH149129
Partition: ID-1: / size: 2.9G used: 30M (2%) fs: overlay dev: N/A
           ID-2: swap-1 size: 4.20GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 25500
Info:      Processes: 178 Uptime: 17 min Memory: 850.1/3856.2MB Init: systemd v: 231 Gcc sys: 6.1.1
           Client: Shell (bash 4.3.461 running in xfce4-terminal) inxi: 2.3.1

tu peux déjà tenter la chose suivante

manjaro-chroot -a ( choisi 1 si une seule ligne )
mkinitcpio -P
exit ( quitte chroort *obligatoire*)
et redémarre
mkinitcpio me renvoie une erreur 'No presets found in /etc/mkinitcpio.d'

Fichier « /boot/vmlinuz-4.4-x86_64 » non disponible

#6Messageil y a 1 mois

En cherchant des infos sur chroot, je suis tombé sur ce topic en anglais https://bbs.archlinux.org/viewtopic.php?id=250486

Je me suis inspiré des réponses et j'ai fait :

manjaro-chroot -a
pacman -S linux 
pacman -S mkinitcpio
exit
J'ai redémarré et ça a marché.

Merci beaucoup pour vos réponses.

Répondre