Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

Samba KDE n'affiche pas la liste de ses partages à un client Xfce

#1Messageil y a 6 jours

Bonjour,
J'ai de longue date un poste nommé TOSHIBA sous Manjaro Xfce en IP dynamique (avec des partages réalisés sous thunar avec thunar-shares-plugin-gtk3).
Mon poste Manjaro KDE nommé H2-IMEDIAS1800 récemment installé en IP statique "voit" parfaitement la liste de ces partages et me permet d'y accéder via la liste des partages affichée dans Dolphin en y invoquant : smb://toshiba/
C'est dans l'autre sens que ça se gâte : la liste des partages déclarés dans KDE sous Dolphin avec kdenetwork-filesharing n'est pas visible depuis le poste Xfce, je suis obligé de spécifier précisément le partage auquel je veux accéder.
Par exemple, depuis Xfce :
smb://h2-imedias1800/ me renvoie l'erreur "L'obtention de la liste des partages a échoué : Argument invalide."
mais :
smb://h2-imedias1800/nom_du_partage/ me permet d'y accéder (j'ai juste à m'identifier)
Le comportement est le même en attaquant le poste KDE par son adresse IP...
Sous Xfce le pare-feu est réglé via gufw pour autoriser tous les appels entrants. Mais à ma connaissance aucun pare-feu n'est activé par défaut sous KDE (la liste des services activés n'y indique d'ailleurs ni iptables, ni ufw, comme activés, contrairement au poste Xfce)
Pour finir, j'ai exactement les mêmes fichiers smb.conf sur les deux machines :

[global]
	max log size = 1000
	usershare path = /var/lib/samba/usershare
	pam password change = yes
	map to guest = Bad Password
	server role = standalone server
	passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
	usershare allow guests = yes
	passdb backend = tdbsam
	force directory mode = 0070
	client min protocol = CORE
	security = user
	name resolve order = lmhosts bcast host wins
	log file = /var/log/samba/%m.log
	usershare owner only = yes
	guest account = nobody
	passwd program = /usr/bin/passwd %u
	obey pam restrictions = yes
	force create mode = 0070
	dns proxy = no
	os level = 20
	unix password sync = yes
	usershare max shares = 100
	workgroup = DOMICILE

[homes]
   comment = Home Directories
   browseable = no
   read only = yes
   create mask = 0700
   directory mask = 0700
   valid users = %S

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
La ligne 'client min protocol = CORE' permet aux deux postes Linux d'accéder aux partages d'une vieille station Windows XP.
Si quelqu'un voulait m'éclairer de ses lumières, ce serait sympa.

Samba KDE n'affiche pas la liste de ses partages à un client Xfce

#2Messageil y a 6 jours

attention , il y a maintenant un minium requis pour Samba pour la connexion ,
V2 ou V3 , on autorise plus la V1 en connexion ( pb lié aux failles de sécurités )

Samba KDE n'affiche pas la liste de ses partages à un client Xfce

#3Messageil y a 6 jours

stephane a écrit : il y a 6 jours attention , il y a maintenant un minium requis pour Samba pour la connexion ,
V2 ou V3 , on autorise plus la V1 en connexion ( pb lié aux failles de sécurités )
Ça n'explique pas pourquoi ça passe dans un sens et pas dans l'autre...

Samba KDE n'affiche pas la liste de ses partages à un client Xfce

#4Messageil y a 4 jours

Résolu par les manipulations suivantes sur la machine KDE !

Alors que iptables.service n'était pas activé et que ufw n'était pas installé, j'ai installé gufw, ce qui a installé sa dépendance ufw puis j'ai activé le service ufw.service :

sudo systemctl enable ufw.service
sudo ufw enable
Puis dans le profil 'Domestique" de l'interface graphique gufw j'activé le pare-feu (sur 'Entrant : refuser' et 'Sortant : Autoriser') et enfin inscrit la règle avancée "N'importe où AUTORISER ENTRÉE 192.168.1.0/24" sous le nom "Réseau local".
Un redémarrage des deux machines a suffi à gommer toutes les rugosités.

Étrange... :o
Quand j'avais installé le pare-feu sur la machine Xfce il y a deux ans, ça n'était absolument pas pour permettre d'accéder à ses partages, mais par simple paranoïa...
Répondre