Questions sur l'installation et la configuration de Manjaro Linux.

Message d'attente de 10 secondes

#21Messageil y a 1 an

Salut Erwan
Erwan a écrit :
il y a 1 an
Bonjour,

Il ne te reste plus qu'à éditer le fichier /etc/default/grub en remplaçant l'uuid de l'ancien swap par celle du nouveau et en supprimant l'uuid sur la deuxième ligne :wink:

Voilà ce que ça donnera une fois la modif effectuée :

[jean-xfce@jean-xfce ~]$ cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='Manjaro'
#GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=5554e3e3-a8e5-481e-9b32-c60095a1b096"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""
Ensuite on lance un sudo update-grub et peut-être reconstruire l'image ? :saispas: : mkinitcpio -p linux414
dans ton exemple la nouvelle ligne concernant le nouveau "swap" est commentée... : Normal ??
:saispas:

Message d'attente de 10 secondes

#22Messageil y a 1 an

:bjr: Bien vu, une erreur de ma part, surement ;)

Message d'attente de 10 secondes

#23Messageil y a 1 an

Ok ! donc pas de " # "
Je termine ce que je suis en train de faire et je modifie ça par la suite .
je te tiens au courant !
A+

Message d'attente de 10 secondes

#24Messageil y a 1 an

Oui, en fait ce n'est pas une erreur de ma part, j'ai pris le fichier que tu as posté puis je l'ai modifié en conséquence, sans m'aperçevoir que tu avais commenté la ligne. Ce qui générait l'erreur est bien l'uuid de la seconde ligne, la supprimer uniquement devrait suffire pour qu'elle n'apparaisse plus mais, vu que tu as un swap, autant le déclarer dans grub :sourire:

Message d'attente de 10 secondes

#25Messageil y a 1 an

:bjr:
Voilà j'ai fais l'opération et tout fonctionne nickel !
Sauf que je ne sais pas ce que j'ai fais mais j'ai du sans doute par erreur supprimé 2 lignes dans le grub qui sont les 2 lignes suivantes :

GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""
ma question: sont-elles importantes ? à mon avis non puisque au reboot ça a marché , mais bon, je n'en sais rien :saispas:

Dois je les remettre ?
Si oui pas de souci je peux ! Qu'en penses tu ?
voilà mon nouveau "grub "
GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=5554e3e3-a8e5-481e-9b32-c60095a1b096"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors. Used by normal and wallpaper
# modes only. Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
A ton avis ??
:merci:

Message d'attente de 10 secondes

#26Messageil y a 1 an

En fait il ne te manque que cette ligne (juste en dessous de celle de l'uuid) : GRUB_CMDLINE_LINUX=""
Cela ne devrait pas de te poser de souci mais, lors d'une mise à jour de grub tu risques de te retrouver à chaque fois avec un nouveau .pacnew
Perso, je collerai cette ligne dans grub, histoire d'avoir un grub conforme ;)

Message d'attente de 10 secondes

#27Messageil y a 1 an

Ok pas de soucis !
Problème résolu.
En tout cas un grand merci à toi pour ton aide .
Salut !
:merci::merci:

Répondre