Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

Réinstallation Grub possible ?

#1Messageil y a 7 mois

Bonsoir. :bjr:

J'ai une très mauvaise nouvelle (enfin pour moi !! ).
J'ai reçu par la poste une clé avec code pour une installation de Windows 10 provenant du Ministère des Finances belge où je travaille.
Donc, j'ai été obligé d'installer Windows pour le Taf (j'avais essayé en VB, et même en Vmware, mais impossible avec le noyau 4.19).
Étant donné que je possède 3 disques de 3 T0 + 1 SSD de 500 Go sur ma machine, je me suis dit : je vais installer Windows sur un seul disque (donc pas en dual-boot) et je pourrai démarrer ma Manjaro depuis Grub et Windows depuis le Bios.
Mais ma surprise fut telle que dès le démarrage, Grub n'apparaît plus.
Là, je pense à chrooter. Donc, depuis une Manjaro live, je suis le post : Vous n'avaez pas de console, on chroot.
Là, j'obtiens :

[manjaro@manjaro ~] sudo manjaro-chroot -a
 ==> detected systems:
 --> 0) ManjaroLinux
 ==> selected to mount [0-0]:
Et là, malheureusement, il refuse de chrooter.
Ma partition /boot (Manjaro) est sur /dev/sdc1, ma partition / est sur /dev/sdc2. /dev/sdc étant mon SSD.
Si je veux chrooter en montant /dev/sdc /mnt, il me retourne une erreur.
Alors, comment puis-je réinstaller grub pour l'avoir au démarrage et ne plus devoir lancer Manjaro depuis le bios ?
Je sais, le post est très long, mais j'ai voulu vous donner le plus de renseignements possibles.

Merci de vos réponses comme toujours très constructives. :bien

Réinstallation Grub possible ?

#2Messageil y a 7 mois

obelix1502 a écrit :
il y a 7 mois
Bonsoir. :bjr:
.....
Donc, j'ai été obligé d'installer Windows pour le Taf (j'avais essayé en VB, et même en Vmware, mais impossible avec le noyau 4.19).
.....
Merci de vos réponses comme toujours très constructives. :bien
On t'a répondu sur ce post :
viewtopic.php?f=20&t=10569&p=116678#p116678
pour installer Windows en VB !
Tu n'as pas employé les bons paquets !
Va voir les réponses et tu pourras installer ton Windows en VB !
je l'ai moi-même en Vb et sans problèmes !! Donc il n'y a aucune raison que ça ne marche pas !!

Réinstallation Grub possible ?

#3Messageil y a 7 mois

bonsoir
pas de sudo ...

tu démarre sur la clé USB ,
tu ouvre un terminal
et tu tape

manjaro-chroot -a
....
exit ( obligatoire ) 

Réinstallation Grub possible ?

#4Messageil y a 7 mois

Il est vrai que cela fonctionne sans sudo sauf que :

Si je ne monte pas toutes les partitions, le manjaro-chroot -a m'indique une erreur.
Par la suite il me dit lorsque je veux réinstaller Grub que le dosier /boot/efi n'est pas en EFI.
Or, mon /dev/sdc1, me montre ceci :

total 43748
drwxr-xr-x 4 root root     4096 01.01.1970 01:00 efi/
drwxr-xr-x 5 root root     4096 02.11.2018 22:24 grub/
drwxr-xr-x 2 root root     4096 25.10.2018 21:42 memtest86+/
-rw-r--r-- 1 root root    28160 26.10.2018 19:47 amd-ucode.img
-rw-r--r-- 1 root root 29281170 01.11.2018 14:34 initramfs-4.19-x86_64-fallback.img
-rw-r--r-- 1 root root  7933080 01.11.2018 14:33 initramfs-4.19-x86_64.img
-rw-r--r-- 1 root root  1747456 25.08.2018 10:35 intel-ucode.img
-rw-r--r-- 1 root root        0 21.10.2018 09:45 linux414-x86_64.kver
-rw-r--r-- 1 root root       21 28.10.2018 00:39 linux419-x86_64.kver
-rw-r--r-- 1 root root        0 21.10.2018 09:45 vmlinuz-4.14-x86_64
-rw-r--r-- 1 root root  5785456 28.10.2018 00:39 vmlinuz-4.19-x86_64
Et /boot/efi :

[bruno@bruno efi]$ ll
total 8
drwxr-xr-x 5 root root 4096 01.11.2018 15:28 EFI/
drwxr-xr-x 2 root root 4096 02.11.2018 21:40 uefi/
Puis EFI :

drwxr-xr-x 2 root root 4096 01.11.2018 15:28 boot/
drwxr-xr-x 2 root root 4096 01.11.2018 15:28 Manjaro/
drwxr-xr-x 4 root root 4096 02.11.2018 13:30 Microsoft/
je me pose la question : que fait donc Windows là ???

je l'ai installé sur un disque à part. Il ne devrait pas se trouver dans /dev/sdc1... (qui est ma partition boot,esp de Manjaro) :tetu!:tetu!

Réinstallation Grub possible ?

#5Messageil y a 7 mois

tu confonds répertoire /boot/efi
et UEFI
Par la suite il me dit lorsque je veux réinstaller Grub que le dosier /boot/efi n'est pas en EFI.

tu as démarré avec une option qui bascule UEFI en legacy ( a cause de l'install windows )

manjaro demande un UEFI sans les options Fastboot / Secure Boot / CSM , fastboot , etc ...

Réinstallation Grub possible ?

#6Messageil y a 7 mois

Mais dans le bios, je n'ai pas le secureboot activé, ni le CSM, le fastboot etc.
Alors... que faire ?

Réinstallation Grub possible ?

#7Messageil y a 7 mois

quelle commande as tu fait pour restaurer le grub ?

Réinstallation Grub possible ?

#8Messageil y a 7 mois

Voilà :

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

Réinstallation Grub possible ?

#9Messageil y a 7 mois

ok ,
as tu vérifié avec inxi -Fxxx que tu est bien en EFI uniquement ?

Réinstallation Grub possible ?

#10Messageil y a 7 mois

Je n'ai pas vérifié, mais je suis absolument sûr de n'avoir jamais rien installé en non-uefi ou en MBR si tu veux.

Voici le rapport :

[bruno@bruno ~]$ inxi -Fxxx
System:
  Host: bruno Kernel: 4.19.0-3-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.1 info: xfce4-panel 
  wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: ASUS product: All Series v: N/A 
  serial: <root required> 
  Mobo: ASUSTeK model: Z97-E v: Rev X.0x serial: <root required> 
  UEFI: American Megatrends v: 0706 date: 11/11/2015 
CPU:
  Topology: Quad Core model: Intel Core i5-5675C bits: 64 type: MCP 
  arch: Broadwell rev: 1 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24793 
  Speed: 3304 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 3304 2: 2970 
  3: 3107 4: 3152 
Graphics:
  Device-1: NVIDIA GM107 [GeForce GTX 750] vendor: ASUSTeK driver: nvidia 
  v: 410.73 bus ID: 01:00.0 chip ID: 10de:1381 
  Display: x11 server: X.Org 1.20.3 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA 410.73 
  direct render: Yes 
Audio:
  Device-1: Intel 9 Series Family HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8ca0 
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:0fbc 
  Device-3: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 1-4:2 chip ID: 046d:0843 serial: A03454AE 
  Sound Server: ALSA v: k4.19.0-3-MANJARO 
Network:
  Device-1: Intel Ethernet I218-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:19.0 chip ID: 8086:15a1 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: f0:79:59:93:f7:f0 
Drives:
  Local Storage: total: 8.46 TiB used: 1.21 TiB (14.2%) 
  ID-1: /dev/sda vendor: Seagate model: ST3000DM001-1CH166 size: 2.73 TiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: Z1F4EK4N rev: CC27 scheme: GPT 
  ID-2: /dev/sdb vendor: Western Digital model: WD3003FZEX-00Z4SA0 
  size: 2.73 TiB speed: 6.0 Gb/s rotation: 7200 rpm serial: WD-WMC1F0D1PKYH 
  rev: 1A01 scheme: GPT 
  ID-3: /dev/sdc vendor: Kingston model: SV300S37A240G size: 223.57 GiB 
  speed: 6.0 Gb/s serial: 50026B775A08F73D rev: BBF2 scheme: GPT 
  ID-4: /dev/sdd vendor: Western Digital model: WD3003FZEX-00Z4SA0 
  size: 2.73 TiB speed: 6.0 Gb/s rotation: 7200 rpm serial: WD-WMC1F0DC19NU 
  rev: 1A01 scheme: GPT 
  ID-5: /dev/sde type: USB vendor: TDK model: LoR TF10 size: 57.68 GiB 
  serial: 07074B3266D78652 rev: PMAP scheme: MBR 
Partition:
  ID-1: / size: 49.73 GiB used: 12.58 GiB (25.3%) fs: ext4 dev: /dev/sdc2 
  ID-2: /home size: 2.69 TiB used: 323.10 GiB (11.8%) fs: ext4 
  dev: /dev/sdb1 
  ID-3: swap-1 size: 12.30 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc3 
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A gpu: nvidia temp: 38 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 204 Uptime: 2h 15m Memory: 15.61 GiB used: 8.57 GiB (54.9%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 clang: 7.0.0 Shell: bash 
  v: 4.4.23 running in: xfce4-terminal inxi: 3.0.27 

Réinstallation Grub possible ?

#11Messageil y a 7 mois

alors sous manjaro ,
un update-grub devrait suffire

Réinstallation Grub possible ?

#12Messageil y a 7 mois

J'avais fait l'update grub, mais j'attendais que les maj de Windows sous VB se fassent.
J'ai redémarré.
C'est toujours Windows 10 qui démarre.
Mais lorsque je boote sur Manjaro depuis le bios, le menu de grub apparaît maintenant, ce qu'il ne faisait pas auparavant.
Ce qui n'arrange pas mes affaires. :gsourire::rigole::rigole:

Réinstallation Grub possible ?

#13Messageil y a 7 mois

Bonjour,
Il me semble que windows ne laisse pas faire comme ça, il garde la main sur le boot.
Il faut lui dire de chercher un autre bootmgr en ligne de commande:

bcdedit /set {bootmgr} path \EFI\Manjaro\grubx64.efi
Bonne journée
arzh

Réinstallation Grub possible ?

#14Messageil y a 7 mois

merci.

Mais qu'est-ce que cette commande bcdedit ?

Puis, dois-je passer cela en chroot ou en bash normal depuis Manjaro ?

Édit, après quelques recherches, c'est une commande Windows. (Là, je n'y connais rien !!)

Je passe cette commande (cmd) en mode administrateur depuis Windows 10 ?

Merci de l'aide apportée.

Réinstallation Grub possible ?

#15Messageil y a 7 mois

Re,
Oui c'est une commande de Windows, il me semble qu'il n'y a pas besoin, de toute façon s'il faut être admin
il te le dira.
la commande pour la liste des actions possible

bcdedit /v
la commande pour annuler la changement de bootmgr (au cas ou)

bcdedit /deletevalue {bootmgr} path \EFI\Manjaro\grubx64.efi

Réinstallation Grub possible ?

#16Messageil y a 7 mois

Merci à tous mon problème est réglé.
En fait, le sudo update-grub a suffit.
Il suffisait ensuite de changer mes options de démarrage dans le bios et d'indiquer Manjaro en premier ordre de boot pour que Grub réapparaisse au redémarrage.
Et OSprober a aussi tenu compte de Windows 10 installé par mon boulot. :gsourire:

Répondre