Questions sur l'installation et la configuration de Manjaro Linux.

Restauration Grub bloquée

#1Messageil y a 2 mois

Bonjour,

(Je précise d'entrée que le navigateur NetSurf que j'utilise actuellement ne semble pas autoriser l'option pour afficher le code, je fais donc des copier/coller...)

Suite à une MAJ, Grub est planté (invite "Grub Rescue").
J'ai suivi la procédure du wiki anglophone, à savoir:

Booter sur un live USB Manjaro XFCE minimal, puis:

sudo pacman -S mhwd-chroot 
puis
sudo mhwd-chroot
Je suis donc en chroot.

L'UID de ma partition système s'affiche.
Mais pas de choix à rentrer.

Manuellement je peux également chrooter.

J'installe les paquets suivants:

sudo pacman -S mtools os-prober
La commande fdisk -l me renvoie:

Périphérique   Début       Fin  Secteurs Taille Type
/dev/sdb1    2099200 117226271 115127072  54,9G Système de fichiers Linux
/dev/sdb2       2048   2099199   2097152     1G Système EFI
Je suis donc la procédure UEFI:

[manjaro /]# sudo mkdir /boot/efi
mkdir: impossible de créer le répertoire « /boot/efi »: Le fichier existe
Bon s'il existe, tant mieux, je ne comprends pas mais bon...

sudo mount /dev/sdb2 /boot/efi

[manjaro /]# sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
Installation pour la plate-forme x86_64-efi.
EFI variables are not supported on this system.
EFI variables are not supported on this system.
Installation terminée, sans erreur.
Le Wiki prévient du message "EFI variables are not supported on this system." et suggère de sortir de chroot et de taper:

sudo modprobe efivarfs
puis en chroot:

mount -t efivarfs efivarfs /sys/firmware/efi/efivars
Je fais donc:

Exit
[manjaro manjaro]# sudo modprobe efivarfs
modprobe: FATAL: Module efivarfs not found in directory /lib/modules/4.19.0-3-MANJARO
[manjaro manjaro]# sudo pacman -S efivar (le paquet s'installe)

[manjaro manjaro]# sudo modprobe efivarfs
modprobe: FATAL: Module efivarfs not found in directory /lib/modules/4.19.0-3-MANJARO
Et là je bloque. J'ai évidemment dû raté un truc mais je ne sais pas quoi.

EDIT: j'ai redémarré, je retente la procédure pour la xième fois mais le dernier message a changé (à vrai dire il était comme ça dans les 20 premières tentatives):

mount -t efivarfs efivarfs /sys/firmware/efi/efivars
mount: /sys/firmware/efi/efivars: le point de montage n'existe pas.
Modifié en dernier par Blasted_pingin le 20 Nov 2018, 15:09, modifié 1 fois.

Restauration Grub bloquée

#2Messageil y a 2 mois

bonsoir

alors tu quitte cette procédure manuelle ( mhwd-chroot ) qui demande différentes étapes intermédiaires
, avec Exit

et tu relance la procédure ( à partir de la cle USB )
avec manjaro-chroot -a qui est automatique
;-)
Modifié en dernier par stephane le 20 Nov 2018, 19:49, modifié 2 fois.

Restauration Grub bloquée

#3Messageil y a 2 mois

Bonjour.

sudo pacman -S mhwd-chroot 
Normalement, mhwd-chroot est déjà installé par défaut sur les live sessions.

sudo mhwd-chroot
Je suis donc en chroot.

L'UID de ma partition système s'affiche.
Mais pas de choix à rentrer.
Il suffit de rajouter l'option -a "auto"

sudo manjaro-chroot -a
Edit: grillé :salut:
La commande fdisk -l me renvoie:

Périphérique   Début       Fin  Secteurs Taille Type
/dev/sdb1    2099200 117226271 115127072  54,9G Système de fichiers Linux
/dev/sdb2       2048   2099199   2097152     1G Système EFI
Je suis donc la procédure UEFI:

Il devrait au moins apparaître un /dev/sda....

Je pense que tu n'as pas installé sur la bonne cible :saispas:

Restauration Grub bloquée

#4Messageil y a 2 mois

[manjaro@manjaro ~]$ manjaro-chroot -a
==> Mounting (ManjaroLinux) [/dev/sdb1]
--> mount: [/mnt]
--> mount: [/mnt/home]
--> mount: [/mnt/boot/efi]


Et du coup je fais quoi après? je suis un peu perdu là.

Restauration Grub bloquée

#5Messageil y a 2 mois

alors

manjaro-chroot -a ( selection de la distribution 1 si unique )
*/ cas EFI
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

*/cas Bios 
grub-install --recheck /dev/sdN ( N= lettre du disque )

exit ( quitter chroot)
et redemarrer

Restauration Grub bloquée

#6Messageil y a 2 mois

la commande me renvoie ça:

[manjaro /]# manjaro-chroot -a
==> ERROR: You can't mount 0!

Restauration Grub bloquée

#7Messageil y a 2 mois

Si j'essaie de poursuivre:

[manjaro /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
Installing for x86_64-efi platform.
EFI variables are not supported on this system.
EFI variables are not supported on this system.
Installation finished. No error reported.

Restauration Grub bloquée

#8Messageil y a 2 mois

Blasted_pingin a écrit :
il y a 2 mois
la commande me renvoie ça:

[manjaro /]# manjaro-chroot -a
==> ERROR: You can't mount 0!
il faut saisir 1 !

Restauration Grub bloquée

#9Messageil y a 2 mois

Blasted_pingin a écrit :
il y a 2 mois
la commande me renvoie ça:

[manjaro /]# manjaro-chroot -a
==> ERROR: You can't mount 0!
Essaies

sudo manjaro-chroot  -a

mdp manjaro

Restauration Grub bloquée

#10Messageil y a 2 mois

Blasted_pingin a écrit :
il y a 2 mois
Si j'essaie de poursuivre:

[manjaro /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
Installing for x86_64-efi platform.
EFI variables are not supported on this system.
EFI variables are not supported on this system.
Installation finished. No error reported.
j’espère que tu n'a pas cassé la clé USB !

Restauration Grub bloquée

#11Messageil y a 2 mois

Non l'erreur est la même.

[manjaro /]# sudo manjaro-chroot  -a
==> ERROR: You can't mount 0!
La clé USB ne doit pas être cassée puisque l'erreur est là depuis des heures et que je reboote dessus.

[/quote]

il faut saisir 1 !
[/quote]

Je le saisis où le 1?

Restauration Grub bloquée

#12Messageil y a 2 mois

alors la question EST importante :
tu as fait 2 fois manjaro-chroot -a
ou BIEN tu as correctement quitter par exit
avant de le relancer !

Restauration Grub bloquée

#13Messageil y a 2 mois

La première fois j'ai correctement quitté en tapant "exit".
Suite au message disant de faire "sudo manjaro-chroot -a" alors que je venais de rechrooter, je l'ai donc tapé une seconde fois en étant déjà chrooté.

Restauration Grub bloquée

#14Messageil y a 2 mois

il n'y a qu'un seul chroot
exit et relance le terminal

vérifie aussi avec inxi -Fxxx
tu as bien démarré correctement en EFI only
Modifié en dernier par stephane le 19 Nov 2018, 22:33, modifié 1 fois.

Restauration Grub bloquée

#15Messageil y a 2 mois

On peut récapituler la procédure entière?

Je ne comprends pas le principe de la manoeuvre:

[manjaro@manjaro ~]$ sudo manjaro-chroot -a
==> Mounting (ManjaroLinux) [/dev/sdb1]
 --> mount: [/mnt]
 --> mount: [/mnt/home]
 --> mount: [/mnt/boot/efi]
[manjaro /]# exit
exit
 --> umount: [/mnt/boot/efi]
 --> umount: [/mnt/home]
 --> umount: [/mnt]
[manjaro@manjaro ~]$
Je monte les partitions, je les démonte, je sors et je relance et quoi?
Modifié en dernier par Blasted_pingin le 19 Nov 2018, 22:33, modifié 1 fois.

Restauration Grub bloquée

#16Messageil y a 2 mois

Je crois que tu t’emmêles un peu les pinceaux !

Il faut booter sur la clé usb et là faire le chroot
Tu ne peux pas chrooter sur un système qui est déjà chrooter

Quand tu démarres sur la clé USB tu es sur le système qui est installé sur la clé USB.t Si tu installes des paquets (via pacman), tu les installes sur la clé USB
Quand tu "chroot" : tu rentres sur le système qui est sur ton disque dur. Les opérations que tu fais se font sur le disque dur.

Courage !!

Restauration Grub bloquée

#17Messageil y a 2 mois

Je plussoie: je suis complètement largué sur les manips à faire.

J'ai compris la différence entre travailler en chrooté ou en live mais je ne comprends toujours pas la marche à suivre.
Je veux juste réparer le GRUB.

Restauration Grub bloquée

#18Messageil y a 2 mois

on reprends :
demarrage clé USB
ouvrir le terminal
vérifier le demarrage EFI ( inxi -Fxxx )
tu va restaurer le grub

manjaro-chroot -a ( selection de la distribution 1 si unique , tu as accès aux partitions de la distribution)
pacman -Syyu ( vérifie versions + accès dépôts )
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
( fourni un retour si le moindre problème apparaît en retour , TOUT doit être OK )
exit ( quitter chroot)
puis reboot

Restauration Grub bloquée

#19Messageil y a 2 mois

Merci.
Je viens de redémarrer sur la clé pour faire ça au propre.

manjaro@manjaro ~]$ inxi -Fxxx
System:
  Host: manjaro Kernel: 4.19.0-3-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.1 info: xfce4-panel 
  wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Notebook product: W230ST v: N/A 
  serial: <root required> Chassis: type: 9 serial: <root required> 
  Mobo: Notebook model: W230ST serial: <root required> 
  BIOS: American Megatrends v: 4.6.5 date: 09/12/2013 
Battery:
  ID-1: BAT0 charge: 42.4 Wh condition: 43.2/62.2 Wh (70%) volts: 12.9/11.1 
  model: Notebook BAT type: Li-ion serial: 0001 status: Charging 
CPU:
  Topology: Dual Core model: Intel Core i5-4300M bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20760 
  Speed: 955 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 898 2: 898 
  3: 899 4: 898 
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics 
  vendor: CLEVO/KAPOK driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0416 
  Device-2: NVIDIA GK106M [GeForce GTX 765M] vendor: CLEVO/KAPOK 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:11e2 
  Display: x11 server: X.Org 1.20.3 driver: intel,nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa tty: N/A 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.2.3 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  chip ID: 8086:0c0c 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:8c20 
  Sound Server: ALSA v: k4.19.0-3-MANJARO 
Network:
  Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: e000 
  bus ID: 03:00.0 chip ID: 8086:08b1 
  IF: wlp3s0 state: up mac: 0c:8b:fd:6c:2d:7a 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: CLEVO/KAPOK driver: r8169 v: kernel port: d000 bus ID: 04:00.1 
  chip ID: 10ec:8168 
  IF: enp4s0f1 state: down mac: 00:90:f5:ed:03:9b 
Drives:
  Local Storage: total: 994.63 GiB used: 43.3 MiB (0.0%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm serial: JG40006EG4HEUC 
  rev: A3B0 scheme: MBR 
  ID-2: /dev/sdb vendor: Intel model: SSDMCEAC060B3 size: 55.90 GiB 
  speed: 6.0 Gb/s serial: CVLI302500MB060K rev: LLLi scheme: GPT 
  ID-3: /dev/sdc type: USB model: USB DISK 2.0 size: 7.21 GiB 
  serial: 070158316A276A55 rev: PMAP scheme: MBR 
Partition:
  ID-1: / size: 5.78 GiB used: 43.3 MiB (0.7%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 57.0 C mobo: N/A gpu: nouveau temp: 49 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 196 Uptime: 2m Memory: 7.71 GiB used: 743.9 MiB (9.4%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: xfce4-terminal inxi: 3.0.27

Restauration Grub bloquée

#20Messageil y a 2 mois

Maintenant tu envoies la commande de chroot

Répondre