Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

[Abandon] samba me pose problème...

#1Messageil y a 2 semaines

Bonjour à tous

Possédant un NAS synologie, l'utilisation avec NFS est une galère car l'utilisateur n'est pas reconnu en tant que tel ce qui m'empêche d'avoir les droits sur le dossier partagé mais uniquement pour les sous dossier :
par exemple dans le dossier "Pym" crée sur le NAS je ne peux que lire. Par contre le dossier "Quotidien" dans ce même dossier "Pym" est accéssible aussi en écriture. c'est bien connu y copris par les techs de Synologie, et il n'y a pas de solution facile.
Donc j'ai voulue réutiliser Samba, et là problème. J'ai pourtant suivi les indications trouvé sur ArchLinux mais aussi dans ce forum (trucs et astuces). et pourtant....

Voici le hic :

$ smbclient -L 192.168.1.10
Unable to initialize messaging context
Enter WORKGROUP\pymmanjaro's password: 
session setup failed: NT_STATUS_LOGON_FAILURE
j'ai tentré de modifier le mot de passe dans Samba via l'utilitaire Samba Server Configuration Tool . Sans succès malgré un redémarrage de la machine.

Sur ma précédente distribution (Ubuntu) je n'avais aucun soucis, j'obtenais la liste des dossiers partagés sur mon réseau. avec Manjaro, impossible.
Et hélas pour moi, tout ce que j'ai trouvé sur le web...est en anglais.
L'un d'entre vous peut il m'aider ? Merci
Modifié en dernier par pymlinux le 02 Fév 2019, 16:41, modifié 1 fois.

[Abandon] samba me pose problème...

#2Messageil y a 2 semaines

Je continue sur mes investigations, car ça devient compliqué et je ne veux pas retourner sur une autre distribution. :saispas:

J'ai fait ceci

systemctl restart samba
Job for samba.service failed because the control process exited with error code.
See "systemctl status samba.service" and "journalctl -xe" for details.
[PC-Pym ~]# systemctl status samba.service
● samba.service - Samba AD Daemon
   Loaded: loaded (/usr/lib/systemd/system/samba.service; disabled; vendor pres>
   Active: failed (Result: exit-code) since Tue 2019-01-29 13:27:19 CET; 20s ago
     Docs: man:samba(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 8297 ExecStart=/usr/bin/samba --foreground --no-process-group $SAMBA>
 Main PID: 8297 (code=exited, status=1/FAILURE)
   Status: "daemon failed to start: Samba detected misconfigured 'server role' >
    Error: 22 (Argument invalide)

janv. 29 13:27:19 PC-Pym samba[8297]: root process[8297]:   Copyright Andrew Tr>
janv. 29 13:27:19 PC-Pym samba[8297]: root process[8297]: [2019/01/29 13:27:19.>
janv. 29 13:27:19 PC-Pym samba[8297]: root process[8297]:   At this time the 's>
janv. 29 13:27:19 PC-Pym samba[8297]: root process[8297]:   'server role = acti>
janv. 29 13:27:19 PC-Pym samba[8297]: root process[8297]:   You should start sm>
janv. 29 13:27:19 PC-Pym samba[8297]: root process[8297]: [2019/01/29 13:27:19.>
janv. 29 13:27:19 PC-Pym samba[8297]: root process[8297]:   exit_daemon: STATUS>
janv. 29 13:27:19 PC-Pym systemd[1]: samba.service: Main process exited, code=e>
janv. 29 13:27:19 PC-Pym systemd[1]: samba.service: Failed with result 'exit-co>
janv. 29 13:27:19 PC-Pym systemd[1]: Failed to start Samba AD Daemon.
Très clair, n'est-ce pas ? et encore ce n'est que le début.
En utilisant reverso pour essayer de traduire, il semblerait que le serveur est mal configuré..... Je vais essayer de reprendre l'installation de samba.

On conitnue la rigolade

sudo smbpasswd -a root
New SMB password:
Retype new SMB password:
Added user root.
et rebelote

sudo smbclient -L 192.168.1.10
Enter WORKGROUP\root's password: 
session setup failed: NT_STATUS_LOGON_FAILURE
De mieux en mieux

 sudo systemctl restart smbd
Failed to restart smbd.service: Unit smbd.service not found.
J'ai tenté de suivre ce tuto
https://manjaro.site/install-samba-arch-linux-2017/....

Je sens bien un gros craquage :tetu!:tetu!

pour infos

 systemctl enable smbd.service
Failed to enable unit: Unit file smbd.service does not exist.
ben voyons..... à quoi sert d'installer les paquets si Manjaro me répond que ça n'existe pas. Pas facile tout ça !
Merci d'éditer les messages pour ajout plutôt que de les empiler les uns après les autres. :wink:
administration/modération
Modifié en dernier par Erwan le 29 Jan 2019, 15:43, modifié 2 fois.

[Abandon] samba me pose problème...

#3Messageil y a 2 semaines

bonjour

je ne suis pas sûr de comprendre ce que tu fais ...
Normalement tout réglage est sur ton nas uniquement
smbpasswd et systemctl restart samba n'a rien à faire sur la manjaro qui elle n'est que client

---

Depuis quelques temps le service est smb et non plus smbd, comme dit plus haut c'est uniquement pour transformer ta manjaro en serveur de fichiers :saispas:

[Abandon] samba me pose problème...

#4Messageil y a 2 semaines

Bonjour papajoke et merci

En fait j'essaye de comprendre ce qui se passe et surtout pourquoi un sudo smbclient -L 192.168.1.10 me rejette alors que sur Ubuntu par exemple, je liste sans problème mes partages sur le NAS.

De plus mon fstab, pourtant opérationnel sur une Xubuntu, ne fonctionne pas sur Manjaro.

Bref je ne sais plus trop quoi faire, je cherche mais je tombe trop souvent sur des trucs en Anglais qui, bien souvent, sont trop ancien.

[Abandon] samba me pose problème...

#5Messageil y a 2 semaines


[Abandon] samba me pose problème...

#6Messageil y a 2 semaines

Hélas rien n'y fait ! Que ce soit pour root ou l'utilisateur et je ne pense pas avoir d'erreur :

$ sudo smbpasswd -a pymmanjaro
[sudo] Mot de passe de pymmanjaro : 
New SMB password:
Retype new SMB password:

$ sudo smbpasswd -a root
New SMB password:
Retype new SMB password:

$ sudo smbclient -L 192.168.1.10
Enter WORKGROUP\root's password: 
session setup failed: NT_STATUS_LOGON_FAILURE
j'ai réussi à faire différemment pour connaitre mes dossiers partagés, mais ça me turlupine....

Répondre