Questions sur l'installation et la configuration de Manjaro Linux.

Pamac

#1Messageil y a 6 ans

:bjr:

J'ai un truc bisard avec Pamac. Je l'ai installé sans soucis, l'entrée figure correctement dans le menu mais poas moyen de la lancer. Via le menu il ne se passe rien et via le terminal j'ai en sortie :

checking updates
set-icon
Updates available
check updates done

mais rien ne s'affiche. Une idée, je suis sous E17 pour info.
Merci
Dernière modification par andson le 07 Mar 2013, 06:54, modifié 1 fois.

Pamac

#2Messageil y a 6 ans

:bjr: andson

La commande est : pamac-tray

Pamac

#3Messageil y a 6 ans

:bjr: ewolnux

Oups !! J'vais oublié une p'tite ligne;

[andson@manjaro ~]$ pamac-tray
checking updates
set-icon
Updates available
check updates done

Pamac

#4Messageil y a 6 ans

:bjr:

Ben, tu le mets dans la liste des applis lancées au démarrage ?

Pamac

#5Messageil y a 6 ans

:bjr:

C'est ce que j'ai fait :
Configuration --> Tout --> Applis --> Apllications au démarrage --> Applications --> Pamac Tray Icon --> Ajouter --> Appliquer.
Mais cela ne marche pas . :maisnon:

Pamac

#6Messageil y a 6 ans

Moui, avec E17...

Que donne pamac_updater ?

Pamac

#7Messageil y a 6 ans

Salut,

A tout hasard, aurais-tu le module E17 "zone de notification" désactivé ? sais-t-on jamais...

A+

Pamac

#8Messageil y a 6 ans

Désolé pour ces apparitions par intermittence ... trop occupé les retraités :gsourire:
@ fassil
J'ai essayé avec le module activé/désactivé ça ne change rien
Esclapion a écrit :Moui, avec E17...

Que donne pamac_updater ?

Avec pamac-updater pamac est lancé mais refuse de faire les mises à jour pour car je n'ai pas les droits nécessaires.

[andson@manjaro ~]$ pamac-updater
get handle
get handle
0 local alpm.Package("alsa-lib-1.0.26-1-x86_64")
0 local alpm.Package("dbus-glib-0.100-1-x86_64")
0 local alpm.Package("desktop-file-utils-0.21-1-x86_64")
0 local alpm.Package("gtk2-2.24.15-1-x86_64")
0 local alpm.Package("hunspell-1.3.2-2-x86_64")
0 local alpm.Package("libevent-2.0.21-2-x86_64")
0 local alpm.Package("libnotify-0.7.5-1-x86_64")
0 local alpm.Package("libvpx-1.1.0-1-x86_64")
0 local alpm.Package("libxt-1.1.3-1-x86_64")
0 local alpm.Package("mime-types-8-1-any")
0 local alpm.Package("mozilla-common-1.4-3-any")
0 local alpm.Package("nss-3.14.1.1.93-1-x86_64")
0 local alpm.Package("sqlite-3.7.15.2-1-x86_64")
0 local alpm.Package("startup-notification-0.12-3-x86_64")
[] []
get handle
[andson@manjaro ~]$

Pamac

#9Messageil y a 6 ans

Euh, sudo ? :clindoeil:

Pamac

#10Messageil y a 6 ans

D"accord via le terminal, pour le lancement via le menu ? :triste:
Edit : Même avec sudo il y a un blème signalé dans ma langue de prédilection ... :colère:

Error:
Traceback (most recent call last):
  File "/usr/lib/python3.3/site-packages/pamac/pamac-daemon.py", line 287, in Commit
    t.commit()
alpm.error: transaction failed, pm_errno 27 (transaction not prepared)

Pamac

#11Messageil y a 6 ans

Un lanceur ? Je ne connais pas E17, mais ça doit être comme les copains.

Pamac

#12Messageil y a 6 ans

python, et surtout python 3 est installé ?

Pamac

#13Messageil y a 6 ans

Apparemment non, le lanceur est bien présent par contre il n'y a pas moyen (ou je n'ai pas trouvé) d'accéder à ses propriétés. Mais à mon avis ce n'est pas le problème car si je lance une appli qui demande les droits de root E17 me le signale tandis que la je n'ai rien, c'est comme si je cliquais dans le vide.

Question subsidiaire :
Pourquoi Pacman-gui me signale que mon système est à jour alors que pamac me propose la mise à jour de logiciels ?

Pamac

#14Messageil y a 6 ans

Esclapion a écrit :python, et surtout python 3 est installé ?


Oups !! je vérifie.

Pamac

#15Messageil y a 6 ans

Oui

Pamac

#16Messageil y a 6 ans

Voila la partie de code concernée la ligne 287 correspond à t;commit() je n'y connait pas grand chose mais apparemment il s'agit d'un problème de connection du à policykit.

@dbus.service.method('org.manjaro.pamac', '', 's', sender_keyword='sender', connection_keyword='connexion')#, async_callbacks=('success', 'nosuccess'))
   def Commit(self, sender=None, connexion=None):#success, nosuccess, sender=None, connexion=None):
      global t
      global error
      error = ''
      if self.policykit_test(sender,connexion,'org.manjaro.pamac.commit'):
         try:
            t.commit()
            #success('')
         except pyalpm.error:
            error = traceback.format_exc()
            #nosuccess(error)
         except dbus.exceptions.DBusException:
            pass
         finally:
            self.CheckUpdates()
            return error

Pamac

#17Messageil y a 6 ans

Là, à part Guinux, pour te dépanner... :sos:

Pamac

#18Messageil y a 6 ans

as-tu un autre environnement que E17 installé pour faire un essai ?
comment lances-tu E17 ?

Pamac

#19Messageil y a 6 ans

:bjr:

Sous XFCE et OpenBox pas de soucis.
Pour E17 j'ai installe manjaro-net puis les paquets E17 via yaourt, comme c'est le seul bureau sur cette partition je le lance de manière tout à fait classique.
Pamac et d'ailleurs lancé au démarrage puisque sous le logo e17 mors de la phase de démarrage je peux clairement lire Starting pamac trau icon

Petit rappel du problème : :gsourire:

1) Pamac ne démarre pas via le menu

2) La commande pamac-tray me renvoie la sortie ci-dessous mais ne lance pas le logiciel
[andson@manjaro ~]$ sudo pamac-tray
[sudo] password for andson:
Sorry, try again.
[sudo] password for andson:
checking updates
set-icon
Updates available
check updates done

3) Pour la commande Pamac-updater le problème signalé plus haut semble concerner uniquement seamonkey, ce matin j'ai fait un nouveau test et j'ai deux mises à jour proposées la première concernait le firmeware et c'est très bien déroulée la deuxième concernait seamonkey et la j'ai à nouveau mon message d'erreur.
Error:
Traceback (most recent call last):
File "/usr/lib/python3.3/site-packages/pamac/pamac-daemon.py", line 287, in Commit
t.commit()
alpm.error: transaction failed, pm_errno 27 (transaction not prepared)

Pamac

#20Messageil y a 6 ans


Répondre