Questions sur l'installation et la configuration de Manjaro Linux.

Grub

#1Messageil y a 6 ans

:bjr:
Suite à une mise à jour de ce matin je me retrouve avec un Grub très, très, très lent, entre l'affichage du Welcome Grub et l'affichage du menu de boot il s'écoule bien une dizaine de minutes,( c'est bien simple si Linux est réputé pour tout faire même le café maintenant il me donne même le temps de le boire :rigole: ) je rigole mais ce n'est pas marrant.
J'ai déjà eu un mauvais pressentiment à la fin de la mise à jour, il fallait bien cinq minutes entre la détection de chaque partitions Linux présentes sur mes disque durs (3), par contre XP a été détecté en 2 secondes :gsourire:
Pour info : noyau 3.7.10
Dernière modification par andson le 04 Mar 2013, 15:14, modifié 1 fois.

Grub

#2Messageil y a 6 ans

salut andson

Essaie de passer au 3.8 (ce que j'ai fait). Voir si c'est toujours pareil.

Grub

#3Messageil y a 6 ans

Ok

Grub

#4Messageil y a 6 ans

:bjr:

Suite à une mise à jour de ce matin je me retrouve avec un Grub très, très, très lent, entre l'affichage du Welcome Grub et l'affichage du menu de boot il s'écoule bien une dizaine de minutes


Je n'ai pas de message Welcome Grub, directement le menu. Quel est le Linux qui gère le Grub, c'est bien Manjaro ?

Grub

#5Messageil y a 6 ans

Esclapion a écrit ::bjr:

Suite à une mise à jour de ce matin je me retrouve avec un Grub très, très, très lent, entre l'affichage du Welcome Grub et l'affichage du menu de boot il s'écoule bien une dizaine de minutes


Je n'ai pas de message Welcome Grub, directement le menu. Quel est le Linux qui gère le Grub, c'est bien Manjaro ?

J'ai toujours eu ce message de bienvenue avec la version du Grub installé qui s'affiche. Ton PC est peut-être trop rapide l'affichage dure maxi 2s :gsourire:
Pour en revenir à mon soucis c'est bien Manjaro qui gère mon Grub. Pour te donner une idée le temps passé entre mon dernier message et celui-ci c'est le temps qu'il a fallut pour au menu pour s'afficher :rendre: (à déduire le temps d'installer le nouveau kernel, autant dire pas grand chose)
Peut-être repasser au noyau 3.7.9 ? Mais la je ne connais pas la ligne de commande.

Grub

#6Messageil y a 6 ans

Pourrais tu nous passer la ligne GRUB_CMDLINE_LINUX_DEFAULT de ton /etc/default/grub, à tout hasard ?

Parce que là, le noyau ne joue pas, c'est uniquement un pb de grub. :saispas:

C'est avant Manjaro, qui ne rentre en jeu que lorsqu'une entrée est choisie.

Grub

#7Messageil y a 6 ans

Avec un peu de retard :desole:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=/dev/disk/by-uuid/b6592244-6319-48d9-aa9a-df31193a6790

J'ai vérifié l'UUID ne correspond à aucune de mes partitions je les ai toutes vérifiées a part les swap. Un autre truc qui me chiffonne c'est le message ci-ssous

(Half new UUID - will be randomly generated)

je ne me souviens pas avoir déjà vue ce type de message sur cette partition. C'est sur ce MBR que j'ai installé Grub.
Dernière modification par andson le 02 Mar 2013, 19:39, modifié 1 fois.

Grub

#8Messageil y a 6 ans

A-tu essayé ( sudo update-grub ) ?
si cela ne fonctionne pas :
voici mon grub ( /etc/default/grub )
========================================
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-uuid/8c79e610-d698-4552-80e8-0d4e41020435"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors. Used by normal and wallpaper
# modes only. Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Grub

#9Messageil y a 6 ans

:salut:
Oui j'ai réinstallé Grub sur le MBR et fait la mise à jour mais sans succès.
A part le n° de l'UUID (encore heureux ... :gsourire: ) tout correspond

Grub

#10Messageil y a 6 ans

Et il correspond bien à ton swap, cet UUID ?

Grub

#11Messageil y a 6 ans

Oui il correspond bien à la partition swap, je suppose que la solution consiste à mettre à la place l'UUID de la partition / de Manjaro. Mais sais tu d'où vient l'erreur ?

Grub

#12Messageil y a 6 ans

Non, il faut le laisser sur le swap, ça c'est bon.

Il y a une possibilité de problème matériel. :triste: As-tu connecté récemment qqch (DDE, imprimante, etc...) ?

Grub

#13Messageil y a 6 ans

Non je n'ai rien installé côté matériel. Par contre lors de la mise à jour un petit détail m'a intrigué. Normalement la mise à jour se termine par l'installation de Grub, or aujourd'hui la mise à jour c'est terminé par la mise à jour de pamac.

Edit: Peux tu m'expliquer en quelques mots en quoi Grub est concernée par la partition swap ?

Grub

#14Messageil y a 6 ans

As-tu essayé depuis de faire un grub-install /dev/sda (ou sdX, ça dépend de ta config) depuis Manjaro ?

Et il faut être paient, ça peut prendre une ou deux minutes.

Grub

#15Messageil y a 6 ans

Oui ce matin, je vais re-tenter le coup donc si tu n'as pas de nouvelles d'ici quelques minutes on se retrouve demain pour l'apéro :rigole:

Grub

#16Messageil y a 6 ans

andson a écrit :Oui ce matin, je vais re-tenter le coup donc si tu n'as pas de nouvelles d'ici quelques minutes on se retrouve demain pour l'apéro:rigole:

A quelle heure :rigole:

Grub

#17Messageil y a 6 ans

Cinquante sept minutes, peut mieux faire ... (ça me rappel quelque chose ... :gsourire: )
Désolé pour l'apéro... Une mirabelle ? :rigole:

Grub

#18Messageil y a 6 ans

Bon assez joué, même la sélection des différentes entrées du menu se fait à une lenteur désespérante. Je vais télécharger la dernière iso xfce et refaire une install ça ira nettement plus vite. M'embête seulement de ne pas en connaitre la raison. :triste:

Grub

#19Messageil y a 6 ans

Pour l'uuid correspondant à la swap, associée à l'option "resume", ça permet de conserver en mémoire l' OS lancée au précédent démarrage - quand il y a plusieurs distributions installées - , et de la proposer par défaut donc en démarrage auto si une autre n'est pas choisie dans le délai GRUB_TIMEOUT=5 de 5 sec p.ex..
Mes dernières lenteurs de démarrage liée au matériel connecté.étaient dues la présence d'une clef USB au formatage mal reconnu, et la lenteur venait alors du bios, avant le départ de grub, une fois grub lancé, il agissait normalement

Grub

#20Messageil y a 6 ans

waitnsea a écrit :Pour l'uuid correspondant à la swap, associée à l'option "resume", ça permet de conserver en mémoire l' OS lancée au précédent démarrage - quand il y a plusieurs distributions installées - , et de la proposer par défaut donc en démarrage auto si une autre n'est pas choisie dans le délai GRUB_TIMEOUT=5 de 5 sec p.ex..


Bonjour

Il me semble que ce qui permet de lancer par défaut le dernier OS sélectionné au précédent boot (quand plusieurs OS), c'est plutôt dans /etc/default/grub :

GRUB_DEFAULT=saved
...
...
...
...

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

Répondre