Questions sur l'installation et la configuration de Manjaro Linux.

Grub

#21Messageil y a 7 ans

waitnsea a écrit :Mes dernières lenteurs de démarrage liée au matériel connecté.étaient dues la présence d'une clef USB au formatage mal reconnu, et la lenteur venait alors du bios, avant le départ de grub, une fois grub lancé, il agissait normalement


Merci pour les infos. Mon problème est différent, la lenteur vient après le lancement de Grub, comme je l'ai dit plus haut, Grub démarre et affiche son petit message de bienvenue avec son n° de version, puis plus rien avant ... 57 minutes mon dernier record, et même la pour choisir une entrée parmis les trois présente faut pas être nerveux. J'ai téléchargé la dernière version XFCE tout c'est déroulé normalement mais à l'installe du boot loader j'avais compris, le temps de détecter les différentes partitions,largement le temps de faire ma toilette et au démarrage même chanson. Pourtant ma config est toujours la même et je n'avais aucun soucis avant la dernière mise à jour.

Grub

#22Messageil y a 7 ans

Décidement rien ne marche. J'ai refais l'install, mis le grub sur une autre unitée, débrancher tout ce qui n'était pas nécessaire pour le démarrage, vérifié toutes les connexions rien ne marche. J'ai même installé LinuxMint pensant à une défaillance de l'installateur de Manjaro, même problème. Je ne sais plus quoi faire. :sos:
Un virux ?

Grub

#23Messageil y a 7 ans

En installant le Grub depuis Mint, par un grub-install toujours, tu as le même problème ?

Si oui, c'est un peu inquiétant.

Grub

#24Messageil y a 7 ans

Je vais peut-être raconté une bêtise (ou une co******, au choix, mais est-ce que ça pourrait venir d'une barrette mémoire ?

Peut-être faire un test barrette ?

Grub

#25Messageil y a 7 ans

Esclapion a écrit :En installant le Grub depuis Mint, par un grub-install toujours, tu as le même problème ?

Si oui, c'est un peu inquiétant.


Oui. Et cela m'inquiète aussi. Le test de barrette je peux le faire un les sortants l'une après l'autre ou y a t-il un autre moyen ?

Edit : j'oubliais memtester :gsourire:
Dernière modification par andson le 03 Mar 2013, 16:24, modifié 1 fois.

Grub

#26Messageil y a 7 ans

Ce serait toujours intéressant, mais normalement une barrette mémoire vérolée, c'est plutôt un fonctionnement instable, genre arrêt et redémarrage de temps en temps (du moins sous W7. Sous Linux, ça doit être un plantage).

Un essai non moins bête à faire (mais j'ai ce genre de pb). Débrancher la tour du secteur, physiquement à la prise (pas seulement au bouton), env. 1', puis la rebrancher.

(edit)

Pour la ram, tu dois avoir memtest dans un coin, pas besoin de manips physique.

Grub

#27Messageil y a 7 ans

La tour a eu toute la nuit pour se reposer mais je vais retenter le coup après un mentest.
Si une idée vous vient ... je repasse à l'occasion :siffle

Grub

#28Messageil y a 7 ans

J'ai bien dit, séparée du secteur, en retirant la prise.

Grub

#29Messageil y a 7 ans

Tu en sais beaucoup plus que moi...
C'est bien dans la swap qu'il trouve ses infos ?

Grub

#30Messageil y a 7 ans

?
La swap ne sert qu'à l'hibernation, en pratique.

Grub

#31Messageil y a 7 ans


Grub

#32Messageil y a 7 ans

Oui, il semble que j'avais certaines idées fausses sur le grub,

(Je ne pensais d'ailleurs pas pouvoir aider andson, la lenteur de son démarrage me semble matérielle ou liée à des choses sérieuses (corruptions de tables de partition p.ex.) et non à son grub).

Mais, par expérience, quand mon grub est installé sur Manjaro avec l'uuid de la swap, au reboot j'ai en choix surligné mon dernier choix d'OS, tandis que quand il est sur ma Mint, sans ces options, je reviens toujours sur la Mint comme premier choix.

Grub

#33Messageil y a 7 ans

Oui, ça sauve le nom du dernier choix dans un fichier à part. Par contre, ton interprétation de resume m'étonne beaucoup. :choc:

Grub

#34Messageil y a 7 ans

waitnsea a écrit :Oui, il semble que j'avais certaines idées fausses sur le grub,

(Je ne pensais d'ailleurs pas pouvoir aider andson, la lenteur de son démarrage me semble matérielle ou liée à des choses sérieuses (corruptions de tables de partition p.ex.) et non à son grub).

Mais, par expérience, quand mon grub est installé sur Manjaro avec l'uuid de la swap, au reboot j'ai en choix surligné mon dernier choix d'OS, tandis que quand il est sur ma Mint, sans ces options, je reviens toujours sur la Mint comme premier choix.

C'est dû à ce que je t'ai dit plus haut.

Règle ton /etc/default/grub de mint comme manjaro et il se comportera de la même manière.

Grub

#35Messageil y a 7 ans

OK, merci

Grub

#36Messageil y a 7 ans

waitnsea a écrit :OK, merci

J'ai une petite brochure sur le net très bien foutue ; il faut que je recherche ; je t'enverrais le lien.

Grub

#37Messageil y a 7 ans

Je prends... merci d'avance, @ bientôt

Grub

#38Messageil y a 7 ans

Au passage : je n'ai pas de swap, et pourtant je reviens toujours par défaut sur mon dernier choix.

Grub

#39Messageil y a 7 ans

:bjr:
Toujours la galère. Voila ce que je me propose de faire :
Attendre les nouvelles mises à jour car c'est quand même bisard, quand je fais un update-grub les partions W§ et LinuxMint s'affichent en des temps records et les deux partitions Manjaro me prennent 10 minutes et les soucis ont commencés après une mise à jour.
Si ce n'est pas ça :
Me mettre sur Sda (LinuxMint) débrancher un disque dur et faire un update-grub ce qui me permettrait d'isoler et de détecter le disque qui à un probhlème. (s'il y en a un ...)
Bon ... pas bon ?

Grub

#40Messageil y a 7 ans

Esclapion a écrit :Au passage : je n'ai pas de swap, et pourtant je reviens toujours par défaut sur mon dernier choix.

Forcément puisque ce choix est donné dans le fichier /etc/default/grub :

GRUB_DEFAULT=saved
...
...
...
...

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

Ça n'a rien à voir avec le swap.

Répondre