Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

impossible de trouver Qt4

#1Messageil y a 6 ans

Salut :salut:

une mise à jour d'un logiciel installé depuis AUR m'est proposé mais j'ai une erreur due à QT pendant la compilation :

==> Téléchargement du PKGBUILD de umplayer depuis AUR...
x PKGBUILD
x umplayer.install



umplayer 0.97_svn181-2
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> n

==> Dépendances de umplayer :
 - mplayer (déjà installé)
 - qt4 (compilation depuis AUR)


==> Éditer umplayer.install ? [O/n] ("A" pour annuler)
==> --------------------------------------------------
==> n

==> Lancer la compilation de umplayer ? [O/n]
==> -----------------------------------------
==>
==> Construction et installation du paquet
==> Installation/compilation des dépendances manquantes pour umplayer:
Erreur : impossible de trouver la cible : qt4
==> Relancer la compilation de umplayer ? [o/N]


sur le site arch c'est indiqué que Qt4 et Qt5 etaient dans les depots extra mais impossible de les trouver avec yaourt -S ...

j'ai tenté la mise à jour en remplacent QT4 par QT dans le pkgbuild mais ça me fait une erreur en fin de compilation :
/bin/sh: qmake-qt : commande introuvable
make: *** [src/umplayer] Erreur 127

une idée ?
Dernière modification par sickboy le 08 Mar 2013, 10:43, modifié 1 fois.

impossible de trouver Qt4

#2Messageil y a 6 ans

Qt5 est dans les dépôts unstable. Par contre, qt4 est normalement dans les dépôts stables ? :confus:

[root@manjaro pat]# pacman -S qt
Avertissement : qt-4.8.4-3 est à jour -- réinstalle
résolution des dépendances...
recherche des conflits entre paquets...

Cibles (1) : qt-4.8.4-3

Taille totale installé :      90,92 MiB
Taille de mise à jour nette :   0,00 MiB

Procéder à l'installation ? [O/n]

impossible de trouver Qt4

#3Messageil y a 6 ans

Ah oui autant pour moi, j'avais tapé yaourt -S qt4, oups :oops:

si Qt4 est bien installé je ne vois pas trop pourquoi il y a cette erreur ?

Erreur : impossible de trouver la cible : qt4

impossible de trouver Qt4

#4Messageil y a 6 ans

il va falloir éditer le pkgbuild pour voir quelle version de Qt4 est exigée, ou si le nom du paquet ne correspond pas...

impossible de trouver Qt4

#5Messageil y a 6 ans

C'est parce que depuis quelques jours, le paquet qt est devenu qt4 sur archlinux depuis la venue de qt5. Il suffit de changer qt4 en qt dans les dépendances.

++

impossible de trouver Qt4

#6Messageil y a 6 ans

probleme résolu apres grosse mise à jour du système
pacman -Syyu, puis entre autre remplacer Qt par extra/Qt4

Répondre