Postez ici vos trucs & astuces.

Tuto: Compiz avec Xfce

#1Messageil y a 6 ans

Hello tout le monde,
comme j'ai un peu lutté pour faire fonctionner Compiz dans Xfce, je voulais partager la méthode que j'ai utilisée; c'est parti...

Attention ! depuis le 21 Mai 2013, Compiz et Emerald ont disparu des dépôts Manjaro (et Arch); l'installation depuis les dépôts officiels est impossible
Mais depuis la mise à jour du 29 décembre 2013 (pour Stable), il y a de nouveau ce qu'il faut dans les dépôts, voir en fin de tuto
toutefois, j'ai sauvegardé le nécessaire et vous pouvez télécharger une archive contenant tous les paquets:
-Compiz 64 bits
-Compiz 32 bits
les deux archives contiennent également Emerald et ses thèmes.

1) décompresser l'archive téléchargée dans un répertoire, ouvrir le terminal dans ce répertoire et taper:

sudo pacman -U *.tar.xz


2) il faut ensuite mettre quelques réglages dans le "Gestionnaire de configuration compizconfig", histoire qu'il fonctionne au premier lancement; on activera donc les plugins "décoration de la fenêtre" (dans "effets"), "déplacer la fenêtre" et "redimensionner la fenêtre" (dans "gestion des fenêtres"), en cochant les cases correspondantes.
il faut ensuite s'assurer que Emerald démarre; là, problème, il fallait refaire la commande "emerald --replace" à chaque démarrage (ça ne restait pas); pour régler ça, j'ai créé ~/.config/autostart/Emerald.desktop, avec le contenu suivant:

[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=Emerald
Comment=activation Emerald
Exec=emerald --replace
OnlyShowIn=XFCE;
StartupNotify=false
Terminal=false
Hidden=false


3) régler Xfce pour que démarre Compiz à la place de Xfwm; au départ, j'avais modifié le fichier dans /etc, mais les mises à jour de Xfce écrasait tout à chaque fois, donc on procède autrement:

mv ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml.old
cp /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml ~/.config/xfce4/xfconf/xfce-perchannel-xml/

ensuite, éditer le fichier ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml avec votre éditeur favori, et chercher la section:

<property name="Client0_Command" type="array">
   <value type="string" value="xfwm4"/>
 </property>

et la modifier pour que ça devienne:

<property name="Client0_Command" type="array">
   <value type="string" value="compiz"/>
   <value type="string" value="ccp"/>
 </property>

sauvegarder le fichier et quitter (et vous notez qu'on a fait une sauvegarde de l'ancien).

4) redémarrer la session et admirer; on peut maintenant faire joujou avec les options de Compiz (dans "Gestionnaire de configuration compizconfig") et les thèmes Emerald (dans "Gestionnaire de thèmes Emerald").

Au cas où on voudrait revenir en arrière
On ne sait jamais, ça peut ne pas plaire, ou bien la carte graphique est trop limite pour Compiz; dans ce cas, c'est très simple, vu qu'on avait gardé une sauvegarde des fichiers de conf:

rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml
mv ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml.old ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml
rm ~/.config/autostart/Emerald.desktop

c'est tout, on peut relancer la session, tout est redevenu comme avant...
on peut bien sûr désinstaller les paquets:

sudo pacman -Rs ccsm compiz-core compiz-fusion-plugins-extra compiz-fusion-plugins-main compizconfig-backend-gconf emerald emerald-themes


Mise à jour du 29/12/2013
nous avons un nouveau paquet compiz-xfce dans les dépôts; il suffit de l'installer et tout doit normalement être automatique, puisqu'au premier lancement, toute ancienne configuration est sauvegardée et remplacée par celle qui va bien.
toutefois, il faut partir du thème Aidwata-manjaro-dark (celui d'origine) et penser à effacer le cache de session de Xfce (dans "session et démarrage").
d'autre part, Emerald n'est pas fourni et remplacé par Compiz-decorator-gtk, ce qui posera peut-être des problème à ceux qui utilisaient Emerald (à voir), mais ça peut se régler dans le Ccsm. il faut penser à enlever le fichier emerald.desktop pour ceux qui en avaient fait un.

NB: s'il n'y a pas de Sudo dans les commandes, c'est qu'il n'y en a pas besoin...

PS: et n'hésitez pas à le dire si quelque chose ne marche pas pour vous...

Tuto: Compiz avec Xfce

#2Messageil y a 6 ans

Merci pour le partage. :sourire:

Tuto: Compiz avec Xfce

#3Messageil y a 6 ans

j'avais fait cette installation, mais en utilisant ce que disait le wiki.
pour démarrer compiz et emerald voilà ce qu'il dit :

Pour configurer Compiz comme votre gestionnaire de fenêtre par défaut et/ou d'Emerald comme votre décorateur de fenêtres par défaut, vous devez ajouter Compiz Fusion Icon dans les Applications au démarrage de votre bureau. Cela permet de déterminer quels sont les programmes et applications qui sont automatiquement activés lorsque le bureau démarre. Les paramètres de démarrage de votre ordinateur de bureau peuvent être trouvés dans la section appropriée du menu de votre bureau. Pour XFCE, allez dans la section Paramètres du menu, Session et démarrage; une fois ouvert, sélectionnez l'onglet Démarrage automatique, puis cliquez sur + Ajouter.
1. Dans le champ Nom, tapez fusion-icon
2. Dans le champ Commande, tapez fusion-icon
3. Cliquez sur Valider.
fusion-icon devrait maintenant apparaître au bas de la liste. Assurez-vous que la case qui est en face soit cochée, puis fermez la fenêtre de l'application. Pour autant qu'ils aient été activés avant de vous déconnecter ou éteindre votre ordinateur, Compiz et/ou Emerald démarreront à chaque fois automatiquement!

ça marche bien.
seul hic : de temps en temps, au démarrage on se retrouve avec un bureau sans rien, juste le fond d'écran. obligé de redémarrer en ligne de commande.
peut-être un problème au niveau de moment où fusion-icon se charge...
sinon, ça marchait très bien... :bien

Tuto: Compiz avec Xfce

#4Messageil y a 6 ans

:bjr:

Une chance sur mille, mais jette un coup d'oeil ICI.

Tuto: Compiz avec Xfce

#5Messageil y a 6 ans

le problème avec Fusion-icon, c'est que même si on arrivait à le faire marcher correctement sous Xfce (ce qui n'est pas le cas), il fait perdre du temps; en effet, la session démarre sur le gestionnaire de fenêtre original (Xfwm), et ensuite Fusion-icon le remplace par Compiz.
la méthode illustrée plus haut démarre directement Compiz, sans passer par Xfwm...

Tuto: Compiz avec Xfce

#6Messageil y a 6 ans

c'est ce que j'avais remarqué et c'est plus propre de démarrer directement compiz et emarald... beau boulot !!!

Tuto: Compiz avec Xfce

#7Messageil y a 6 ans

Salut,

<Sarcastique> Hé bien "Mr Michux", il est pas près d'avoir des fenêtres qui brûlent ou se transforment en avion en papier à la fermeture, voire un cube avec la binette de chacun de ses enfants par face sans mettre les mains dans le cambouis/avoir un doc Loubrix sous la souris...</Sarcastique>

A+
Dernière modification par fassil le 04 Mai 2013, 09:01, modifié 1 fois.

Tuto: Compiz avec Xfce

#8Messageil y a 6 ans

@Loubrix : merci, sympa. :clap

Tuto: Compiz avec Xfce

#9Messageil y a 6 ans

Bonjour Loubrix :bjr:

Intéressant, merci. Je vais tester ça. :bien

Tuto: Compiz avec Xfce

#10Messageil y a 6 ans

Comme dit mon collègue, je vais tester ça aussi ... à l'occasion :clindoeil:

Tuto: Compiz avec Xfce

#11Messageil y a 6 ans

fassil a écrit :Salut,

<Sarcastique> Hé bien "Mr Michux", il est pas près d'avoir des fenêtres qui brûlent ou se transforment en avion en papier à la fermeture, voire un cube avec la binette de chacun de ses enfants par face sans mettre les mains dans le cambouis/avoir un doc Loubrix sous la souris...</Sarcastique>

A+

c'est un truc façon "clique-ici" que tu veux ? ça doit pouvoir se régler avec un petit script en Zenity qui modifie les fichiers à grand coup de Sed...
je regarde ça, et j'essaie de faire un paquet (mais pas aujourd'hui, faut que j'aille récupérer mes enfants chez leur mère à l'autre bout de la France, c'est la fin des vacances)...

Tuto: Compiz avec Xfce

#12Messageil y a 6 ans

Super Loubrix, c'est bien plus propre comme ça... je m'étais dit que je regarderai pour lancer directement compiz au démarrage sans avoir à passer par xfwm avant.. bah tu m'évites de me casser la tête...
C'est parfait, Merci ! :p

Tuto: Compiz avec Xfce

#13Messageil y a 6 ans

Loubrix a écrit :c'est un truc façon "clique-ici" que tu veux ?


C'est trop gentil, doc, mais ma 9 cellules "made in china, c'est pas bien/mais comment faire autrement.." commence un tantinet à battre de l'aile & je suis allergique aux pilotes Nvidia & à trop de clique, aussi :clindoeil:

A+

Tuto: Compiz avec Xfce

#14Messageil y a 6 ans

J'ai ajouté la méthode pour revenir en arrière dans le premier post...

@ fassil: j'ai un peu de mal à comprendre ce que tu dis...

Tuto: Compiz avec Xfce

#15Messageil y a 6 ans

Loubrix a écrit :@ fassil: j'ai un peu de mal à comprendre ce que tu dis...

Pas étonnant, tu n'as pas pris la langue fassilienne en option :rigole:

Tuto: Compiz avec Xfce

#16Messageil y a 6 ans

Merci pour ce tutoriel compiz est installé et lancé sur ma section.

Par contre dernière petite question, je ne trouve pas l'option expose qui permet de mettre les 4 bureaux virtuels en exposé avec écran divisé en 4 (a la cinnamon)

Et je n'ai plus le "haut" des fenêtres pour les déplacer redimensionner etc

Merci d'avance
Dernière modification par folkarys le 06 Mai 2013, 17:14, modifié 1 fois.

Tuto: Compiz avec Xfce

#17Messageil y a 6 ans

:bjr:

il va demander de désigner ce qu'on veut installer du groupe; donc on veut tout sauf compiz-decorator-gtk et compiz-decorator-kde.


Comment les exclus-tu, stp ?

Tuto: Compiz avec Xfce

#18Messageil y a 6 ans

bonjour, j'ai quelques soucis pour revenir en arrière personnellement malgré le fait que j'ai suivi le tutoriel.
Pouvez-vous me redonner un Xfce config de base sans avoir compiz ?
Merci

Tuto: Compiz avec Xfce

#19Messageil y a 6 ans

@ Esclapion: on les exclut en saisissant les numéros de tous les paquets sauf ceux qu'on ne veut pas installer.
celà dit, on pourrait les installer, ça ne gêne pas, c'est juste qu'on ne s'en sert pas, donc ils prendraient de la place pour rien...

@ Folkarys: l'exposé de bureau se trouve dans la section "bureau" du gestionnaire de configuration CompizConfig, et il s'appelle simplement "exposé".
pour la décoration des fenêtres, si tu l'as perdue, vérifie que "décoration de la fenêtre" est bien activé dans "effets", et que tu as choisis un thème dans la configuration d'Emerald; enfin quand tu testes des trucs, certains plugins peuvent être incompatible avec ton matériel et provoquer des plantages; dans ce cas, désactive le plugin fautif, et relance le décorateur avec la commande "emerald --replace"

pour revenir en arrière, la méthode que j'ai donnée en mode texte est aussi faisable avec l'explorateur de fichier; il faut simplement supprimer le fichier qu'on a édité (ou bien le renommer par exemple en ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml.compiz) et redonner son nom d'origine au fichier ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml.old (en enlevant ".old"); si on laisse le fichier Emerald.desktop, ça ne gêne pas Xfce.
par contre, au moment de se déconnecter de la session, penser à décocher la case "enregistrer la session".

Tuto: Compiz avec Xfce

#20Messageil y a 6 ans

Heu non toujours pas. Pourtant le fichier correspond bien. je ne comprend plus rien.

Y'a moyen de forcer la réinstallation de xfce ?

Edit : réglè avec un xfwm4 --replace
Dernière modification par folkarys le 06 Mai 2013, 19:48, modifié 1 fois.

Répondre