Postez ici vos trucs & astuces.
Répondre

[xfce] menu parametres trop long

#1Messageil y a 6 ans

:bjr:

le menu paramètres affiche tous les outils de configuration Xfce, ça fait un menu trop long et pas clair

pour cacher les icones deja presentes dans le "gestionnaire des parametres j'ai fait ceci:

sudo gedit /etc/xdg/menus/xfce-applications.menu

puis le contenu par ce qui suive:

<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
  "http://www.freedesktop.org/standards/menu-spec/1.0/menu.dtd">

<Menu>
    <Name>Xfce</Name>

    <DefaultAppDirs/>
    <DefaultDirectoryDirs/>
    <DefaultMergeDirs/>

    <Include>
        <Filename>exo-web-browser.desktop</Filename>
        <Filename>exo-mail-reader.desktop</Filename>
        <Filename>xfce4-about.desktop</Filename>
        <Filename>xfce4-session-logout.desktop</Filename>
    </Include>

    <Layout>
        <Filename>exo-web-browser.desktop</Filename>
        <Filename>exo-mail-reader.desktop</Filename>
        <Separator/>
        <Menuname>Settings</Menuname>
        <Separator/>
        <Merge type="all"/>
        <Separator/>
       
       
        <Filename>xfce4-about.desktop</Filename>
        <Filename>xfce4-session-logout.desktop</Filename>
    </Layout>

    <Menu>
        <Name>Settings</Name>
        <Directory>xfce-settings.directory</Directory>
        <Include>
            <Filename>xfce-settings-manager.desktop</Filename>
            <Filename>xfce4-settings-editor.desktop</Filename>
            <And>
                <Category>Settings</Category>
               <Not><Category>XFCE</Category></Not>
          <Not><Category>X-XFCE-SettingsDialog</Category></Not>
                <Not><Category>System</Category></Not>
            </And>
        </Include>

        <Layout>
            <Filename>xfce-settings-manager.desktop</Filename>
            <Separator/>
            <Merge type="all"/>
        </Layout>
    </Menu>

    <Menu>
        <Name>Accessories</Name>
        <Directory>xfce-accessories.directory</Directory>
        <Include>
            <Or>
                <Category>Accessibility</Category>
                <Category>Core</Category>
                <Category>Legacy</Category>
                <Category>Utility</Category>
            </Or>
        </Include>
        <Exclude>
            <Or>
                <Filename>xfce4-about.desktop</Filename>
                <Category>Settings</Category>
                <Category>System</Category>
            </Or>
        </Exclude>

        <Layout>
            <Filename>xfrun4.desktop</Filename>
            <Filename>xfce4-appfinder.desktop</Filename>
            <Separator/>
            <Merge type="all"/>
        </Layout>
    </Menu>

    <Menu>
        <Name>Development</Name>
        <Directory>xfce-development.directory</Directory>
        <Include>
            <Category>Development</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Education</Name>
        <Directory>xfce-education.directory</Directory>
        <Include>
            <Category>Education</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Games</Name>
        <Directory>xfce-games.directory</Directory>
        <Include>
            <Category>Game</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Graphics</Name>
        <Directory>xfce-graphics.directory</Directory>
        <Include>
            <Category>Graphics</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Multimedia</Name>
        <Directory>xfce-multimedia.directory</Directory>
        <Include>
            <Category>Audio</Category>
            <Category>Video</Category>
            <Category>AudioVideo</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Network</Name>
        <Directory>xfce-network.directory</Directory>
        <Include>
            <Category>Network</Category>
        </Include>
        <Exclude>
            <Or>
                <Filename>exo-mail-reader.desktop</Filename>
                <Filename>exo-web-browser.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

    <Menu>
        <Name>Office</Name>
        <Directory>xfce-office.directory</Directory>
        <Include>
            <Category>Office</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>System</Name>
        <Directory>xfce-system.directory</Directory>
        <Include>
            <Or>
                <Category>Emulator</Category>
                <Category>System</Category>
            </Or>
        </Include>
        <Exclude>
            <Or>
                <Filename>xfce4-session-logout.desktop</Filename>
                <Filename>ubuntu-software-center.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

    <Menu>
        <Name>Other</Name>
        <Directory>xfce-other.directory</Directory>
        <OnlyUnallocated/>
        <Include>
            <All/>
        </Include>
        <Exclude>
            <Category>Settings</Category>
            <Category>Screensaver</Category>
            <Category>X-Xfce-Toplevel</Category>
        </Exclude>
    </Menu>

</Menu>


et voila le resultat

Image

le menu whisker est modifié aussi
( astuce trouvé sur le site de voyager linux)
Dernière modification par melomane le 10 Aou 2013, 14:18, modifié 5 fois.

[xfce] menu parametres trop long

#2Messageil y a 6 ans

concrètement, ça change quoi dans le menu ? fais une capture au besoin pour nous montrer...

[xfce] menu parametres trop long

#3Messageil y a 6 ans

fait

[xfce] menu parametres trop long

#4Messageil y a 6 ans

ok, donc ça fait sauter tout ce qui se trouve aussi dans le gestionnaire de paramètre (et qui fait doublons).
effectivement l'astuce est sympa, surtout si on a un netbook...

par contre, c'est une astuce, pas un problème, donc je déplace ton sujet dans la bonne section ;)

[xfce] menu parametres trop long

#5Messageil y a 6 ans

Merci melomane,
Beaucoup plus propre comme ça !
NB Il m'a fallu rebooter 2 fois avant que ce soit pris en compte ! Une histoire de sauvegarde de session j'imagine...
Maintenant, nickel !

[xfce] menu parametres trop long

#6Messageil y a 6 ans

Excellent, je vais adopter ça sur le laptop :clap

[xfce] menu parametres trop long

#7Messageil y a 6 ans

par contre, je n'y ai pas pensé, mais si on veut que ça reste en cas de mise à jour de Xfce, il vaudrait mieux copier xfce-applications.menu dans ~/.config/menus et faire les modifs dans la copie...


[xfce] menu parametres trop long

#9Messageil y a 6 ans

:salut:

il y a une erreur , le menu "Autres" se rempli avec les icones qui etait dans "parametres"...

voici donc la correction, j'ai mis la totalité du script:

<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
  "http://www.freedesktop.org/standards/menu-spec/1.0/menu.dtd">

<Menu>
    <Name>Xfce</Name>

    <DefaultAppDirs/>
    <DefaultDirectoryDirs/>
    <DefaultMergeDirs/>

    <Include>
        <Filename>exo-web-browser.desktop</Filename>
        <Filename>exo-mail-reader.desktop</Filename>
        <Filename>xfce4-about.desktop</Filename>
        <Filename>xfce4-session-logout.desktop</Filename>
    </Include>

    <Layout>
        <Filename>exo-web-browser.desktop</Filename>
        <Filename>exo-mail-reader.desktop</Filename>
        <Separator/>
        <Menuname>Settings</Menuname>
        <Separator/>
        <Merge type="all"/>
        <Separator/>
       
       
        <Filename>xfce4-about.desktop</Filename>
        <Filename>xfce4-session-logout.desktop</Filename>
    </Layout>

    <Menu>
        <Name>Settings</Name>
        <Directory>xfce-settings.directory</Directory>
        <Include>
            <Filename>xfce-settings-manager.desktop</Filename>
            <Filename>xfce4-settings-editor.desktop</Filename>
            <And>
                <Category>Settings</Category>
               <Not><Category>XFCE</Category></Not>
          <Not><Category>X-XFCE-SettingsDialog</Category></Not>
                <Not><Category>System</Category></Not>
            </And>
        </Include>

        <Layout>
            <Filename>xfce-settings-manager.desktop</Filename>
            <Separator/>
            <Merge type="all"/>
        </Layout>
    </Menu>

    <Menu>
        <Name>Accessories</Name>
        <Directory>xfce-accessories.directory</Directory>
        <Include>
            <Or>
                <Category>Accessibility</Category>
                <Category>Core</Category>
                <Category>Legacy</Category>
                <Category>Utility</Category>
            </Or>
        </Include>
        <Exclude>
            <Or>
                <Filename>xfce4-about.desktop</Filename>
                <Category>Settings</Category>
                <Category>System</Category>
            </Or>
        </Exclude>

        <Layout>
            <Filename>xfrun4.desktop</Filename>
            <Filename>xfce4-appfinder.desktop</Filename>
            <Separator/>
            <Merge type="all"/>
        </Layout>
    </Menu>

    <Menu>
        <Name>Development</Name>
        <Directory>xfce-development.directory</Directory>
        <Include>
            <Category>Development</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Education</Name>
        <Directory>xfce-education.directory</Directory>
        <Include>
            <Category>Education</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Games</Name>
        <Directory>xfce-games.directory</Directory>
        <Include>
            <Category>Game</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Graphics</Name>
        <Directory>xfce-graphics.directory</Directory>
        <Include>
            <Category>Graphics</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Multimedia</Name>
        <Directory>xfce-multimedia.directory</Directory>
        <Include>
            <Category>Audio</Category>
            <Category>Video</Category>
            <Category>AudioVideo</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>Network</Name>
        <Directory>xfce-network.directory</Directory>
        <Include>
            <Category>Network</Category>
        </Include>
        <Exclude>
            <Or>
                <Filename>exo-mail-reader.desktop</Filename>
                <Filename>exo-web-browser.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

    <Menu>
        <Name>Office</Name>
        <Directory>xfce-office.directory</Directory>
        <Include>
            <Category>Office</Category>
        </Include>
    </Menu>

    <Menu>
        <Name>System</Name>
        <Directory>xfce-system.directory</Directory>
        <Include>
            <Or>
                <Category>Emulator</Category>
                <Category>System</Category>
            </Or>
        </Include>
        <Exclude>
            <Or>
                <Filename>xfce4-session-logout.desktop</Filename>
                <Filename>ubuntu-software-center.desktop</Filename>
            </Or>
        </Exclude>
    </Menu>

    <Menu>
        <Name>Other</Name>
        <Directory>xfce-other.directory</Directory>
        <OnlyUnallocated/>
        <Include>
            <All/>
        </Include>
        <Exclude>
            <Category>Settings</Category>
            <Category>Screensaver</Category>
            <Category>X-Xfce-Toplevel</Category>
        </Exclude>
    </Menu>

</Menu>

[xfce] menu parametres trop long

#10Messageil y a 6 ans

Je n'ai pas de Sous-menu "Autres" ? Ou est-ce ?

[xfce] menu parametres trop long

#11Messageil y a 6 ans

apres accessoires

[xfce] menu parametres trop long

#12Messageil y a 6 ans

Bon, alors, j'ai pas :sourire:

Mais je vais regarder ta correction, merci.

(edit)

Ce qui est marrant, c'est que je n'ai "plus". :saispas: Sur ma capture, plus haut, il y est -> ????

(re_edit)

Oui, j'ai essayé, ça semble bien marcher, même si je n'ai toujours plus "Autres". :sourire:

[xfce] menu parametres trop long

#13Messageil y a 6 ans

Merci Melomane. Cette astuce est vraiment utile tant il est vrai que le menu xfce...est un vrai bazar :colère::gsourire:
waitnsea a écrit :Merci melomane,
Beaucoup plus propre comme ça !
NB Il m'a fallu rebooter 2 fois avant que ce soit pris en compte ! Une histoire de sauvegarde de session j'imagine...
Maintenant, nickel !

C'est un peu, je crois, le (petit) defaut d'Xfce : il faut effacer les sessions antérieurs et parfois certains fichiers de config (.trucmachin) dans le /home afin de rendre opérants certains changements de paramètres.

[xfce] menu parametres trop long

#14Messageil y a 6 ans

Salut,

Est-ce qu'en jouant avec la ligne Categorie du /usr/share/applications/"nom de l'applic".desktop vous pouvez changez l'item correspondant de place dans les sous-menus ?
Histoire de pousser le "pimp/tune your menu" un peu + loin... :clindoeil:

A+

[xfce] menu parametres trop long

#15Messageil y a 6 ans

:bjr:

Vi, et on peut aussi en masquer par NoDisplay.

[xfce] menu parametres trop long

#16Messageil y a 6 ans

Pratique ça, pour les trucs dont on ne se sert jamais, et qu'on oublie, et qu'on finit par chercher un jour...

[xfce] menu parametres trop long

#17Messageil y a 6 ans

fassil a écrit :Salut,

Est-ce qu'en jouant avec la ligne Categorie du /usr/share/applications/"nom de l'applic".desktop vous pouvez changez l'item correspondant de place dans les sous-menus ?
Histoire de pousser le "pimp/tune your menu" un peu + loin... :clindoeil:

A+

et on peut aussi s'arranger pour que ça n'apparaisse que dans les menus de certains environnements de bureau (pour ceux qui en ont plusieurs et ne veulent pas voir d'appli Kde dans leur menu Xfce)

[xfce] menu parametres trop long

#18Messageil y a 6 ans

Salut,

Pour rebondir sur les menus trop longs, et souligner une singularité d'Enlightenment (que les "Openboxeurs" trouveraient spontanemment si elle était exploitée dans le profil par défaut), au clic droit n'importe où apparaissent vos applications favorites:

Image

Et que en coller trois des + usuelles dès la première "expérience utilisateur" permettrait de s'en apercevoir tout seul comme un grand...

"In keyboard I trust, mais un clic judicieux, ça le fait aussi :clindoeil: "

A+

Répondre