Problèmes et questions concernant le noyau et le support matériel.
Répondre

MAJ tout noyau bloque le clavier

#1Messageil y a 2 mois

Bonjour tout le monde,
Dans la dernière version des noyaux, aucun de ceux qui sont disponibles (4.4, 4.9, 4.14, 4.17, 4.18, 4.19) ne me permet d'avoir un clavier actif dans l'écran de connexion de session dans XFCE. Si j'utilise la commande :

DOWNGRADE_FROM_ALA=1 downgrade linux418
, je peux choisir la version linux418-4.18.16-1 plutôt que linux418-4.18.16-2. En redémarrant, mon clavier est alors actif, mais cette situation n'est pas satisfaisante.
Quelqu'un sait-il ce qui a changé dans les noyaux qui affecte mon clavier ?
Comment le vérifier ?
Comment le réparer ?
Mon clavier est USB, mon ordi n'est pas un HP.

Merci

MAJ tout noyau bloque le clavier

#2Messageil y a 2 mois

bonsoir

peux tu nous fournir un retour de
inxi -Fxxxz
si tu sais quelle version exactement pose problème pour le clavier ,
mieux vaut le remonter sur le forum manjaro.org

la version 4.19.1 viens juste d'apparaitre ce dimanche , donc c'est sans doute un des patches de philm qui provoque le problème ( si c'est lié a icu , il a été livré le 02/11 donc ... )

question complémentaire , as tu testé les dernieres iso version 18 ?
Modifié en dernier par Erwan le 05 Nov 2018, 20:09, modifié 1 fois.
Raison :Ajout balises code en ligne

MAJ tout noyau bloque le clavier

#3Messageil y a 2 mois

Salut,
Ne serait-ce pas plutôt lightdm qui fait des siennes ? Ton clavier est-il aussi sans réaction en TTY (ctrl+alt+2) ?

MAJ tout noyau bloque le clavier

#4Messageil y a 2 mois

Bonjour,
Sur l'écran de connexion, le clavier est vraiment coincé puisque même la touche "Verr Num" est inopérante.
J'ai testé 4.19 mais pas 4.19.1.
Non je n'ai pas testé le dernier live USB en v18. J'ai une v17 qui fonctionne donc j'ai a priori pas trop d'intérêt à la mettre à jour. Je suppose que si le dernier live USB v18 utilise la dernière version du noyau (v19?), j'aurais le même problème. Dans ce cas ou le cas contraire, le test m'apporterait-il une info supplémentaire ? Je pense qu'on doit pouvoir investiguer directement sur une distib installée défaillante, non ?
J'avais eu le même problème avec 4.14, je l'avais résolu en utilisant 4.19 en version rc dispo en repo.
Je n'avais pas le problème avec 4.17 ni 4.18, je les utilisais donc comme versions de secours.
Maintenant, j'ai l'impression que toutes les versions du repo ont été mises à jour avec ce problème. A moins qu'il provienne d'ailleurs ? Mais c'est quand même lié au noyau puisqu'une ancienne version de 4.18 n'inclut pas le problème.
Donc actuellement, aucune version du repo n'est satisfaisante pour moi, ce qui me bloque dans le processus de mise-à-jour du noyau.
Plus généralement, c'est un peu bizarre de mettre à jour tous les noyaux du repo, non ? Il ne serait pas plus judicieux de "versionner" davantage et de garder la "n" dans le repo quand on ajoute une "n+1" ?
En l'occurrence, garder la version 4.18.16-1 disponible quand on met la 4.18.16-2.

inxi -Fxxxz
System:
  Host: samspade Kernel: 4.18.16-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: N/A wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: P5QL PRO v: Rev 1.xx serial: <filter> 
  BIOS: American Megatrends v: 0902 date: 11/28/2008 
CPU:
  Topology: Quad Core model: Intel Core2 Quad Q9550 bits: 64 type: MCP 
  arch: Penryn rev: A L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 22653 
  Speed: 2220 MHz min/max: 2003/2833 MHz Core speeds (MHz): 1: 2220 2: 2431 
  3: 2408 4: 2318 
Graphics:
  Device-1: NVIDIA G96 [GeForce 9500 GT] driver: nouveau v: kernel 
  bus ID: 01:00.0 chip ID: 10de:0640 
  Display: x11 server: X.Org 1.20.3 driver: nouveau unloaded: modesetting 
  alternate: fbdev,nv,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: NV96 v: 3.3 Mesa 18.2.4 compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: Intel 82801JI HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 chip ID: 8086:3a3e 
  Sound Server: ALSA v: k4.18.16-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet 
  vendor: ASUSTeK P5KPL-CM driver: ATL1E v: N/A port: dc00 bus ID: 02:00.0 
  chip ID: 1969:1026 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k 
  v: kernel port: e400 bus ID: 04:00.0 chip ID: 168c:002e 
  IF: wlp4s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 9.32 TiB used: 6.63 TiB (71.1%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  speed: 3.0 Gb/s serial: <filter> rev: 1B6Q scheme: GPT 
  ID-2: /dev/sdb vendor: Toshiba model: HDWE160 size: 5.46 TiB 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: FS2A scheme: GPT 
  ID-3: /dev/sdg vendor: Western Digital model: WD40EZRZ-00WN9B0 
  size: 3.64 TiB speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 0A80 scheme: GPT 
Partition:
  ID-1: / size: 19.56 GiB used: 15.57 GiB (79.6%) fs: ext4 dev: /dev/sda5 
  ID-2: /home size: 999.7 MiB used: 203.3 MiB (20.3%) fs: ext3 
  dev: /dev/sda4 
  ID-3: swap-1 size: 10.00 GiB used: 73.4 MiB (0.7%) fs: swap dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: nouveau temp: 56 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
Info:
  Processes: 256 Uptime: 17h 06m Memory: 7.79 GiB used: 3.03 GiB (38.9%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: xfce4-terminal inxi: 3.0.27

MAJ tout noyau bloque le clavier

#5Messageil y a 2 mois

Bonjour. As tu essayé la version fallback du kernel?

MAJ tout noyau bloque le clavier

#6Messageil y a 2 mois

Je viens de tester le fallback : même problème.
Pour info, la souris fonctionne et me permet d'utiliser le clavier virtuel.

MAJ tout noyau bloque le clavier

#7Messageil y a 2 mois

Aujourd'hui les noyaux ont été mis à jour et le problème persiste

MAJ tout noyau bloque le clavier

#8Messageil y a 2 mois

avec la clé install USB
que donne

 inxi --usb

USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  Hub: 1-10:2 info: Genesys Logic Hub ports: 4 rev: 2.0 
  Device-1: 1-11:3 info: Logitech G35 Headset type: Audio,HID rev: 1.1 
  Device-2: 1-13:4 info: Logitech Keyboard K120 type: Keyboard,HID rev: 1.1 
  Device-3: 1-14:45 info: Logitech G5 Laser Mouse type: Mouse,HID rev: 2.0 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 
  
  
 lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 045: ID 046d:c049 Logitech, Inc. G5 Laser Mouse
Bus 001 Device 004: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 001 Device 003: ID 046d:0a15 Logitech, Inc. G35 Headset
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 

MAJ tout noyau bloque le clavier

#9Messageil y a 2 mois

Voilà ce que j'ai fait :
- je suis dans ma Manjaro démarré depuis le disque dur
- je connecte la clé USB
- je la monte
C'est bien ça ?
J'obtiens :

USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  Device-1: 1-1:2 info: Alcor Micro AU6477 Card Reader Controller 
  type: Mass Storage,HID rev: 2.0 
  Device-2: 1-5:3 info: SanDisk SDCZ80 Flash Drive type: Mass Storage 
  rev: 2.1 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 
  Hub: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 
  Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 
  Hub: 7-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 
  Device-3: 7-1:2 info: Wacom CTF-420 [Volito2] type: Mouse rev: 1.1 
  Device-4: 7-2:3 info: N/A type: Mouse rev: 1.1 
  Hub: 8-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 
  Device-5: 8-2:2 info: Elan Micro ActiveJet K-2024 Multimedia Keyboard 
  type: Keyboard,HID rev: 1.1 

MAJ tout noyau bloque le clavier

#10Messageil y a 2 mois

Salut, j ai eu ce bug il y a quelque temps sur un PC portable que j installais.

En choisissant "clavier francais AZERTY" dans la liste des claviers dans le gestionnaire de parametre, ca s est resolu.

ca ne coute rien d essayer...

MAJ tout noyau bloque le clavier

#11Messageil y a 2 mois

Voilà ce que j'ai dans les paramètres du clavier :
Image
Je n'ai pas la possibilité de choisir "clavier français AZERTY"

MAJ tout noyau bloque le clavier

#12Messageil y a 2 mois

Bonjour.
Essaye sudo kbctl -l fr
Le MP sera en qwerty, mais après , tu devrais avoir le clavier en français pour la session en cours.

MAJ tout noyau bloque le clavier

#13Messageil y a 2 mois

sspade a écrit :
il y a 2 mois
Voilà ce que j'ai dans les paramètres du clavier :
Image
Je n'ai pas la possibilité de choisir "clavier français AZERTY"
Si si, en cliquant sur "variante"...

MAJ tout noyau bloque le clavier

#14Messageil y a 2 mois

lemust83 a écrit :
il y a 2 mois
Bonjour.
Essaye sudo kbctl -l fr
Le MP sera en qwerty, mais après , tu devrais avoir le clavier en français pour la session en cours.
Mon clavier est déjà en azerty, donc je tape bien le mot de passe en azerty.
En revanche, j'obtiens :

$ sudo kbctl -l fr
sudo: kbctl : commande introuvable
Il faut installer un paquet pour avoir cette commande ?

MAJ tout noyau bloque le clavier

#15Messageil y a 2 mois

Oui, désolé, il faut installer keyboardctl . kbctl est un alias qui invoque cette commande.

MAJ tout noyau bloque le clavier

#16Messageil y a 2 mois

tower41000 a écrit :
il y a 2 mois
sspade a écrit :
il y a 2 mois
Voilà ce que j'ai dans les paramètres du clavier :
Image
Je n'ai pas la possibilité de choisir "clavier français AZERTY"
Si si, en cliquant sur "variante"...
En effet j'ai pu modifié ainsi :
Image
Mais au redémarrage en 4.19, ça ne change rien : le clavier est toujours bloqué.

MAJ tout noyau bloque le clavier

#17Messageil y a 2 mois

lemust83 a écrit :
il y a 2 mois
Oui, désolé, il faut installer keyboardctl . kbctl est un alias qui invoque cette commande.
Après installation de keyboardctl, je lance la commande :

$ sudo kbctl -l fr
[sudo] Mot de passe de sspadem : 
:: saved settings
  XKBMODEL:   pc105
  XKBLAYOUT:  fr
  XKBVARIANT: 
Je redémarre en 4.19 et le clavier est toujours bloqué.

Répondre