Problèmes et questions concernant le noyau et le support matériel.
Répondre

GPU nvidia HS, qui bloque démarrage Linux

#1Messageil y a 3 mois

Salut à tous,

j'ai eu 2 gros soucis ces derniers temps, un crash SSD et un problème avec mon GPU Nvidia qui reste "stucked" au démarrage.
Je suis actuellement sur une mint, mais j'ai envie à nouveau de réinstaller une manjaro.

Concernant mon GPU, le seul moyen d'ouvrir une session c'est de rajouter l'option "nomodeset", mais évidemment l'écran en 640*480 est inutilisable...
Je ne peux pas désactiver dans le bios la carte Nvidia et c'est un pc portable, et cette foutue carte est soudée sur la carte mère, je n'ai donc aucun moyen de désactiver ou retirer celle ci.

Y a t'il une solution sous manjaro qui me permettrait de n'utiliser que le GPU intégré intel du processeur et qui me permette de m'affranchir totalement du GPU Nvidia et donc éviter ces problèmes au démarrage ?
Sous windows, j'arrive à m'en sortir mais je ne trouve pas la commande sous linux me permettant de réaliser cette manip. De plus comme le crash SSD est arrivé quelques temps après le GPU, je dois de toute façon installer un nouveau linux, donc cela relance l'intérêt de manjaro.

Merci à tous pour vos réponses.
David

GPU nvidia HS, qui bloque démarrage Linux

#2Messageil y a 3 mois

bonjour

si tu as accès a mint ou a une iso manjaro sur clé USB
peux tu nous faire le retour

fdisk -l ( sudo peut être requis )
inxi -Fxxxz

GPU nvidia HS, qui bloque démarrage Linux

#3Messageil y a 3 mois

Merci pour cette reponse rapide

je suis sous mint 18.3 il me semble Usb bootable

resultat commande fdisk - l :

mint@mint ~ $ sudo fdisk -l
Disk /dev/loop0: 1.7 GiB, 1773387776 bytes, 3463648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/nvme0n1: 119.2 GiB, 128035676160 bytes, 250069680 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6A71EC80-56BE-03A8-207B-9C9AAF15EA00

Device           Start       End   Sectors   Size Type
/dev/nvme0n1p1    2048    923647    921600   450M Windows recovery environment
/dev/nvme0n1p2  923648   1128447    204800   100M EFI System
/dev/nvme0n1p3 1128448   1161215     32768    16M Microsoft reserved
/dev/nvme0n1p4 1161216 250068991 248907776 118.7G Microsoft basic data


Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 5BA076D2-4D78-4346-B477-097A4F64CAEC

Device          Start        End   Sectors   Size Type
/dev/sda1        2048  245762047 245760000 117.2G Microsoft basic data
/dev/sda2   245762048  655362047 409600000 195.3G Microsoft basic data
/dev/sda3   655362048  716801501  61439454  29.3G Linux filesystem
/dev/sda4   716802048 1536002047 819200000 390.6G Linux filesystem
/dev/sda5  1536002048 1548290047  12288000   5.9G Linux swap
/dev/sda6  1548290048 1953312767 405022720 193.1G Microsoft basic data
/dev/sda7  1953312768 1953523711    210944   103M BIOS boot


Disk /dev/sdb: 1.9 GiB, 2013265920 bytes, 3932160 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x10eca411

Device     Boot Start     End Sectors  Size Id Type
/dev/sdb1  *     2048 3932159 3930112  1.9G  c W95 FAT32 (LBA)
Resultat commande inxi :

mint@mint ~ $ inxi -Fxxxz
System:    Host: mint Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) info: xfce4-panel dm: lightdm
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: Micro-Star model: MS-1775 v: REV:1.0
           Bios: American Megatrends v: E1775IMS.114 date: 01/17/2018
CPU:       Quad core Intel Core i7-6700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20736
           clock speeds: min/max: 800/3500 MHz 1: 862 MHz 2: 960 MHz
           3: 813 MHz 4: 846 MHz 5: 839 MHz 6: 874 MHz 7: 835 MHz 8: 813 MHz
Graphics:  Card-1: Intel Skylake Integrated Graphics
           bus-ID: 00:02.0 chip-ID: 8086:191b
           Card-2: NVIDIA GM204M [GeForce GTX 970M]
           bus-ID: 01:00.0 chip-ID: 10de:13d8
           Display Server: X.Org 1.18.4 drivers: fbdev,intel (unloaded: vesa)
           Resolution: 800x600@75.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 256 bits)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a170
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 02:00.0 chip-ID: 168c:003e
           IF: wlp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 04:00.0 chip-ID: 1969:e0a1
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-3: Atheros usb-ID: 001-004 chip-ID: 0cf3:e300
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1002.2GB (0.8% used)
           ID-1: /dev/nvme0n1 model: N/A size: 128.0GB serial: S1XVNYAH204916
           ID-2: /dev/sda model: HGST_HTS721010A9 size: 1000.2GB serial: JS100X6207RMHS temp: 35C
           ID-3: USB /dev/sdb model: UDisk size: 2.0GB serial: UDisk-0:0 temp: 0C
Partition: ID-1: swap-1 size: 6.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 62.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 236 Uptime: 3 min Memory: 736.8/7857.8MB
           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in xfce4-terminal) inxi: 2.2.35 
En esperant aue cela puisse aider

GPU nvidia HS, qui bloque démarrage Linux

#4Messageil y a 3 mois

alors par défaut ,
manjaro installe bumblebee , mais sans garanti pour la partie Nvidia

par défaut tu est toujours sur les drivers Intel , il faut lancer par une commande pour avoir Nvidia

je te conseille de créer une clé et de voir déjà en Live ,
prends la version avec noyau > 4.19.x la plus élevé
https://manjaro.org/manjaro-preview-releases

tu choisi l'option Non-free ( c'est pour indiquer vérifier pour tout driver drm , pas uniquement Nvidia )

GPU nvidia HS, qui bloque démarrage Linux

#5Messageil y a 3 mois

Bon je viens de créer la clef usb avec cette image et j'ai essayé tous les modes possibles.

En mode non-free et en mode free, j'ai même essayé de changer à la main au niveau de la ligne de commande les options i915.modset etc... sans succès.

J'ai noté une différence en supprimant les options modeset pour les 3 pilotes (i915, nouveau et readon) et en rajoutant l'option "nomodeset", je passe le splash screen (listing des retours des commandes) mais je reste sur un écran noir avec un curseur en haut à gauche, par contre lorsque j'appuye sur le bouton Arrêt du pc, majaro s'arrête proprement, contrairement aux autres essais ou je fais un forced shutdown en maintenant le bouton arrêt pendant plusieurs secondes, autrement je ne peux plus redémarre le pc (la clef usb ne clignotant plus et après plusieurs dizaines de secondes sans voir défiler le listing des commandes).

A noter si cela a une importance selon le mode (free/non-free), je reste bloqué plus ou moins longtemps sur 2 commandes :

A job start is running for livemedia MHWD script
et

reached target graphical interface
Pour résumer sauf à utiliser le mode "nomodeset" je suis systématiquement bloqué sur une de ces 2 lignes, ma clef usb freeze le pc n'est plus fonctionnel.

A noter que je n'ai pas de changements sur une led capslock qui pourrait clignoter ou quelque chose dans le genre.

Résultat, je suis bloqué encore une fois, en espérant que tu aura une idée ingénieuse à ma proposer.

Merci d'avance.

GPU nvidia HS, qui bloque démarrage Linux

#6Messageil y a 3 mois

as tu bien vérifié les options dans le bios ,
avant de démarrer sur la clé USB ?

tu vas juste tenter en ajoutant ce paramètre
acpi_os=! acpi_osi="Windows 2009"
sinon
acpi_os=! acpi_osi="Windows 2012"
sinon
acpi_os=! acpi_osi="Windows 2015"

GPU nvidia HS, qui bloque démarrage Linux

#7Messageil y a 3 mois

Dans le bios, je n'ai absoluement aucune options concernant les CG.

Pour tes options à rajouter, je relance en driver non-free ou en nomodeset ?

GPU nvidia HS, qui bloque démarrage Linux

#8Messageil y a 3 mois

tu relance en drivers non-free

GPU nvidia HS, qui bloque démarrage Linux

#9Messageil y a 3 mois

Bon, c'est pas gagné.

Avec les lignes 2009 et 2012, je plante à la ligne

reached target graphical interface
, freeze total système.
Avec la ligne 2015, je passe à une ligne de plus que ci-dessus et le système freeze à la ligne

Started TLP system Startup/Shutdown
.

Une idée doc ?

GPU nvidia HS, qui bloque démarrage Linux

#10Messageil y a 3 mois

tente si tu peux avoir un TTY ( Ctrl+ Alt + F2 )
sinon ajoute en plus
acpi_os=! acpi_osi="Windows 2009" servicemd.mask=mhwd-live.service

si tu obtiens le TTY
faire alors un retour de

inxi -Fxxxz
pour acpi , accepter osi windows 7 , pour mhwd , ne plus tenir compte de la base manjaro pour la config graphique ,
normalement tu devrais avoir le TTY
Modifié en dernier par stephane le 02 Déc 2018, 17:59, modifié 1 fois.

GPU nvidia HS, qui bloque démarrage Linux

#11Messageil y a 3 mois

J'ai tenté le TTY, freeze complet
Ok je réessaye avec l'autre ligne.

Si ca fonctionne il faudra que tu me dises en 2 lignes à quoi servent ces commande :)

GPU nvidia HS, qui bloque démarrage Linux

#12Messageil y a 3 mois

Fonctionne pas, je plante au même endroit :

Started TLP system startup/shutdown
Pas de TTY disponible

Tu as encore autre chose sous le coude ?

GPU nvidia HS, qui bloque démarrage Linux

#13Messageil y a 3 mois

hélas non , hormis demander sur le forum manjaro.org :
ce qui m'ennuie dans cet histoire c'est un portable récent

mais on a tous les problèmes avec bumblebee , et les cartes Nvidia & bios impose une vérification au démarrage ,
qui bloque la carte nvidia , même si tu ne l'utilise pas
Modifié en dernier par stephane le 02 Déc 2018, 18:20, modifié 1 fois.

GPU nvidia HS, qui bloque démarrage Linux

#14Messageil y a 3 mois

Oui, le pc à quelques mois, MSI , c'est fini, en portable il n'y a qu'une marque qui ait vraiment été fiable c'est Toshiba, puis samsung et la MSI c'est franchement une daube !

Ok, je vais tenter le coup sur le forum anglais, merci en tout cas pour le temps passé à m'aider.

Bonne soirée

GPU nvidia HS, qui bloque démarrage Linux

#15Messageil y a 3 mois

Bonjour,
J'ai trouvé une solution radicale qui fait que Manjaro fonctionne très bien : j'ai désactivé la carte Nvidia dans le bios de mon PC portable HP. Et c'est pas faute d'avoir essayer de la faire fonctionner (hein Stéphane ?)
Ouais, je sais, cela ne va pas convenir à tout le monde... :shock: Mais j'ai fait mon choix, il faut tester aussi cette solution

GPU nvidia HS, qui bloque démarrage Linux

#16Messageil y a 3 mois

Salut l'ami, je n'ai pas cette option dans mon bios, j'y avais bien pensé :(

Répondre