Problèmes et questions concernant le noyau et le support matériel.
Répondre

Problème systemd

#1Messageil y a 3 mois

Hello,

Depuis maintenant quelques maj il m'arrive lors de l’arrêt de la machine de voir un message rapidement concernant un problème avec systemd.

Comme ce message est très rapide, je n'ai pas eu le temps de tout voir mais voilà ce qu'il est écrit :

" Transport npoint is not connected "

( Ce message n'est la qu'une fois sur deux pas tout le temps )

Après avoir chercher sur internet j'ai vu pas mal de chose mais aucune info sur comment résoudre ce soucis.

Devant le message il y avait écris systemd.

Ps : Je ne suis pas certain d'avoir poster dans la bonne section mais je ne savais pas ou le mettre d'autre.

Merci

Problème systemd

#2Messageil y a 3 mois

Bonjour.
Je suppose que c'est 'endpoint' et non 'npoint'. Pour le savoir, tu devrais retrouver l'erreur dans journalctl -b1 -p3 | grep 'transport' .
L'option -b0 pour le boot actuel, -b1 pour le boot précédent, -b2 pour celui d'avant, etc.... et après |grep, entre les délimiteurs, un mot clé pour limiter une remontée très verbeuse.
Je suppose que le point de montage par défaut /mnt est déconnecté trop tôt lors de l'extinction de la machine, soit par le kernel, soit par systemd. Il faudrait voir si tu as ce message avec un noyau plus ancien.

Problème systemd

#3Messageil y a 3 mois

La commande ne retourne rien du tout.
J'avais déjà tester de voir dans le journal mais impossible de voir le message juste avant l'extinction du pc.

Problème systemd

#4Messageil y a 3 mois

Hello,

Je viens poster des nouvelles car je n'ai toujours pas trouver la réponse.

Sur le deuxième pc j'ai installer des petites choses hier soir et lors de l’arrêter j'ai eu le message ( même pas une demi seconde juste après le message " power off "

Je me demande si le problème n'est pas lier à colorls et ruby.

Qu'en pensez vous ?

Problème systemd

#5Messageil y a 3 mois

Bon je fait une petite update sur mon poste.

J'ai chercher partout pour trouver l'erreur mais elle n'est pas enregistrer dans journalctl
Je vais donc enregistrer une vidéo lors de chaque extinction du pc et essayer d'avoir cette fameuse erreur en vidéo histoire de savoir ce qu'elle dit exactement.

J'ai chercher partout sur internet pour voir d’où cela peut venir mais j'ai trouver a boire et à manger.

J'ai tester différents noyaux mais j'ai eu cette erreur avec tout les noyaux que j'ai tester.

J'ai désinstaller tout ce qui concerne colorls et toutes les dépendances de AUR et sur les dépots officiels. ( Je me suis même si que colorls ou une des dépendances ruby était malveillante et que l'erreur venait de là.

Donc pour le moment vidéo lors de l’arrêt et bien regarder si cette erreur est encore la après la suppression de colorls et des dépendances. SInon cela viens peut être de la dernière maj des noyaux.

Je détail tout cela car si une personne a le même soucis que moi il aura une idée pour orienter ces recherches.

ps : depuis que j'ai cette erreur j'ai les pc qui sont beaucoup plus lent et ont beaucoup plus de mal

Problème systemd

#6Messageil y a 3 mois

je n'arrive pas à comprendre comment tu fais le lien entre colorls et ton erreur ...
En cherchant sur le web, ton erreur me semble être liée à un problème de montage d'une partition - sans doute que systemd n'arrive pas à bien démonter une certaine partition à l'extinction (qui peut être sur une autre machine)

Problème systemd

#7Messageil y a 3 mois

Je parle de colorls car c'est le dernier programme que j'ai mis sur les deux pc.

J'ai réussi à capturer l'erreur.

https://ibb.co/zJKQ0gH

J'ai cette erreur sur tout les pc que j'ai.

Pacman -Syyuu ne montre rien
Pacman - Syyu ne montre rien

Tout est à jour. Le soucis viens lorsque j'arrête le pc ( je n'ai rien fait de spécial et le deuxième pc je l'allume juste pour faire les majs )

Pc 1 4.14 même erreur
Pc 2 4.19 même erreur

Avoir la même erreur sur plusieurs pc juste après avoir les majs

Logiciel que j'ai installer récemment

Tmux tilix falkon colorls neovim + la version qt yakuake ( drop down terminal )

Voilà toutes les infos que j'ai.

Ps : Toutes les partitions monter sont sur le même disque dur. 1 seul disque par machine
La seule chose externe c'est google drive dans dolphin

Merci

[Edit] :
Hello,
Comme je n'arrivais pas à régler ce problème j'ai fait appel à un collègue spécialiste dans les grosses infrastructure réseau linux.
Il a fait plein de choses dessus et au final tout remarche correctement.
Je ne saurais vous dire quoi exactement donc je préfère ne rien dire plutôt que de dire des bêtises.

Problème systemd

#8Messageil y a 2 mois

Bon je rouvre le sujet car le problème est revenu ( je ne l'avais pas eu durant plus d'une semaine )

Log erreur dans le journalctl

févr. 28 05:34:16 cyberdr3am-pc gdm[349]: GLib: g_hash_table_find: assertion 'version == hash_table->version' failed
févr. 28 05:34:17 cyberdr3am-pc kglobalaccel5[13724]: This application failed to start because no Qt platform plugin could be initialized. Reinstall>
                                                       
                                                       Available platform plugins are: wayland-org.kde.kwin.qpa, dxcb, eglfs, linuxfb, minimal, mini>
févr. 28 05:34:17 cyberdr3am-pc drkonqi[13737]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling th>
                                                 
                                                 Available platform plugins are: wayland-org.kde.kwin.qpa, dxcb, eglfs, linuxfb, minimal, minimalegl>
févr. 28 05:34:18 cyberdr3am-pc systemd-coredump[13768]: Failed to send coredump datagram: Broken pipe
févr. 28 05:34:18 cyberdr3am-pc systemd-coredump[13785]: Failed to connect to coredump service: Connection refused
Un de vous a une idée ?

Problème systemd

#9Messageil y a 2 mois

Bonjour.
Apparemment, c'est lié à kglobalaccel... As tru essayé la version git ? (Aur)
Je n'ai pas KDE, donc je passe la main :wink:

Problème systemd

#10Messageil y a 2 mois

:bjr:
Et moi, je ne connais pas gdm :lol:

En tout cas cela me semble être un tout autre problème qui n'a rien à voir avec le précédent
2 messages de 2 apps: This application failed to start , donc en plus cela est au démarrage ?

et voir no Qt platform plugin avec gdm me laisse de glace :rendre:

Problème systemd

#11Messageil y a 2 mois

:bjr:
Je n'ai pas GDM non plus :gsourire:
Si c'est lié au DM, il faudrait se connecter via startx pour voir.

Problème systemd

#12Messageil y a 2 mois

Ce message je l'ai eu lors de l'arret du pc.

Voilà ce qu'il y a entre les erreurs

févr. 28 05:34:17 cyberdr3am-pc kdeinit5[779]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not su>
févr. 28 05:34:18 cyberdr3am-pc mkinitcpio[13687]: ==> Build complete.
févr. 28 05:34:17 cyberdr3am-pc kdeinit5[779]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not su>
févr. 28 05:34:17 cyberdr3am-pc kdeinit5[779]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not su>
févr. 28 05:34:17 cyberdr3am-pc kdeinit5[779]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not su>
févr. 28 05:34:17 cyberdr3am-pc kdeinit5[779]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not su>
févr. 28 05:34:17 cyberdr3am-pc kdeinit5[779]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not su>
févr. 28 05:34:17 cyberdr3am-pc kglobalaccel5[13724]: qt.qpa.xcb: could not connect to display :0
févr. 28 05:34:17 cyberdr3am-pc kglobalaccel5[13724]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
févr. 28 05:34:17 cyberdr3am-pc kglobalaccel5[13724]: This application failed to start because no Qt platform plugin could be initialized. Reinstall>
                                                       
                                                       Available platform plugins are: wayland-org.kde.kwin.qpa, dxcb, eglfs, linuxfb, minimal, mini>
févr. 28 05:34:17 cyberdr3am-pc drkonqi[13737]: qt.qpa.xcb: could not connect to display :0
févr. 28 05:34:17 cyberdr3am-pc drkonqi[13737]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
févr. 28 05:34:17 cyberdr3am-pc drkonqi[13737]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling th>
                                                 
                                                 Available platform plugins are: wayland-org.kde.kwin.qpa, dxcb, eglfs, linuxfb, minimal, minimalegl>
févr. 28 05:34:17 cyberdr3am-pc kdeinit5[779]: The X11 connection broke: I/O error (code 1)
févr. 28 05:34:18 cyberdr3am-pc systemd[1]: Requested transaction contradicts existing jobs: Transaction for systemd-coredump@0-13768-0.service/star>
févr. 28 05:34:18 cyberdr3am-pc systemd[1]: systemd-coredump.socket: Failed to queue service startup job (Maybe the service file is missing or not a>
févr. 28 05:34:18 cyberdr3am-pc systemd[1]: systemd-coredump.socket: Failed with result 'resources'.
févr. 28 05:34:18 cyberdr3am-pc systemd-coredump[13768]: Failed to send coredump datagram: Broken pipe
févr. 28 05:34:18 cyberdr3am-pc systemd-coredump[13785]: Failed to connect to coredump service: Connection refused
févr. 28 05:34:18 cyberdr3am-pc systemd[1]: mkinitcpio-generate-shutdown-ramfs.service: Succeeded.
févr. 28 05:34:18 cyberdr3am-pc systemd[1]: Started Generate shutdown-ramfs.
févr. 28 05:34:19 cyberdr3am-pc systemd[1]: session-c2.scope: Succeeded.
févr. 28 05:34:19 cyberdr3am-pc systemd[1]: Stopped Session c2 of user cyberdr3am.
févr. 28 05:34:19 cyberdr3am-pc systemd[1]: Stopping User Manager for UID 1000...
D'après ce que j'ai vu c'est un soucis avec systemd. Pour gdm je peut remettre lightdm si il faut. Je l'avais mis pour régler des problèmes il y a un certain temps.

Problème systemd

#13Messageil y a 2 mois

Bon j'ai fait plusieurs test.

J'ai changer gdm ( que j'avais mis pour éviter d'avoir des soucis d'affichage mais comme ils sont régler j'ai remis lightdm qui était la au début lors de l'installation du pc )
J'ai arreter le pc via le terminal et en tty et je n'ai pas eu l'erreur avec ces deux méthodes.

Je vais donc continuer d'utiliser le pc et voir si j'ai encore ce message avec toutes les modifs que j'ai fait.

Répondre