Problèmes et questions concernant le noyau et le support matériel.
Répondre

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#1Messageil y a 2 mois

Bonsoir,
J'ai posté un bug à (https://bugzilla.kernel.org/show_bug.cgi?id=206769)

Ma carte son fonctionne uniquement sur le kernel : 5.4.23-1 mais pas sur le kernel 5.5.7-1 et d'autres kernel plus anciens...

Voici leur réponse :
Ask you distribution to add the support for this hardware (firmware, pulseaudio, alsa-ucm) or add snd-intel-dspcfg.dsp_driver=1 kernel parameter as the boot options. See 'modinfo snd-intel-dspcfg' for more details.

Que dois je faire exactement ?

Merci

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#2Messageil y a 2 mois

1) voir si manjaro a bien le bon firmware pour le DSP
2) ajouter au boot ( Esc au demarrage , (e) edit )
ajouter sur la ligne de boot kernel snd-intel-dspcfg.dsp_driver=1
puis F10 ou Ctrl+ X ( option valide uniquement pour ce boot )

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#3Messageil y a 2 mois

Salut,

Tu peux essayer de charger le driver en manuel pour tester (système démarré avec le noyau 5.5).
Dans un terminal :

sudo modprobe snd_intel_dspcfg
s'il n'y a pas de message, c'est qu'il devrait être chargé.
Pour être sur :

lsmod | grep snd_intel_dspcfg
devrait afficher une ligne avec le nom du module.

Reste à voir si ça suffit pour que ta carte son fonctionne. Si c'est suffisant, il faudra faire une autre manipulation pour charger le module à chaque démarrage, sinon il faudra agir, comme mentionné par stephane, au niveau des options du noyau.

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#4Messageil y a 2 mois

$ sudo modprobe snd_intel_dspcfg
C'est passé sans erreur !

lsmod | grep snd_intel_dspcfg
snd_intel_dspcfg 28672 4 snd_hda_intel,snd_sof_pci,snd_sof_intel_hda_common,snd_soc_skl

Mais toujours pas de son :desole:

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#5Messageil y a 2 mois

verifie

sudo journalctl -b0 -g sof-audio-pci

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#6Messageil y a 2 mois

Avec cette méthode ca marche ;)

"1) voir si manjaro a bien le bon firmware pour le DSP
2) ajouter au boot ( Esc au demarrage , (e) edit )
ajouter sur la ligne de boot kernel snd-intel-dspcfg.dsp_driver=1
puis F10 ou Ctrl+ X ( option valide uniquement pour ce boot )"

Mais tu peux me dire comment le mettre définitivement au boot grub STP ?

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#7Messageil y a 2 mois

alors tu va modifier le fichier suivant
sudo nano /etc/default/grub
et sur la ligne
GRUB_CMDLINE_LINUX_DEFAULT="..." <-- tu ajoute la ligne ici
GRUB_CMDLINE_LINUX="" <-- ou là

tu sauve et tu met à jour sur la partir démarrage

sudo update-grub

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#8Messageil y a 2 mois

Oh la la !!!!! Ca marche !!!! bravo les gars !! :bien
Merci beaucoup :gsourire:

P.S Si vous avez une info pour activer le pavé numérique au boot de Manjaro et ça sera parfait :gsourire:

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#9Messageil y a 2 mois

ok pas de pb

merci

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#10Messageil y a 2 mois

williams a écrit :
il y a 2 mois

P.S Si vous avez une info pour activer le pavé numérique au boot de Manjaro et ça sera parfait :gsourire:
Bobjour,
Bien que hors sujet..., Peut-être la solution ici, :wink:

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#11Messageil y a 2 mois

Merci beaucoup ;)
P.S ca marche pas mais c'est pas grave ;)

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#12Messageil y a 2 mois

Bonjour,
En complément, Il faut ''Aussi'' dans la section prévue, activer le pavé numérique au démarrage.... :!:
Mais, on ne sait pas sous quel Environnement de bureau (DE) tu es ? : kde, xfce...? => il faudrait le préciser dans ta signature....Merci, car çà aidera les intervenants... :sourire:

Pour KDE/Plasma ( je ne connais pas les autres DE ):
Configuration du système/Matériel, Périphériques d'entrée/Clavier => Verrouillage numérique au démarrage plasma :
Cocher Activer .
Et la prise en compte sera prise au prochain re-démarrage de Manjaro...

Il serait mieux pour toi d'ouvrir un autre sujet...

Carte son plus reconnue kernel Linux 5.6rc3 & Linux 5.5.7-1

#13Messageil y a 2 mois

Oui je l'ai déjà fait 😉 mais rien à faire
J'ouvrirais un poste effectivement...
Merci

Répondre