Problèmes et questions concernant le noyau et le support matériel.
Répondre

Enlever Kernel 5.4.22-1

#1Messageil y a 2 mois

Bonjour tout le monde
Suite à la Maj du 28/02, (ou j'ai commencé à évoquer le pb) je me suis retrouvé avec le noyau 54, alors que je n'avais que le 414 et le 419 (utilisé) d'installé
Je me suis retrouvé sans connexion internet (idem que lors d'un essai précédent, après lequel je l'avais désinstallé)
En voulant l'enlever par la configuration du système, j'ai la reponse suivante :

removing linux54-nvidia-435xx breaks dependency 'linux54-nvidia-435xx' required by linux-lts-nvidia-435xx
Suite aux indications de lemust j'ai fait :

[michelr@michel-pc ~]$ sudo mhwd -r pci linux-lts-nvidia-435xx linux54-nvidia-435xx 
[sudo] Mot de passe de michelr : 
Error: config 'linux-lts-nvidia-435xx' is not installed!
[michelr@michel-pc ~]$ sudo mhwd -r pci linux54-nvidia-435xx                       
Error: config 'linux54-nvidia-435xx' is not installed!
[michelr@michel-pc ~]$ sudo mhwd-kernel -r pci linux54
Error: Please enter a valid kernel name.
Currently running: 4.19.106-1-MANJARO (linux419)
The following kernels are installed in your system:
   * linux414
   * linux419
   * linux54
D'un coté linux-lts-nvidia-435xx et linux54-nvidia-435xx ne sont pas installés, de l'autre j'ai la même réponse que plus haut :confus:
Pour le noyau j'ai essayé "linux54"(réponse ci-dessus), "5.4.22-1-MANJARO","linux 5.4.22-1"...même réponses.
Je sèche un peu là :sos:
Michel

Enlever Kernel 5.4.22-1

#2Messageil y a 2 mois

bonjour,

c'est en fait que tu as d'installé le méta-paquet linux-lts et non linux54 directement ; et qu'il pointe actuellement sur linux54, il faut donc dé-installer ce paquet

Enlever Kernel 5.4.22-1

#3Messageil y a 2 mois

Bonjour
Merci papajoke pour ta réponse.
Etant donné que j'utilise le 419 et que j'ai en second noyau le 414, et qu'ils sont tous les deux LTS, est-ce que la suppression du méta-paquet linux-lts, ne va pas poser problème?
Est-ce qu'il faut que je mette en relais un "non lts", supprimer linux-lts, et réinstaller directement le 419 et le 414 ?
Merci d'avance
Michel

Enlever Kernel 5.4.22-1

#4Messageil y a 2 mois

Salut,
michel ruiz a écrit :
il y a 2 mois
Etant donné que j'utilise le 419 et que j'ai en second noyau le 414, et qu'ils sont tous les deux LTS, est-ce que la suppression du méta-paquet linux-lts, ne va pas poser problème?
Est-ce qu'il faut que je mette en relais un "non lts", supprimer linux-lts, et réinstaller directement le 419 et le 414 ?
Le paquet linux-lts pointe vers le noyau 5.4 seulement, donc le 4.14 et le 4.19 ne seront pas touchés.

Dépend de                : linux54
Les méta-paquets comme linux-latest ou linux-lts sont très bien pour les gens qui n'osent pas changer de noyau. Ça se fait automatiquement pendant une mise à jour, sans leur intervention, par contre, ce n'est pas l'idéal quand on a l'habitude de faire les changements manuellement, je ne veux pas qu'on me force la main, je n'ai donc pas ces méta-paquets installés.

Le 4.19 et le 5.4 ont un support court qui dure deux ans.
Version Maintainer Released Projected EOL
5.4 Greg Kroah-Hartman & Sasha Levin 2019-11-24 Dec, 2021
4.19 Greg Kroah-Hartman & Sasha Levin 2018-10-22 Dec, 2020
4.14 Greg Kroah-Hartman & Sasha Levin 2017-11-12 Jan, 2024
4.9 Greg Kroah-Hartman & Sasha Levin 2016-12-11 Jan, 2023
4.4 Greg Kroah-Hartman & Sasha Levin 2016-01-10 Feb, 2022
3.16 Ben Hutchings 2014-08-03 Jun, 2020

Enlever Kernel 5.4.22-1

#5Messageil y a 2 mois

Merci smurf, pour ta réponse qui m'éclaire un petit peu .
Mais :

[michelr@michel-pc ~]$ sudo mhwd -r pci linux-lts
[sudo] Mot de passe de michelr : 
Error: config 'linux-lts' is not installed!
[michelr@michel-pc ~]$ 
Je suis allé voir dans octopi, à l'appel de "linux-lts", seul linux-lts-nvidia-435xx était indiqué installé (alors que la réponse à la commande mhwd me donnait l'inverse :confus: )
J'ai utilisé octopi pour la suppression et en fait les noms des packages à supprimer étaient:

Packages (2) linux-lts-nvidia-435xx-1:5.4-1  linux54-nvidia-435xx-435.21-26
Et là j'ai pu enlever le 5.4.22-1 :bien

Merci aussi pour l'info sur les échéances des supports noyaux

Michel
Dernière modification par michel ruizil y a 2 mois, modifié au total 1 fois.

Enlever Kernel 5.4.22-1

#6Messageil y a 2 mois

J'ai une carte graphique AMD, donc pas de pilote lié à la version de noyau, quand je veux installer ou supprimer un noyau, j'utilise la commande mhwd-kernel.

edit : cette commande ne marche que pour les noyaux, pas les paquets latest ou lts.

mhwd-kernel -l                                                                       
available kernels:
   * linux316
   * linux414
   * linux419
   * linux44
   * linux49
   * linux54
   * linux55
   * linux56
   * linux419-rt
   * linux54-rt

Enlever Kernel 5.4.22-1

#7Messageil y a 2 mois

Merci smurf
Je note la commande, elle resservira
Michel

Répondre