Problèmes et questions concernant le noyau et le support matériel.
Répondre

KDE Setting réglage sortie audio manquante - Pb contourné

#1Messageil y a 1 mois

Bonjour
Ma config :
Système d'exploitation : Manjaro Linux
Version de KDE Plasma : 5.18.3
Version de KDE Frameworks : 5.68.0
Version de Qt : 5.14.1
Version de noyau : 5.4.28-1-MANJARO

15: PCI 1b.0: 0403 Audio device 
 SysFS ID: /devices/pci0000:00/0000:00:1b.0 
 SysFS BusID: 0000:00:1b.0 
 Hardware Class: sound 
 Model: "Intel 9 Series Chipset Family HD Audio Controller" 
 Vendor: pci 0x8086 "Intel Corporation" 
 Device: pci 0x8ca0 "9 Series Chipset Family HD Audio Controller" 
 SubVendor: pci 0x1458 "Gigabyte Technology Co., Ltd" 
 SubDevice: pci 0xa182  
 Driver: "snd_hda_intel" 
 Driver Modules: "snd_hda_intel" 
 Memory Range: 0xf7f10000-0xf7f13fff (rw,non-prefetchable) 
 IRQ: 35 (833 events) 
 Module Alias: "pci:v00008086d00008CA0sv00001458sd0000A182bc04sc03i00" 
 Driver Info #0: 
   Driver Status: snd_hda_intel is active 
   Driver Activation Cmd: "modprobe snd_hda_intel"

17: PCI 300.1: 0403 Audio device 
 SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0/0000:02:00.0/0000:03:00.1 
 SysFS BusID: 0000:03:00.1 
 Hardware Class: sound 
 Model: "ATI Navi 10 HDMI Audio" 
 Vendor: pci 0x1002 "ATI Technologies Inc" 
 Device: pci 0xab38 "Navi 10 HDMI Audio" 
 SubVendor: pci 0x1da2 "Sapphire Technology Limited" 
 SubDevice: pci 0xe421  
 Driver: "snd_hda_intel" 
 Driver Modules: "snd_hda_intel" 
 Memory Range: 0xf7ca0000-0xf7ca3fff (rw,non-prefetchable) 
 IRQ: 36 (475 events) 
 Module Alias: "pci:v00001002d0000AB38sv00001DA2sd0000E421bc04sc03i00" 
 Driver Info #0: 
   Driver Status: snd_hda_intel is active 
   Driver Activation Cmd: "modprobe snd_hda_intel" 
 Attached to: #11 (PCI bridge)

Mon Pb
[/color]
Sans modification de hardware lors d'une des dernières MAJ j'ai perdu dans le panneau de config de KDE le réglage des sorties audio :
Normalement je devrais avoir ça :
https://framapic.org/OGg1hxD9jRUK/SDkGreWRxWSk.png
et j'ai ça
https://framapic.org/ow8soSNgKzR3/HxDGeFOESjeH.png

J'ai éteint la sortie HMDI .
Combien même je ne peux avoir le son que sur les enceintes, pas sur le casque banché sur jack ? comment puis-je récupérer ce réglage ?
Dernière modification par Gilllesil y a 1 mois, modifié au total 2 fois.

KDE Setting réglage sortie audio manquante - Pb contourné

#2Messageil y a 1 mois

Personnellement, je ne règle pas mes entrées - sorties - enregistrements via le panneau de configuration de KDE, mais directement depuis pulseaudio.
Là, j'ai toutes les possibilités de réglages.
Je ne sais si cela peut t'aider... :saispas:

KDE Setting réglage sortie audio manquante - Pb contourné

#3Messageil y a 1 mois

Merci Obé, voila un conseil très judicieux !
et tu fais ça comment ?

... j'ai cherché Pulseaudio GUI et j'ai trouvé j'ai "pavucontrol"

5 aur/pavucontrol-qt-git 0.2.0.20.g3d26e86-1 (+5 0.00%) 
    Qt port of pavucontrol
.

pécable j'ai retrouvé ma boite dialogue dans cet outil casque fonctionnel

obé c'est pas pour rien qu'il est tombé dans la potion magique quand il était petit :bien

Je ne dirais pas résolu c'est plus une méthode de contournement, mais ça marche

KDE Setting réglage sortie audio manquante - Pb contourné

#4Messageil y a 1 mois

bonjour

il me semble (confus dans mon esprit) que pour le son :
- avant nous avions phonon ou pulseaudio
- depuis peu kde ne supporte plus que pulseaudio

normalement pavucontrol n'a pas d’intérêt puisque c'est un gui à pulseaudio comme notre plasma-pa

---
et l'interface qui change à chaque maj :maisnon: mal de crane assuré :mrgreen:
Image
Donc dans ton image, kde ne voit qu'un seul périphérique de disponible pour la lecture (sinon maintenant il ne propose plus un combo liste à sélectionner mais une liste avec un bouton "par défaut" uniquement si plusieurs périphériques)

KDE Setting réglage sortie audio manquante - Pb contourné

#5Messageil y a 1 mois

Ok j'ai pigé :tetu!

sur mon boitier pc j'ai les sorties son comme tout le monde à l'arrière, mais sur le panel avant j'ai aussi une prise casque + micro.
Mes enceintes sont branchées à l'arrière et mon casque à l'avant et donc plasma-pa ne détecte pas mon casque et donc ne l'affiche pas tandis que pavucontrol lui me propose toujours le combo avec pour choix :
sortie ligne enfichée
casque audio non enfichée

il faudrait que plasma-pa m'affiche tout le temps la ligne casque

KDE Setting réglage sortie audio manquante - Pb contourné

#6Messageil y a 1 mois

même config et plama-pa détecte bien le casque :saispas:
Image

si casque est branché, il commute en automatique, le combo me propose "casque/sortie ligne"

----
Par contre... si casque branché, impossible de commuter vers mes enceintes - le combo le propose (copie écran + haut), mais le son est toujours vers le casque

KDE Setting réglage sortie audio manquante - Pb contourné

#7Messageil y a 1 mois

On va pas se prendre la tête pavu fait le taff ...

De toute façon comme j'ai fait un nettoyage de printemps des orphelins un peu comme un bourrin j'avoue
l'age sans doute :pappy:

...plus de connexion réseau les config sont toujours dans networkmanager, mais il ne se connecte plus au réseau

Sauf a ce que vous ayez une solution "miracle" je suis mûr pour une ré-install

KDE Setting réglage sortie audio manquante - Pb contourné

#8Messageil y a 1 mois

Ré-install toute fraîche faite, et pas mieux sur la gestion de la sortie son casque ...
je gardes mon parucontrôle

... par contre le nouveau splash de Grub est plutôt élégant

KDE Setting réglage sortie audio manquante - Pb contourné

#9Messageil y a 1 mois

Écoute, je ne sais pouquoi, j'ai eu la même blague.

C'est-à-dire que sur le panneau avant, lorsque j'ai branché mon casque, rien n'était reconnu. J'ai été obligé de le brancher à l'arrière, directement sur la carte son pour qu'il soit reconnu.

À l'avant, rien à faire. Or, auparavant, un casque d'une autre marque était reconnu. Tu me rassures, je pensais que ma "prise" avant était fichue... :colère:

Répondre