Problèmes et questions concernant le noyau et le support matériel.

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#21Messageil y a 5 ans

Quoi dire ? je vous décerne mon cher modérateur la médaille des platines ;-) ( private joke !! ) , en plus d"être sympa les routiers, ne sont pas manchots ? !! la biz poulet ( comme on dis au rugby ? GUERRIER, JE T'ADMIRES, ET JE TE BADES !!

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#22Messageil y a 5 ans

Bonjour @ tous. :salut:
Je remonte ce sujet car nous avons enfin trouvé comment installer readesm sous Manjaro.
Voir le premier message que j'ai édité .
Merci d'en parler autour de vous si vous connaissez des chauffeurs ayant quelques notions de Linux. :gsourire:

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#23Messageil y a 5 ans

Bonjour @ tous :bjr:
Ce petit "up" pour vous dire que j'ai modifié readesm pour l'avoir en français ,(et pas que dans le texte)
:clindoeil:

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#24Messageil y a 5 ans

Haha comme par hasard, je suis futur chauffeur SPL et ce genre de programme pourrait être très utile pour ma propre carte ^^


Et si, il y a des chauffeurs sur linux ! :gsourire:

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#25Messageil y a 4 ans

Ce nouveau up pour vous annoncer une nouvelle version de readesm-fr.2.4 corrigeant le défaut de francisation du message d'accueil, une inversion de termes dans la légende graphique et autres bricoles....
Prochaine étape et non des moindre, rediriger la destination des fichiers d'installation qui pointent actuellement vers /usr/local. Cette instruction est enracinée dans le code source.....Je ne suis pas contre un petit coup de main :clindoeil:

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#26Messageil y a 4 ans

c'est toi qui a la main sur les sources maintenant ? parce que plutôt que d'agir dans le PKGBUILD, on peut régler les variables de Cmake...
il y a deux solutions je pense:
soit directement à la source, changer le CMAKE_INSTALL_PREFIX dans cmake_install.cmake (au début)

# Set the install prefix
if(NOT DEFINED CMAKE_INSTALL_PREFIX)
  set(CMAKE_INSTALL_PREFIX "/usr/local")
endif()
string(REGEX REPLACE "/$" "" CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}")

on change en:

# Set the install prefix
if(NOT DEFINED CMAKE_INSTALL_PREFIX)
  set(CMAKE_INSTALL_PREFIX "/usr")
endif()
string(REGEX REPLACE "/$" "" CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}")


ou alors, on laisse cette valeur par défaut, et on inclue un "set" dans CmakeLists.txt (vers la fin)

#packaging
if(UNIX)
endif()

à modifier en

#packaging
if(UNIX)
  set(CMAKE_INSTALL_PREFIX "/usr")
endif()


après, si tu n'as pas la main sur les sources, on pourra toujours passer des options dans le PKGBUILD
note que tu peux lancer Makepkg avec l'option --noprepare, ce qui t'évite la construction du paquet à la fin et te permet de regarder comme ça a été agencé dans le répertoire de destination

NB: c'est vrai que /usr/local est bien quand on compile et installe à la main, mais là, comme on fait un paquet, ça n'a pas de sens...

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#27Messageil y a 4 ans

:bjr:
J'ai déjà testé la première solution ,et je me retrouve avec deux exécutables ; un dans /usr/bin , l'autre dans /usr/local/bin....
J'ai aussi modifié "à chaud" le manifest.install généré par cmake .Evidemment ,cmake refuse de compiler...
J'essaierai ta seconde proposition.
Edit: Pour les sources ,ce programme semble à l'abandon depuis 2011 et est hébergé sur un dépôt Subversion.
J'avais fait un paquet readesm original qui pointe vers ce dépôt puis j'ai recueilli les sources que j'ai modifiées à ma sauce sur SourceForge .C'est là que pointe ce nouveau PKGBUILD.

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#28Messageil y a 4 ans

Bon ,j'ai essayé l'option set dans cmake.list

#packaging
if(UNIX)
  set(CMAKE_INSTALL_PREFIX "/usr")
endif()
et les fichiers vont bien dans /usr mais je perd la traduction. Il me faut dans ce cas reprendre tous les liens...Pfuu comme qui dirait :clindoeil:

Du coup , j'ai noté une curiosité; si vous allez sur https://aur.archlinux.org/packages/readesm-fr/ voir le PKGBUILD ,celui-ci est erroné puisqu'il est en fait l'ancien (2.2).
Par contre

yaourt -G readesm-fr
télécharge dans le home le bon PKGBUILD.
En gros, se méfier de la fonction "voir le pkgbuild" de Aur.

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#29Messageil y a 4 ans

La façon la plus propre de modifier les variables définies dans le cmake file est d'utiliser l'option -D. Ici, en l'occurrence, cela donnerait :

cmake -DCMAKE_INSTALL_PREFIX="/usr" ..

Pour ce qui est de la traduction, je n'arrive pas à voir, par contre.
Pour connaître toutes les variables utilisées pour le cmake :

cmake -LAH

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#30Messageil y a 4 ans

:salut:
Merci pour l'info .
Je fais un petit <break;;> et je m'y remet :clindoeil:

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#31Messageil y a 4 ans

S3B a écrit :
Loubrix a écrit :au passage, je rappelle que le logiciel Cardpeek est capable de lire plein d'autres cartes à puce (je me demande s'il saurait accéder au nouveau permis de conduire).

Ça m’intéresserais également, vu que je viens de le recevoir suite à ma visite PL


Je viens de faire l'essai. La carte n'est même pas reconnue. Y z'ont bien blindé le truc .... :tetu!

Chauffeurs PL:Lire sa carte chronotachygraphe sous Linux

#32Messageil y a 2 ans

Bonjour @ tous.
Mise à jour de acsccid , ce pilote nécessaire pour les lecteurs de cartes à puce.
A noter que cardpeek doit être recompilé suite à la dernière mise à jour de GTK.
Les bons chiffres :clindoeil:

Répondre