Problèmes et questions sur les environnements graphiques et les applications.
Répondre

Uberwriter dans AUR cassé

#1Messageil y a 3 ans

Je suis tout triste : j'avais trouvé Uberwriter dans AUR, à ce stade c'est pour moi l'outil de markdown le plus élégant et le plus simple, mais depuis quelques jours, chez moi il est tout malade (plus possible de sauvegarder en pdf ou html) et je n'ai pu l'installer chez des amis sous Manjaro, car il manque une dépendance : pandoc-bin.
(pandoc existe, mais semble ne pas être pris en compte par Uberwriter)

Sous Xubuntu, je peux toujours installer tranquillou le .deb par contre.

Y aurait il une bonne âme pour m'aider à voir comment faire ? (ou m'indiquer une alternative aussi élégante, j'ai essayé remarkable, mais c'est beaucoup moins bien)

Je remarque d'ailleurs que Uberwriter ne semble plus actif sur lauchpad depuis... 2012 et sur github depuis 9 mois : https://github.com/wolfv/uberwriter ce qui est bien dommage, tant il me simplifie les rédactions !
Dernière modification par nam1962 le 05 Fév 2016, 10:06, modifié 1 fois.

Uberwriter dans AUR cassé

#2Messageil y a 3 ans

:bjr: Pourquoi ne pas installer 5 community/pandoc 1.16.0.2-13 et modifier le pkgbuild en conséquence ? ça coûte rien d'essayer :sourire: Sinon je compatis volontiers car j'ai du faire l'impasse sur certains logiciels que j'affectionnai particulièrement :snif

Uberwriter dans AUR cassé

#3Messageil y a 3 ans

Ah, là, je veux bien, mais il me serait utile qu'on me tienne la main ! ! (jamais fait :P )

Uberwriter dans AUR cassé

#4Messageil y a 3 ans

cours openclassroom mais il date :pleure: à l'époque il n'y avait pas de fonction package() alors que maintenant elle est obligatoire (j'ai quand même appris avec lui).

et les références :
* wiki arch (fr)
* wiki (en) : creating packages

et sinon on regarde les sources des autres : 30473 exemples à disposition sur le site web de aur :siffle

Uberwriter dans AUR cassé

#5Messageil y a 3 ans

Merci, me voilà moins bête !
Bon j'y ai été à la brutale en téléchargeant le pkgbuild et en amendant juste pandoc. (à propos, comment éventuellement modifier dans AUR ,)
Ca marche (presque : pas moyen de sauver en pdf alors que ça fonctionnait la semaine dernière).
Dommage que le projet semble en rade (je vais regarder en quoi c'est écrit, même si je suis nul comme dev)

[Edit] Résolu le problème de pdf en installant une palanquée de paquets texlive

Uberwriter dans AUR cassé

#6Messageil y a 2 mois

Tiens, je me suis rendu compte que le projet avait été repris !
On peut l'installer en flatpak.
Il y a un uberwriter-git dans aur, mais il ne démarre pas malgré l'installation de dépendances manquantes indiquées dans les commentaires.

L'ennui actuel du flatpak est qu'il dévore littéralement la CPU...

Uberwriter dans AUR cassé

#7Messageil y a 2 mois


Uberwriter dans AUR cassé

#8Messageil y a 2 mois

Ah oui, mais il est marqué obsolète (et n'embarque pas la dernière version d'Uberwriter ;) )

Uberwriter dans AUR cassé

#9Messageil y a 2 mois

nam1962 a écrit :
il y a 2 mois
Ah oui, mais il est marqué obsolète (et n'embarque pas la dernière version d'Uberwriter ;) )
Oui, mais c'est un utilisateur qui l'a marqué comme obsolète.
N'importe qui peut le faire.
caleb l'a marqué comme obsolète le 28/04/2019 car la version 2.1.5 est sortie. Mais le mainteneur du paquet n'a pas encore faite la mise à jour.
En tous cas, cette version fonctionne très bien :siffle:siffle

Édit : j'ai même eu une mise à jour aujourd'hui :gsourire:
Même s'il est toujours indiqué comme obsolète à cause de caleb

Uberwriter dans AUR cassé

#10Messageil y a 2 mois

Effectivement, là ça fonctionne.
Merci ! :bjr:
Donc le flatpak a un souci, j'ai ouvert un ticket pour çà.

Répondre