Problèmes et questions sur les environnements graphiques et les applications.
Répondre

Erreur dans un .desktop

#1Messageil y a 1 mois

Bonjour
Lorsque je clique droit sur xfce4-whiskermenu-plugin afin de modifier les applications, je vois cette erreur :
Fichier "desktop" invalide détecté ! Veuillez consulter les détails.
Et voici les détails

Erreurs d’interprétation. L'analyse des fichiers "desttop" suivant a échoué par la librairie sos-jacente et ne sera par conséquent pas affiché dans MenuLibre.
http://âpp.com/Hiwt
Voici le détail du fichier

[Desktop Entry]
Name[be]=Паглядзець файл
Name[ca]=Visualitza fitxer
Name[cs]=Zobrazení souboru
Name[da]=Vis fil
Name[de]=Datei betrachten
Name[el]=Προβολή αρχείου
Name[eo]=Vidi dosieron
Name[es]=Ver archivo
Name[eu]=Ikusi fitxategia
Name[fa]=نمایش پرونده
Name[fr]=Afficher le fichier
Name[fur]=Viôt file
Name[gl]=Ver ficheiro
Name[hr]=Prikaži datoteku
Name[hu]=Fájl megtekintése
Name[id]=Lihat berkas
Name[it]=Visualizza file
Name[ko]=파일 보기
Name[lt]=Rodyti failą
Name[lv]=Skatīt datni
Name[nl]=Bestand bekijken
Name[pl]=Wyświetl plik
Name[pt_BR]=Visualize um arquivo
Name[ro]=Vizualizează fișierul
Name[sl]=Pogled datoteke
Name[sr]=Погледај датотеку
Name[sv]=Visa fil
Name[tr]=Dosyayı görüntüle
Name[zh_CN]=查看文件
Name[zh_TW]=檢視檔案
Name=View file
MimeType=application/pkcs12;application/pkcs12+pem;application/pkcs7-mime;application/pkcs7-mime+pem;application/pkcs8;application/pkcs8+pem;application/pkix-cert;application/pkix-cert+pem;application/pkix-crl;application/pkix-crl+pem;application/x-pem-file;application/x-pem-key;application/x-pkcs12;application/x-pkcs7-certificates;application/x-x509-ca-cert;application/x-x509-user-cert;application/pkcs10;application/pkcs10+pem;application/x-spkac;application/x-spkac+base64;
Exec=${exec_prefix}/bin/gcr-viewer
Type=Application
Terminal=false
NoDisplay=true
Qu'est-ce que je sois supprimer ou modifier pour faire disparaître cette erreur ?
Merci
Dernière modification par papajoke le 08 Déc 2019, 02:52, modifié 1 fois.
Raison :remplacement balise quote par CODE

Erreur dans un .desktop

#2Messageil y a 1 mois

bonjour

Bug connu et malheureusement pas encore corrigé
124910
donc : momentanément remplacer ${exec_prefix} par /usr/ dans le .desktop
Pour l'instant pas de mise à jour de gcr à l'horizon , même version dans arch mais corrigé upstream depuis un mois :pleure:

Erreur dans un .desktop

#3Messageil y a 1 mois

D'accord merci Si ça a été corrigé dans archlinux, on peut espérer que ça vienne aussi dans manjaro non ? C'est peut-être un peu long toutefois :o
Ça ne doit pas être un bug bien important. D'ailleurs je ne vois pas à quoi sert cette commande ?

Erreur dans un .desktop

#4Messageil y a 1 mois

non, arch à la même version que nous ! bug corrigé chez gnome uniquement mais comme ils n'ont pas créé de nouvelle numérotation, pour l'instant il n'y a pas de maj chez les mainteneurs (archlinux)
C'est une variable (bug:non convertie) pour créer le paquet car le programme n'est pas installé sur tous les systèmes dans /usr/

Erreur dans un .desktop

#5Messageil y a 1 mois

D'accord merci pour les explications !

Erreur dans un .desktop

#6Messageil y a 1 mois

Bonjour
Ce qui est étonnant c'est que je n'ai pas ce souci ...La version de gcr 3.34.0-1.

Erreur dans un .desktop

#7Messageil y a 1 mois

lemust83 a écrit :
il y a 1 mois
Bonjour
Ce qui est étonnant c'est que je n'ai pas ce souci ...La version de gcr 3.34.0-1.
C'est également cette version qui est installée chez moi. Avec XFCE. Peut-être qu'avec un autre environnement il n'y a pas cette erreur ?

Erreur dans un .desktop

#8Messageil y a 1 mois

Non, j'ai bien Xfce, mais en gtk3 A voir.

Erreur dans un .desktop

#9Messageil y a 1 mois

XFCE en gtk3 c'est par défaut avec la version 4.14 je crois non ?

Erreur dans un .desktop

#10Messageil y a 1 mois

Oui, normalement c'est Xfce4.14 que les devs ont appelé Xfce4-gtk3.
Par contre je viens de voir que j'ai deux versions de ce plugin. La migration vers GTK3 s'est faite en plusieurs étape ce qui pourrait expliquer ce doublon:

$ pacman -Ss whisker
community/xfce4-whiskermenu-plugin 2.3.4-1 (xfce4-goodies) [installé]
    Menu for Xfce4
community/xfce4-whiskermenu-plugin-gtk3 2019.08.15-1 (xfce4-gtk3-goodies) [installé]
    Menu for Xfce4 (meta-transfer-pkg)

Erreur dans un .desktop

#11Messageil y a 1 mois

Non c'est pas ça. À l'installation seul xfce4-whiskermenu-plugin est installé. Suite à ton post, j'ai installé xfce4-whiskermenu-plugin-gtk3 mais j'ai toujours la même erreur.
À noter pour info qu'on ne peut pas supprimer xfce4-whiskermenu-plugin si xfce4-whiskermenu-plugin-gtk3 est installé

pacman -Rsn xfce4-whiskermenu-plugin

vérification des dépendances…
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: la suppression de xfce4-whiskermenu-plugin casse la dépendance « xfce4-whiskermenu-plugin » requise par xfce4-whiskermenu-plugin-gtk3

Erreur dans un .desktop

#12Messageil y a 1 mois

Arf...Je viens de regarder j'avais déjà modifié ce fichier.

sudo nano /usr/share/applications/gcc-viewer
...................
Exec=/usr/bin/gcr-viewer
.................

Erreur dans un .desktop

#13Messageil y a 1 mois

:lol::lol::lol:

Erreur dans un .desktop

#14Messageil y a 1 mois

Salut,
Kristen a écrit :
il y a 1 mois
À noter pour info qu'on ne peut pas supprimer xfce4-whiskermenu-plugin si xfce4-whiskermenu-plugin-gtk3 est installé
Les paquets Xfce dont le nom se termine par "-gtk3" sont les anciens paquets de développement, utilisés avant que la version stable 4.14 de Xfce n'arrive dans les dépôts. Depuis que la version 4.14 se trouve dans les dépôts, les paquets "-gtk3" sont liés aux paquets normaux. J'ai eu le problème lorsque j'ai voulu migrer tous mes paquets gtk3 vers les paquets normaux, il fallait les désinstaller et parfois désinstaller leurs dépendances lorsqu'il y avait des conflits de mise à jour.

lemust83 a écrit :
il y a 1 mois
Arf...Je viens de regarder j'avais déjà modifié ce fichier.

sudo nano /usr/share/applications/gcc-viewer
Pas gcc, gcr. :sourire:

sudo nano /usr/share/applications/gcr-viewer

Erreur dans un .desktop

#15Messageil y a 1 mois

Oui, coquille J'avais fermé le terminal et ai donc recopier avec mes mains pleines de doigts :ivre:

Erreur dans un .desktop

#16Messageil y a 1 mois

Smurf a écrit :
il y a 1 mois
Les paquets Xfce dont le nom se termine par "-gtk3" sont les anciens paquets de développement, utilisés avant que la version stable 4.14 de Xfce n'arrive dans les dépôts. Depuis que la version 4.14 se trouve dans les dépôts, les paquets "-gtk3" sont liés aux paquets normaux. J'ai eu le problème lorsque j'ai voulu migrer tous mes paquets gtk3 vers les paquets normaux, il fallait les désinstaller et parfois désinstaller leurs dépendances lorsqu'il y avait des conflits de mise à jour.
Intéressant à savoir ça merci :bien

Erreur dans un .desktop

#17Messageil y a 1 mois

Justement, mise à jour en testing actuellement du groupe <gtk3> ==> replacing gkt3-classic with regular gtk3 ... et de manjaro-system qui est est script permettant la maintenance de certaines opérations qui doivent être faites manuellement sous Arch. On passe officiellement à la version 18.4
Mais là, on part H.S. :wink:

Répondre