Page 2 sur 2

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 10 Fév 2019, 20:39
par lemust83
Bonjour.
Pas de souci chez moi sur deux machines. Es tu certains d'avoir bien fait pacman -Syyuu depuis qu tu as changé de branche? Le conflit concerne t'il ces versions de paquets ? N'es tu pas retourné (sans le vouloir) sur la branche Unstable ?
J'ai retiré de cette liste les paquets que tu n'as pas cités:

$ pacman -Q |grep lib32
lib32-expat 2.2.6-2
lib32-gnutls 3.6.6-1
lib32-harfbuzz 2.3.1-1
lib32-libva 2.3.0-1
lib32-libva-vdpau-driver 0.7.4-6
lib32-libvdpau 1.1.1-3
lib32-libvorbis 1.3.6-1
lib32-mesa 18.3.3-1
lib32-mesa-vdpau 18.3.3-1
lib32-vulkan-radeon 18.3.3-1
lib32-zstd 1.3.8-1

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 10 Fév 2019, 20:56
par obelix1502
Oui, j'ai bien fait cette commande et en tty même.
Par contre, j'ai trouvé d'où vient le problème.
Lorsque j'ai supprimé ces paquets lib32, Steam s'est désinstallé.
Lors de sa réinstallation, j'ai lu ceci :

Préparation...
Résolution des dépendances...
Recherche des conflits entre paquets...
Avertissement: cycle de dépendances détecté :
Avertissement: lib32-mesa sera installé avant sa dépendance lib32-libglvnd
Avertissement: cycle de dépendances détecté :
Avertissement: lib32-harfbuzz sera installé avant sa dépendance lib32-freetype2
Avertissement: cycle de dépendances détecté :
Avertissement: lib32-keyutils sera installé avant sa dépendance lib32-krb5
Transaction annulée.

Préparation...
Résolution des dépendances...
Recherche des conflits entre paquets...
Avertissement: cycle de dépendances détecté :
Avertissement: lib32-mesa sera installé avant sa dépendance lib32-libglvnd
Avertissement: cycle de dépendances détecté :
Avertissement: lib32-harfbuzz sera installé avant sa dépendance lib32-freetype2
Avertissement: cycle de dépendances détecté :
Avertissement: lib32-keyutils sera installé avant sa dépendance lib32-krb5
Transaction annulée.

Préparation...
Résolution des dépendances...
Recherche des conflits entre paquets...
Avertissement: cycle de dépendances détecté :
Avertissement: lib32-mesa sera installé avant sa dépendance lib32-libglvnd
Avertissement: cycle de dépendances détecté :
Avertissement: lib32-harfbuzz sera installé avant sa dépendance lib32-freetype2
Avertissement: cycle de dépendances détecté :
Avertissement: lib32-keyutils sera installé avant sa dépendance lib32-krb5
etc.

Et bien sûr, maintenant, impossible de réinstaller Steam car j'ai des erreurs dans les lib32 :pleure: :pleure:

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 10 Fév 2019, 21:01
par papajoke
bien sûr que non ce n'est pas normal !
Après on ne sait plus si tu es en testing, instable ou autre ...
- Changer de branche peut amener ce type d'erreurs
- Installer hors pacman va entraîner très très souvent ce type d'erreur
- Installer des paquets aur peut entraîner ce type d'erreur
- pas rare en testing ou instable (il y a un seul fichier qui pose ce problème avec la dernière maj testing). Donc si l'on est en testing ou instable, c'est un minimum de savoir gérer les conflits

EDIT: oops tu as réédité ton message : je te répondais uniquement pour les conflits de fichiers :wink:

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 10 Fév 2019, 21:03
par Erwan
Bonsoir Obelix, dommage le "etc" nous aurait davantage renseigné que le reste. :pleure:

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 10 Fév 2019, 21:16
par obelix1502
papajoke a écrit :
il y a 7 mois
bien sûr que non ce n'est pas normal !
Après on ne sait plus si tu es en testing, instable ou autre ...
- pas rare en testing ou instable (il y a un seul fichier qui pose ce problème avec la dernière maj testing). Donc si l'on est en testing ou instable, c'est un minimum de savoir gérer les conflits

EDIT: oops tu as réédité ton message : je te répondais uniquement pour les conflits de fichiers :wink:
Je n'ai changé qu'une seule fois de branche il y a 6 mois de stable en testing.
J'essaie (de ce que je comprends) de remonter les petits bugs que je rencontre sur les différents gits et autres des développeurs.
D'habitude, je sais gérer la plupart des conflits de fichiers. Mais ici, c'est à l'installation de steam-manjaro pourtant maintenu par Philip Muller, qui installe des paquets lib32 avant leurs dépendances lib32.
Donc quand mises à jour il y a, pacman trouve des fichiers vides ou déjà présents, donc ne peut les vérifier.
Parfois même, pour certains paquets, la transaction échoue, justement à cause de ces paquets installés avant leurs dépendances. Il faut donc les désinstaller et si on on oublie le Rsn (comme moi cette fois ci), eh bien c'est fichu, je n'ai pas vu les erreurs lors de la désinstallations et maintenant, je ne peux plus réinstaller le logiciel.

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 10 Fév 2019, 21:29
par lemust83
Oblix32 a écrit : Mais ici, c'est à l'installation de steam-manjaro pourtant maintenu par Philip Muller, qui installe des paquets lib32 avant leurs dépendances lib32.
Pourtant, le retour de pacman -Fl steam-manjaro (je ne l'ai pas installé) ne renvoie pas de lib32....

$ pacman -Fl steam-manjaro 
steam-manjaro etc/
steam-manjaro etc/systemd/
steam-manjaro etc/systemd/system.conf.d/
steam-manjaro etc/systemd/system.conf.d/40-fd-limits.conf
steam-manjaro etc/systemd/user.conf.d/
steam-manjaro etc/systemd/user.conf.d/40-fd-limits.conf
steam-manjaro usr/
steam-manjaro usr/bin/
steam-manjaro usr/bin/steam
steam-manjaro usr/bin/steamdeps
steam-manjaro usr/lib/
steam-manjaro usr/lib/steam/
steam-manjaro usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz
steam-manjaro usr/share/
steam-manjaro usr/share/applications/
steam-manjaro usr/share/applications/steam.desktop
steam-manjaro usr/share/doc/
steam-manjaro usr/share/doc/steam/
steam-manjaro usr/share/doc/steam/README
steam-manjaro usr/share/doc/steam/changelog
steam-manjaro usr/share/doc/steam/steam_subscriber_agreement.txt
steam-manjaro usr/share/icons/
steam-manjaro usr/share/icons/hicolor/
steam-manjaro usr/share/icons/hicolor/16x16/
steam-manjaro usr/share/icons/hicolor/16x16/apps/
steam-manjaro usr/share/icons/hicolor/16x16/apps/steam.png
steam-manjaro usr/share/icons/hicolor/24x24/
steam-manjaro usr/share/icons/hicolor/24x24/apps/
steam-manjaro usr/share/icons/hicolor/24x24/apps/steam.png
steam-manjaro usr/share/icons/hicolor/256x256/
steam-manjaro usr/share/icons/hicolor/256x256/apps/
steam-manjaro usr/share/icons/hicolor/256x256/apps/steam.png
steam-manjaro usr/share/icons/hicolor/32x32/
steam-manjaro usr/share/icons/hicolor/32x32/apps/
steam-manjaro usr/share/icons/hicolor/32x32/apps/steam.png
steam-manjaro usr/share/icons/hicolor/48x48/
steam-manjaro usr/share/icons/hicolor/48x48/apps/
steam-manjaro usr/share/icons/hicolor/48x48/apps/steam.png
steam-manjaro usr/share/licenses/
steam-manjaro usr/share/licenses/steam-manjaro/
steam-manjaro usr/share/licenses/steam-manjaro/COPYING
steam-manjaro usr/share/licenses/steam-manjaro/steam_subscriber_agreement.txt
steam-manjaro usr/share/man/
steam-manjaro usr/share/man/man6/
steam-manjaro usr/share/man/man6/steam.6.gz
steam-manjaro usr/share/pixmaps/
steam-manjaro usr/share/pixmaps/steam.png
steam-manjaro usr/share/pixmaps/steam_tray_mono.png
Ce symptôme ressemble de plus en plus à une installation de paquets exotiques....

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 10 Fév 2019, 22:16
par stephane
que retourne

sudo pacman -Qs steam

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 11 Fév 2019, 01:02
par obelix1502
Voilà :

   sudo pacman -Qs steam

[sudo] Mot de passe de obelix1502 : 
local/steam-devices 0.2-2
    Udev rules for controllers to work with steam

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 11 Fév 2019, 06:52
par lemust83
Voici le PKGBUILD de steam-manjaro

# Maintainer: Fabian Bornschein <plusfabi(At)gmail(Dot)com>
# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
# Contributor: K900 <k0009000@gmail.com>
# Contributor: Alexandru Ianu <alexandru@manjaro.org>
# Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de>

pkgname=steam-manjaro
_package=steam
pkgver=1.0.0.54
pkgrel=12
pkgdesc="Valve's digital software delivery system"
url='http://steampowered.com/'
arch=('i686' 'x86_64')
license=('custom')
depends=('lsb-release' 'desktop-file-utils' 'curl' 'dbus' 'freetype2' 'gdk-pixbuf2' 'ttf-font' 'xorg-xrandr' 'zenity' 'steam-devices')
depends_x86_64=('lib32-libgl' 'lib32-mesa' 'lib32-gcc-libs' 'lib32-libx11' 'lib32-libxss' 'lib32-alsa-plugins')
optdepends=('steam-native: steam native runtime support')
provides=('steam')
conflicts=('steam')
source=(http://repo.steampowered.com/${_package}/pool/${_package}/s/${_package}/${_package}_${pkgver}.tar.gz
        '0001-alsa-sdl-audiodriver.patch'
        '0002-dbus_fatal_warning.patch'
        '0003-manjaro-steam-native.patch'
        '0004-steam_frame_force_close.patch'
        'steam_install_workaround'
        )
sha512sums=('1820f596359d829a4e119f1f916a741ecb7973d36684916cdbbfa435fcdc9c288852491fd6d0b064e8154a43c60d8dcce3c7ed9275aed8f5f116c2782489bf32'
            'ec57f189fbc25633799c553b0eb30bd074f02befd9c7e7ca1c052be0a66ca3745b511b0fccb21ddb57885d60a23c8d40eaa8d63f8da2fc2fff3b8e7f5d23b091'
            '12d8b5786e2a375ec03131ff5c246c64793acc24cf42e74b40cd77a031c17543da05f7dd33b1f17f63524710f5d96636f35908e1953292f44e949f84fb753c27'
            'fec7a63231c502debaa8ccdac73270e47ad42dd85e420eee44100ed0e4e4678e9ad70e36a3df02cc9ebe9936b710737d0867532a9b319bc1bee141c420db5900'
            '62a9d7f216a71588562618129e75cbd5247477ad28b9c4a81c6dd5ed5bb2c35a379c18b82fe10b18ffbd94d4c1bba1ea11f40f2152c75694c5f68a544caaad17'
            'a5eb16810f2e1f1b6fbb627dba7ae74da2f375885f79ab829f918f541861ccde360c6d658b30236e7b8fad789ab98a1c35be1a08f6b19853ec338863b8caccc8')

prepare()
{
    cd ${_package}
    patch -Np1 < "${srcdir}/0001-alsa-sdl-audiodriver.patch"
    patch -Np1 < "${srcdir}/0002-dbus_fatal_warning.patch"
    patch -Np1 < "${srcdir}/0003-manjaro-steam-native.patch"
    patch -Np1 < "${srcdir}/0004-steam_frame_force_close.patch"
}

package()
{
    make -C "${_package}" DESTDIR="${pkgdir}" install

    # install license
    install -dm 755 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
    ln -s "/usr/share/doc/steam/steam_install_agreement.txt" \
    "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"

    #install changelog
    install -Dm 644 "${_package}/debian/changelog" -t "${pkgdir}/usr/share/doc/${_package}"

    # blank steamdeps because apt-get
    ln -sf /usr/bin/true "${pkgdir}/usr/bin/steamdeps"

    # bug #4816 https://github.com/ValveSoftware/steam-for-linux/issues/4816
    install -D -m755 "${srcdir}/steam_install_workaround" \
    "${pkgdir}/usr/bin/steam_install_workaround"
}
On peut y voir effectivement des dépendances lib32. Par contre il n'y a aucune référence à un dossier d'installation en /usr/local. Ce dossier est destiné à des test de binaire et ne doit pas être une destination de binaire dans le cadre d'une installation normale. Il semblerait qu'il s'agisse donc de restes d'une ancienne installation de steam peut être via Aur avec un PKGBUILD non conforme :saispas:
Tu devrais revirer tous ces fichiers en nettoyant aussi dans /var/cache/pacman/pkg/ toutes traces de paquets steam* avant de réinstaller.

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 11 Fév 2019, 07:42
par stephane
voila ce que j'ai de mon côté

sudo pacman -Qs steam

local/steam-devices 0.2-2
    Udev rules for controllers to work with steam
local/steam-manjaro 1.0.0.56-1
    Valve's digital software delivery system
local/steam-native 1.0.0.56-1
    Native replacement for the Steam runtime
[code]

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 11 Fév 2019, 08:16
par lemust83
Oui, apparemment, il ne s'agit pas de /usr/local mais local signifierait "sur la machine" par opposition a "remote" donc en réseau.
Donc le retour de pacman -Qs est cohérent.

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 12 Fév 2019, 22:25
par obelix1502
On recommence, voici ce que j'ai lors de l'installation de steam :

conflit de fichiers:
lib32-mesa : /usr/lib32/libOSMesa.so est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libOSMesa.so.8 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libOSMesa.so.8.0.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libgbm.so est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libgbm.so.1 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libgbm.so.1.0.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libglapi.so est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libglapi.so.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libglapi.so.0.0.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libxatracker.so est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libxatracker.so.2 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libxatracker.so.2.4.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/d3d.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/dri.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/egl.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/gbm.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/gl.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/glesv1_cm.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/glesv2.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/osmesa.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/xatracker.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/share/licenses/lib32-mesa/LICENSE est déjà présent dans le système de fichiers

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 13 Fév 2019, 07:17
par lemust83
Bonjour.
J'ai pu l'installer sans problème et j'ai aussi certains de ces fichiers dans mon système et je n'ai pas d'erreurs:

$ sudo pacman -S steam-manjaro
[sudo] Mot de passe de steph : 
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (4) lib32-libxss-1.2.3-1  steam-devices-0.2-2  zenity-3.30.0-1
            steam-manjaro-1.0.0.56-1

Taille totale du téléchargement :  6,62 MiB
Taille totale installée :        9,28 MiB

:: Procéder à l’installation ? [O/n] 
:: Récupération des paquets…
 zenity-3.30.0-1-x86_64     3,8 MiB   254K/s 00:15 [----------------------] 100%
 steam-devices-0.2-2-any   15,6 KiB  0,00B/s 00:00 [----------------------] 100%
 lib32-libxss-1.2.3-...     6,4 KiB  0,00B/s 00:00 [----------------------] 100%
 steam-manjaro-1.0.0...     2,8 MiB   256K/s 00:11 [----------------------] 100%
(4/4) vérification des clés dans le trousseau      [----------------------] 100%
(4/4) vérification de l’intégrité des paquets      [----------------------] 100%
(4/4) chargement des fichiers des paquets          [----------------------] 100%
(4/4) analyse des conflits entre fichiers          [----------------------] 100%
(4/4) vérification de l’espace disque disponible   [----------------------] 100%
:: Traitement des changements du paquet…
(1/4) installation de zenity                       [----------------------] 100%
(2/4) installation de steam-devices                [----------------------] 100%
(3/4) installation de lib32-libxss                 [----------------------] 100%
(4/4) installation de steam-manjaro                [----------------------] 100%
Dépendances optionnelles pour steam-manjaro
    steam-native: steam native runtime support
:: Exécution des crochets de post-transaction…
(1/4) Updating icon theme caches...
(2/4) Reloading device manager configuration...
(3/4) Arming ConditionNeedsUpdate...
(4/4) Updating the desktop file MIME type cache...
Je suppose que la base de données est corrompue.
Essaye:

sudo rm /var/lib/pacman/sync/*
sudo pacman-mirrors -aB testing -c France,Germany
sudo pacman -Syyuu
sudo pacman -S steam-manjaro

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 13 Fév 2019, 14:07
par obelix1502
Toujours la même chose :

(10/10) analyse des conflits entre fichiers            [############################] 100%
erreur : la validation de la transaction a échoué (conflit de fichiers)
lib32-mesa : /usr/lib32/libOSMesa.so est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libOSMesa.so.8 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libOSMesa.so.8.0.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libgbm.so est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libgbm.so.1 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libgbm.so.1.0.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libglapi.so est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libglapi.so.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libglapi.so.0.0.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libxatracker.so est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libxatracker.so.2 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/libxatracker.so.2.4.0 est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/d3d.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/dri.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/egl.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/gbm.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/gl.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/glesv1_cm.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/glesv2.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/osmesa.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/lib32/pkgconfig/xatracker.pc est déjà présent dans le système de fichiers
lib32-mesa : /usr/share/licenses/lib32-mesa/LICENSE est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 13 Fév 2019, 14:15
par Smurf
Salut,

Ces fichiers font partie de lib32-mesa, j’essaierais une désinstallation de ce paquet avant d'installer steam.

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 13 Fév 2019, 16:09
par lemust83
Alors il reste a tenter:

sudo pacman -S --overwrite '*' steam-manjaro

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 14 Fév 2019, 12:14
par obelix1502
lemust83 a écrit :
il y a 7 mois
Alors il reste a tenter:

sudo pacman -S --overwrite '*' steam-manjaro
C'était LA solution, elle m'a réinstallé toutes ces lib32 en réécrivant par-dessus. :bien

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 14 Fév 2019, 12:25
par papajoke
cette option était déjà donnée ici, à l'inter :wink:
119523
et de plus elle est dans toutes les annonces de mise à jour de ce site :roll:
c'est juste la remplacente de --force

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 14 Fév 2019, 12:26
par lemust83
Tant mieux. Mais ça m'interpelle. Je ne comprend pas pourquoi ça passe sans souci chez moi alors que j'utilise le même driver...Ce qui m'ennuie, c'est que ces dépendances devraient maintenant appartenir à steam.
Peux-tu donner pacman -Qo /usr/lib32/libOSMesa.so pour contrôler ?

Re: [Testing] Erreurs mises à jour lib32 - conflit fichiers

Publié : 14 Fév 2019, 23:47
par obelix1502
Voilà :

   pacman -Qo /usr/lib32/libOSMesa.so
/usr/lib32/libOSMesa.so appartient à lib32-mesa 18.3.3-1