Problèmes et questions sur les environnements graphiques et les applications.
Répondre

Problème Glances suite à maj

#1Messageil y a 5 mois

Hello,

Durant la dernière maj j'ai eu un soucis avec glances. En effet, lors de la maj il ma indiquer comme quoi certains fichier sont déjà présent sur le pc.
Je l'ai donc désinstaller pour effectuer la maj sans problème.
Quand j'ai reboot le pc et voulu réinstaller Glances. Seulement paf même erreur que durant la maj.

Voilà les erreurs :

résolution des dépendances…
recherche des conflits entre paquets…

Paquets (1) glances-3.1.0-1

Taille totale installée :  6,98 MiB

:: Procéder à l’installation ? [O/n] 
(1/1) vérification des clés dans le trousseau                                       [################################################] 100%
(1/1) vérification de l’intégrité des paquets                                       [################################################] 100%
(1/1) chargement des fichiers des paquets                                           [################################################] 100%
(1/1) analyse des conflits entre fichiers                                           [################################################] 100%
erreur : la validation de la transaction a échoué (conflit de fichiers)
glances : /usr/lib/python3.7/site-packages/Glances-3.1.0-py3.7.egg-info/PKG-INFO est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/Glances-3.1.0-py3.7.egg-info/SOURCES.txt est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/Glances-3.1.0-py3.7.egg-info/dependency_links.txt est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/Glances-3.1.0-py3.7.egg-info/entry_points.txt est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/Glances-3.1.0-py3.7.egg-info/requires.txt est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/Glances-3.1.0-py3.7.egg-info/top_level.txt est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/glances/__pycache__/events.cpython-37.pyc est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/glances/events.py est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/glances/outputs/__pycache__/glances_stdout_csv.cpython-37.pyc est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/glances/outputs/glances_stdout_csv.py est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/glances/plugins/__pycache__/glances_smart.cpython-37.pyc est déjà présent dans le système de fichiers
glances : /usr/lib/python3.7/site-packages/glances/plugins/glances_smart.py est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
Si un de nous a une idée pour me permettre de le réinstaller je veux bien.

Merci

Problème Glances suite à maj

#2Messageil y a 5 mois

bonjour

il faut faire un retour sur le forum manjaro.org

Problème Glances suite à maj

#3Messageil y a 5 mois

Bonjour,
plutôt que de le réinstaller, nous allons le supprimer complètement ainsi que ses dépendances et fichiers de configuration puis, seulement après, le réinstaller :

sudo pacman -Rsn glances
et on réinstalle dans un deuxième temps :

sudo pacman -S glances
:wink:

ps : Par curiosité j'aimerai savoir comment tu l'as désinstallé, via le terminal (commande pacman -Rsn) ou par pamac ou octopi ?
ps 2 : Il y a une autre méthode, radicale, supprimer les répertoires à la main en root mais je ne la donnerai pas ici ; méthode réservée seulement à ceux connaissant parfaitement leur système.

Problème Glances suite à maj

#4Messageil y a 5 mois

Merci pour vos réponses.

J'ai fait un sudo pacman -R glances en tty
Du coup maintenant il n'est plus installer et si je veux le réinstaller il me marque l'erreur que je vous ai marquer

Je ne peut pas le supprimer vu qu'il est déjà désinstaller

╰ sudo pacman -Rsn glances                                                                                           1.24G   8.51M 
[sudo] Mot de passe de cyberdr3am : 
erreur : impossible de trouver la cible : glances
edit : Je viens de me crée un compte sur le forum officiel mais je ne peut pas répondre au sujet de la maj

Problème Glances suite à maj

#5Messageil y a 5 mois

pacman -R n'est pas une bonne méthode pour une désinstallation propre car tu laisses en place les dépendances et les fichiers de configuration. Poste le retour de cette commande :

cd /usr/lib/python3.7/site-packages && ls

Problème Glances suite à maj

#6Messageil y a 5 mois

Voilà

  __pycache__                            orcus                                     btrfsutil.cpython-37m-x86_64-linux-gnu.so
  appdirs-1.4.3-py3.7.egg-info           packaging                                 CairoDock.py
  avahi                                  packaging-19.0-py3.7.egg-info             CDApplet-1.0-py3.7.egg-info
  blueman                                pacman_mirrors                            CDApplet.py
  bottle-0.12.16-py3.7.egg-info          pacman_mirrors-4.14.1-py3.7.egg-info      CDBashApplet-1.0-py3.7.egg-info
  btrfsutil-1.1.0-py3.7.egg-info         pep517                                    CDBashApplet.py
  bytesize                               pip                                       cups.cpython-37m-x86_64-linux-gnu.so
  cachecontrol                           pip-18.1-py3.7.egg-info                   cupshelpers-1.0-py3.7.egg-info
  CacheControl-0.12.5-py3.7.egg-info     pkg_resources                             cycler.py
  cairo                                  powerline                                 distlib-0.2.8-py3.7.egg-info
  chardet                                powerline_status-2.7-py3.7.egg-info       distro.py
  chardet-3.0.4-py3.7.egg-info           progress                                  drv_libxml2.py
  colorama                               progress-1.4-py3.7.egg-info               easy_install.py
  colorama-0.4.1-py3.7.egg-info          psutil                                    evdev-1.1.2-py3.7.egg-info
  cupshelpers                            psutil-5.5.0-py3.7.egg-info               ftdi1.py
  curl                                   pycman                                    greenlet-0.4.15-py3.7.egg-info
  cycler-0.10.0-py3.7.egg-info           pyelftools-0.25-py3.7.egg-info            greenlet.cpython-37m-x86_64-linux-gnu.so
  dateutil                               pygtkcompat                               gufw-18.10.0-py3.7.egg-info
  dbus                                   PyKF5                                     imobiledevice.so
  distlib                                pynvim                                    iotop-0.6-py3.7.egg-info
  distro-1.3.0-py3.7.egg-info            pynvim-0.3.2-py3.7.egg-info               ixion.so
  docker                                 pyparsing-2.3.1-py3.7.egg-info            kiwisolver.cpython-37m-x86_64-linux-gnu.so
  docker-3.7.0-py3.7.egg-info            PyQt5                                     lensfun-0.3.2-py3.7.egg-info
  docker_pycreds-0.4.0-py3.7.egg-info    PyQt5-5.11.3.dist-info                    libproxy.py
  dockerpycreds                          PyQt5_sip-4.19.13.dist-info               libvoikko.py
  elftools                               python_dateutil-2.7.5-py3.7.egg-info      libxml2.py
  evdev                                  pytoml                                    libxml2mod.so
  gi                                     pytoml-0.1.20-py3.7.egg-info              louis-3.8.0-py3.7.egg-info
  glances                                requests                                  matplotlib-3.0.2-py3.7-nspkg.pth
  Glances-3.1.0-py3.7.egg-info           requests-2.21.0-py3.7.egg-info            namcap.py
  gufw                                   retrying-1.3.3-py3.7.egg-info             netifaces.cpython-37m-x86_64-linux-gnu.so
  html5lib                               scripts                                   npyscreen-4.10.5-py3.7.egg-info
  html5lib-1.0.1-py3.7.egg-info          setuptools                                pep517-0.5.0-py3.7.egg-info
  idna                                   setuptools-40.6.3-py3.7.egg-info          plist.so
  idna-2.8-py3.7.egg-info                six-1.12.0-py3.7.egg-info                 pyalpm-0.8.5-py3.7.egg-info
  ifaddr                                 team                                      pyalpm.cpython-37m-x86_64-linux-gnu.so
  ifaddr-0.1.6-py3.7.egg-info            ufw                                       pycairo-1.18.0-py3.7.egg-info
  iotop                                  urllib3                                   pycups-1.9.74-py3.7.egg-info
  kiwisolver-1.0.1-py3.7.egg-info        urllib3-1.24.1-py3.7.egg-info             pycurl-7.43.0.2-py3.7.egg-info
  lensfun                                webencodings                              pycurl.cpython-37m-x86_64-linux-gnu.so
  libmount                               webencodings-0.5.1-py3.7.egg-info         PyGObject-3.30.4.egg-info
  lirc                                   websocket                                 pylab.py
  lirc-setup                             websocket_client-0.54.0-py3.7.egg-info    pyparsing.py
  lockfile                               xapp                                      python_xapp-1.4.0-py3.7.egg-info
  lockfile-0.12.2-py3.7.egg-info         xcbgen                                    PyYAML-3.13-py3.7.egg-info
  louis                                  yaml                                      README.txt
  lutris                                 youtube_dl                                retrying.py
  lutris-0.4.23-py3.7.egg-info           youtube_dl-2019.1.17-py3.7.egg-info       setproctitle-1.1.10-py3.7.egg-info
  matplotlib                             zeroconf-0.21.3-py3.7.egg-info            setproctitle.cpython-37m-x86_64-linux-gnu.so
  matplotlib-3.0.2-py3.7.egg-info        _blueman.so                               setup.py
  mpl_toolkits                           _dbus_bindings.so                         six.py
  msgpack                                _dbus_glib_bindings.so                    snack.py
  msgpack-0.6.0-py3.7.egg-info           _ftdi1.so                                 team-1.0-py3.7.egg-info
  Namcap                                 _orcus.so                                 ufw-0.36-py3.7.egg-info
  namcap-3.2.7-py3.7.egg-info            _orcus_json.so                            uno.py
  neovim                                 _snack.so                                 unohelper.py
  netifaces-0.10.9-py3.7.egg-info        _volume_key.so                            volume_key.py
  npyscreen                              _yaml.cpython-37m-x86_64-linux-gnu.so     zeroconf.py
  numpy                                  appdirs.py                              
  numpy-1.16.0-py3.7.egg-info            bottle.py 
J'ai toujours désinstaller tout mes paquets avec juste -R

Problème Glances suite à maj

#7Messageil y a 5 mois

ok, donc il faut supprimer deux dossiers. Je n'aime pas donner ce genre de méthode mais bon...
On se place ou on reste dans le répertoire donné plus haut :

cd /usr/lib/python3.7/site-packages
On supprime les dossiers qui bloquent :

sudo rm -r glances Glances-3.1.0-py3.7.egg-info
vérifie avant que tu es dans le bon répertoire (donné plus haut) : pwd

Problème Glances suite à maj

#8Messageil y a 5 mois

Par précaution, je renomme ce genre de ....lib en ....lib.old avant de les virer . Ne pas oublier d'en faire une liste avant si il y en a pleins...

Problème Glances suite à maj

#9Messageil y a 5 mois

J'ai mis OLD a la fin puis j'ai réinstaller glances.
La réinstallation c'est bien passer. ( Je voulais faire ça mais j'avais un doute du coup je préfère demander )

Pour supprimer un dossier c'est pas sudo rm -rf ? et quel est la commande pour désinstaller proprement un programme ? ( que je change mon alias )

Problème Glances suite à maj

#10Messageil y a 5 mois

Disons que pacman -R désinstalle le paquet seul, pacman -Rs désinstalle aussi les dépendances qui lui sont associées, mais gare au dépendances partagées... et pacman -Rc vire tout en cascade, ce qui est pratique, mais très risqué.
Il n'y a pas de règle absolue et donc un alias de désinstallation n'est pas recommandé car il faut prendre en compte pleins de paramètres.

Problème Glances suite à maj

#11Messageil y a 5 mois

Ok merci

J'ai l'habitude de faire des alias comme ça je suis certain de pas faire de bétises :lol:

Problème Glances suite à maj

#12Messageil y a 5 mois

:salut: Il y avait aussi l'option sudo pacman -S --overwrite sans doute la plus judicieuse. J'avoue ne jamais l'utiliser tout comme son illustre ancêtre --force:oops:

Problème Glances suite à maj

#13Messageil y a 5 mois

Si j'ai ce soucis sur l'autre pc ou je n'ai pas encore fait la maj je ferais cette méthode

Répondre