Problèmes et questions sur les environnements graphiques et les applications.
Répondre

Une mise à jour qui interdit l'accès aux autres environnements graphiques?

#1Messageil y a 7 mois

Boujour !

Presque tout est dit dans le titre: depuis la toute dernière mise à jour (conséquente) de Manjaro, qui s'est pourtant déroulée sans encombre, je n'ai plus accès qu'à mon environnement graphique (desktop) d'origine, soit KDE PLasma.
Il se trouve que j'avais installé parallèlement GNOME SHELL (et donc automatiquement et accessoirement gnome3 et gnome classique). Depuis au redémarrage, je me connecte sans souci à Plasma, mais ce n'est plus possible avec les autres desktops. A chaque fois, je me retrouve sur la page d'accueil ...après quelques minutes d'écran noir. J'ai tente de réinstaller Gnome shell, aucun msg d'erreur n'apparaît. Que se passe-t-il??
Merci d'éclairer ma lanterne.

Une mise à jour qui interdit l'accès aux autres environnements graphiques?

#2Messageil y a 7 mois

Bonjour.
Ce n'est pas Gnome-shell qui pose problème mais plutôt un conflit avec les DM (Display Manager).
Tu dois avoir GDM pour Gnome et SDDM pour KDE-Plasma, hors il n'en faut qu'un seul.
Je pense que tu devrais désactiver SDDM avec un simple systemctl stop sddm.service && systemctl disable sddm.service pour retrouver ta session Gnome-shell avec éventuellement un systemctl start gdm.service mais ce n'est que mon avis car je n'utilise aucun DM...
Au pire, tu le réactive (start + enable) et tu désactive gdm.

Une mise à jour qui interdit l'accès aux autres environnements graphiques?

#3Messageil y a 7 mois

:bjr:
perso, je pencherais pour un plantage de ton gnome : il y avait pas mal de dégâts (signalés) lors de la dernière mise à jour en particulier avec des extensions c'est dans l'annonce.

Une mise à jour qui interdit l'accès aux autres environnements graphiques?

#4Messageil y a 7 mois

Salut à tous! :bjr:
Oui, je pencherais plutôt pour la seconde solution, sans en être absolument certain.Je n'ai pas tenté la première solution proposée ci dessus. En effet: j'ai installé le bureau Budgie, basé sur Gnome3 et cousin de ce dernier, sans aucun souci. Au redémarrage, j'ai pu me loguer très rapidement sans plantage. Par contre, Gnome Shell reste inaccessible. :saispas: Quelqu'un aurait-il une solution pour le retrouver.. car aucun "paquet cassé "n'est signalé lors de l'utilisation d'Octopi et de la réinstallation de Gnome! :?:

Une mise à jour qui interdit l'accès aux autres environnements graphiques?

#5Messageil y a 7 mois

Up! Vous me laissez tomber?
Et si je désinstallais entièrement gnome-shell puisque aucune des solutions proposées ci dessus ne fonctionne?
Ou simplement son cache?
Quelle serait sa commande dans ce cas, quitte à le réinstaller par la suite??

Une mise à jour qui interdit l'accès aux autres environnements graphiques?

#6Messageil y a 7 mois

Bonjour.
On ne laisse personne de côté, mais les utilisateurs de Gnome-shell ne sont pas légion...
Pour virer un DE, on nettoie à la main tous les fichiers de conf dans $HOME Il y en a un peu partout....(.config/ .local/ etc....)
Ensuite en TTY:

sudo pacman -Rcsn gnome-shell
L'option c pour --cascade supprimera tout ce qui est lié à gnome, y compris le serveur X et Wayland qui reste dormant, mais bien installé.
Il ne te reste qu'a réinstaller un autre DE, par exemple:

sudo pacman -S xfce4-gtk3 xfce4-gtk3-goodies
.

Une mise à jour qui interdit l'accès aux autres environnements graphiques?

#7Messageil y a 7 mois

concernant cette maj importante pour gnome
il y a eu en effet un passage à la version 3.32 de gnome

il faut TOUJOURS aller lire le sujet initial ( on mets à chaque fois de notre côté le lien lors de la maj )
le 1er topic qui suit , qui donne toutes les indications a suivre pour eviter ce souci
https://forum.manjaro.org/t/stable-upda ... rs/81570/2

cad les consignes suivantes


gnome 3.32: Two extensions removed from our repos.

We have dropped two packages that shipped additional extensions for Gnome: gnome-shell-extension-topicons-plus-huttli and gnome-shell-extension-taskbar. We won't maintain Topicons Plus and Taskbar anymore.

Those extensions are not in active development anymore and may not work properly (or not work at all) on Gnome 3.32. Notably, it has been reported 4 that using Topicons Plus on Gnome 3.32 may leads to very high CPU usage.

We strongly recommend you to disable those extensions if they are enabled (Tweaks > Extensions) and remove those packages with your favorite package manager. To prevent potential problems with the next version of Gnome, you may do those steps (or at least the first one) before upgrading your system.
Gnome 3.32: Various problems

There is currently several problems with Gnome 3.32. Here is what we know so far.

1. Possibility of broken extensions
Broken extensions is something to expect when transitioning between major versions of Gnome, especially if you are using extensions that are not shipped by default on Manjaro Gnome. If you have a broken extension taken from somewhere else than Manjaro official repositories, you will have to contact the maintainer on the source you have taken the extension from to get more support. You may also want to report the problem to the developer(s) of the extension (if not the same person/group).

It is possible that extensions become so broken on Gnome 3.32 that it makes Gnome Shell crash completely when trying to log in, thus making Gnome completely unusable. For example, we have a report of such issue 6 with a third-party extension (that doesn't come from Manjaro's official repositories) called Extensions 9.

To decrease the risk of breakage (especially if running Gnome extensions that does not come from Manjaro official repositories) and make the upgrade smoother, you can disable all Gnome extensions (Tweaks > Extensions) before upgrading your system, then enable them one by one only after being logged in a completely new session on Gnome 3.32.

2. Using world clocks can break Gnome Shell completely
If you have configured world clocks in Gnome, it may make Gnome Shell segfaults and crashes when trying to log in for a graphical session, making Gnome unusable. If it happens, you will need to reset your parameters for world clocks with the following command (do it in TTY): dbus-launch gsettings reset org.gnome.clocks world-clocks.
See this Arch Linux thread 4 and this ticket 4 from upstream.

3. Gnome Shell may crash completely when resuming from sleep if you use Wayland
If you are using Wayland (instead of X.org 1), Gnome Shell may crash when resuming from sleep. Upstream is aware of this issue. 9 As a workaround, you may use X.org 1 instead of Wayland for now.

4. Miscellaneous
Some programs don't get focused after being launched. Reported to upstream and confirmed for distributions other than Manjaro too. 18
My icon theme is not applied anymore for programs like Gnome Terminal, System Monitor, Gnome Screenshot, Gnome Disks, File Roller, etc.

With version 3.32 of these programs, upstream changed the icon used for many programs part of the Gnome Applications. Instead of using a generic icon shared by many programs, they chose to ship a new icon and use it. Therefore, launchers located in /usr/share/applications (.desktop files) for those programs has been modified to use the new icon instead of the generic one. Here's an example with Gnome Terminal.

Before
Icon=utilities-terminal

After
Icon=org.gnome.Terminal

Since your icon theme most likely doesn't have an icon named org.gnome.X, it falls back to the hicolor theme instead. This is why the icon changed after the system upgrade and "your theme is not applied anymore for those programs."

There is nothing you can really do for now, except living with it for a while. Icon theme designers will have to adapt their theme to the changes made by Gnome developers.

Une mise à jour qui interdit l'accès aux autres environnements graphiques?

#8Messageil y a 7 mois

bonsoir! :bjr:
Merci de toutes ces précisions fort utiles en effet. Ce que j'ai fait, c'est donc désinstaller complètement gnome-tweaks, effacer les dossiers gnome dans mon home,-ou pas- (qu'ils soient dans .config, .local , etc) désinstallé également gnome-shell, puis redémarré. Je me suis alors contenté de ré-installer gnome-shell et le miracle s'est produit. Tout a bien fonctionné. Ma session gnome-shell est réapparu. Il a fallu la reparamétrer, bien sûr, y compris replacer certaines extensions, mais rien de bien grave. J'ignore précisément ce qui a provoqué ce bug, mais les pistes proposées étaient les bonnes.
Merci à tous! :sourire:

Répondre