Problèmes et questions sur les environnements graphiques et les applications.
Répondre

Spyder

#1Messageil y a 3 mois

Bonjour à tous,
Je suis depuis peu de temps sur Manjaro Gnome, et étant professeur de physique-chimie j'utilise régulièrement Spyder pour rédiger mes programmes python, mais celui-ci ne se lance pas sur Manjaro, voici le retour de la commande spyder lancée dans le terminal :

spyder                                                           ✔ 
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 568, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 886, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 777, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (decorator 5.0.9 (/usr/lib/python3.9/site-packages), Requirement.parse('decorator<5'), {'spyder-kernels'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/spyder", line 33, in <module>
    sys.exit(load_entry_point('spyder==5.0.1', 'gui_scripts', 'spyder')())
  File "/usr/bin/spyder", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 855, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3.9/site-packages/spyder/app/start.py", line 34, in <module>
    from spyder.utils.external import lockfile
  File "/usr/lib/python3.9/site-packages/spyder/utils/external/lockfile.py", line 31, in <module>
    from spyder.utils.programs import is_spyder_process
  File "/usr/lib/python3.9/site-packages/spyder/utils/programs.py", line 28, in <module>
    import pkg_resources
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3243, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3226, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3255, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 570, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 583, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 772, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'decorator<5' distribution was not found and is required by spyder-kernels
D'avance merci !

Spyder

#2Messageil y a 3 mois

Bonjour.

pkg_resources.DistributionNotFound: The 'decorator<5' distribution was not found and is required by spyder-kernels
Je ne connais pas Spyder mais il y a dans les dépôts community/python-spyder-kernels 2.0.1-1.
A essayer.

Spyder

#3Messageil y a 3 mois

bonjour

Erreur malheureusement connue chez archlinux ! La dépendance spyder-kernels est marquée "out of date" et le bug lié est ouvert depuis très longtemps chez arch mais aussi chez spyder:triste:
Il est dit (à la fin) que la nouvelle version de python-spyder-kernels corrige ce bug mais pas encore de maj chez arch :pleure:

Spyder

#4Messageil y a 3 mois

lemust83 a écrit : il y a 3 mois Bonjour.

pkg_resources.DistributionNotFound: The 'decorator<5' distribution was not found and is required by spyder-kernels
Je ne connais pas Spyder mais il y a dans les dépôts community/python-spyder-kernels 2.0.1-1.
A essayer.
Ce paquet fait partie des dépendances de Spyder donc vient avec Spyder...
papajoke a écrit : il y a 3 mois bonjour

Erreur malheureusement connue chez archlinux ! La dépendance spyder-kernels est marquée "out of date" et le bug lié est ouvert depuis très longtemps chez arch mais aussi chez spyder:triste:
Il est dit (à la fin) que la nouvelle version de python-spyder-kernels corrige ce bug mais pas encore de maj chez arch :pleure:
Si je comprends bien pas de solutions dans l'immédiat, mis à part downgrade python-decorator, je ne sais pas si cela est facile et recommandé, ou simplement attendre une future mise à jour ?

Spyder

#5Messageil y a 3 mois

il n'y a pas de danger à faire un downgrade, il faut juste avant voir par quelles() application(s) il est utilisé

pactree -r python-XXXX
Au pire, tu risques de planter ves applications python qui l'utilise. Pas difficile de revenir alors en arrière en le ré-installant
Répondre