Tout ce qui concerne internet
Répondre

Une curiosité dans la connexion à la box

#1Messageil y a 1 mois

:bjr: à tous et bonne année :fete: … j'avais une partition inutilisée sur mon disque et j'ai installé une autre arch linux dérivée (Arch anywhere) pour me faire la main… Depuis une semaine je tourne en rond sur quelque chose de très curieux: si je démarre sur arch ma connexion wifi avec ma box est établie mais je ne peux accéder à internet ; mais si je passe d'abord par Manjaro, tout marche ensuite normalement?
J'ai essayé de fouiller un peu le sujet d'activation/désactivation de dhcpcd, désactiver netctl… je me tourne vers vous au cas où… cette bizarrerie vous dise quelque chose :pappy:

Une curiosité dans la connexion à la box

#2Messageil y a 1 mois

sous manjaro on utilise Network manager ,
sous Arch tu utilise quel outil de connexion ?

Une curiosité dans la connexion à la box

#3Messageil y a 1 mois

pareil…

Une curiosité dans la connexion à la box

#4Messageil y a 1 mois

tu ne peux avoir nmcli et networkmanager c'est l'un ou l'autre

je corrige nmcli est la version texte en commande de networkmanager
Modifié en dernier par stephane le 02 Jan 2018, 22:53, modifié 1 fois.

Une curiosité dans la connexion à la box

#5Messageil y a 1 mois

:bien Stéphane, merci de te pencher sur la question , pourquoi me parler de nmcli, je ne saisis pas…?

Une curiosité dans la connexion à la box

#6Messageil y a 1 mois

alors à voir dans les logs
( sudo journalctl -b0 | grep NIC )
il établi d'abord la liaison wifi ou celle eth fixe ?

Une curiosité dans la connexion à la box

#7Messageil y a 1 mois

Aucune idée... comment le savoir?

Une curiosité dans la connexion à la box

#8Messageil y a 1 mois

 sudo journalctl -b0 | grep NIC
 sudo journalctl -b0 | grep en
 

Une curiosité dans la connexion à la box

#9Messageil y a 1 mois

sympa cette commande que l'on peut contextualiser... la wifi a l'air de démarrer en premier...
Dans ton premier post tu parlais de nmcli et j'imagine que tu devais penser à netctl qui ne peut pas être utilisé en même temps que networkmanager... mais du coup je me suis intéressé à nmcli qui permet de récupérer pas mal d'informations sur networkmanager :bien , du coup demain au premier démarrage j'essaierai un <nmcli g> pour voir ce que ça donne, en attendant merci et peut-être à demain!

Une curiosité dans la connexion à la box

#10Messageil y a 1 mois

:bjr: à tous, après un $ nmcli g avec wifi connecté à la box mais sans pouvoir accéder à internet
cela me donne:

STATE                      CONNECTIVITY  WIFI-HW  WIFI    WWAN-HW  WWAN   
connecté (site seulement)  aucun         activé   activé  activé   activé 
J'ai donc rentré la commande : $ nmcli n
me confirmant enabled, et après avoir refait $ nmcli g

STATE     CONNECTIVITY  WIFI-HW  WIFI    WWAN-HW  WWAN   
connecté  plein         activé   activé  activé   activé 

mais toujours pas d'accès à internet bien que connecté à la box, quelqu'un aurait une idée ? :saispas:

Une curiosité dans la connexion à la box

#11Messageil y a 1 mois

:bjr:
Es tu sûr d'être connecté à ta box
peux tu donner le retour de :

ifconfig
et de

ping adresse-box

Une curiosité dans la connexion à la box

#12Messageil y a 1 mois

:bjr: patri-arch, oui et networkmanager-applet me le confirme... ifconfig me donne

enp3s6: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:0f:b0:4c:d4:d1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.17  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::62bb:8d2d:79ed:2c3d  prefixlen 64  scopeid 0x20<link>
        ether 00:90:4b:f3:5d:f2  txqueuelen 1000  (Ethernet)
        RX packets 103  bytes 24649 (24.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 189  bytes 24626 (24.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
et ping ma box

$ ping 192.168.1.11
PING 192.168.1.11 (192.168.1.11) 56(84) bytes of data.
64 bytes from 192.168.1.11: icmp_seq=1 ttl=64 time=0.071 ms
64 bytes from 192.168.1.11: icmp_seq=2 ttl=64 time=0.065 ms
64 bytes from 192.168.1.11: icmp_seq=3 ttl=64 time=0.075 ms
64 bytes from 192.168.1.11: icmp_seq=4 ttl=64 time=0.074 ms
64 bytes from 192.168.1.11: icmp_seq=5 ttl=64 time=0.652 ms
From 192.168.1.17 icmp_seq=6 Destination Host Unreachable
From 192.168.1.17 icmp_seq=7 Destination Host Unreachable
From 192.168.1.17 icmp_seq=8 Destination Host Unreachable
64 bytes from 192.168.1.11: icmp_seq=11 ttl=64 time=0.071 ms
From 192.168.1.17 icmp_seq=9 Destination Host Unreachable
From 192.168.1.17 icmp_seq=10 Destination Host Unreachable
64 bytes from 192.168.1.11: icmp_seq=12 ttl=64 time=0.109 ms
64 bytes from 192.168.1.11: icmp_seq=13 ttl=64 time=0.082 ms
64 bytes from 192.168.1.11: icmp_seq=14 ttl=64 time=0.080 ms
64 bytes from 192.168.1.11: icmp_seq=15 ttl=64 time=0.077 ms
64 bytes from 192.168.1.11: icmp_seq=16 ttl=64 time=0.078 ms
64 bytes from 192.168.1.11: icmp_seq=17 ttl=64 time=0.077 ms
64 bytes from 192.168.1.11: icmp_seq=18 ttl=64 time=0.087 ms
64 bytes from 192.168.1.11: icmp_seq=19 ttl=64 time=0.078 ms
64 bytes from 192.168.1.11: icmp_seq=20 ttl=64 time=0.079 ms
64 bytes from 192.168.1.11: icmp_seq=21 ttl=64 time=0.079 ms
64 bytes from 192.168.1.11: icmp_seq=22 ttl=64 time=0.080 ms
64 bytes from 192.168.1.11: icmp_seq=23 ttl=64 time=0.062 ms
64 bytes from 192.168.1.11: icmp_seq=24 ttl=64 time=0.078 ms
64 bytes from 192.168.1.11: icmp_seq=25 ttl=64 time=0.070 ms
64 bytes from 192.168.1.11: icmp_seq=26 ttl=64 time=0.069 ms
64 bytes from 192.168.1.11: icmp_seq=27 ttl=64 time=0.078 ms
64 bytes from 192.168.1.11: icmp_seq=28 ttl=64 time=0.078 ms
64 bytes from 192.168.1.11: icmp_seq=29 ttl=64 time=0.080 ms
64 bytes from 192.168.1.11: icmp_seq=30 ttl=64 time=0.065 ms
64 bytes from 192.168.1.11: icmp_seq=31 ttl=64 time=0.082 ms
64 bytes from 192.168.1.11: icmp_seq=32 ttl=64 time=0.083 ms
64 bytes from 192.168.1.11: icmp_seq=33 ttl=64 time=0.064 ms
64 bytes from 192.168.1.11: icmp_seq=34 ttl=64 time=0.078 ms
64 bytes from 192.168.1.11: icmp_seq=35 ttl=64 time=0.078 ms
From 192.168.1.17 icmp_seq=39 Destination Host Unreachable
From 192.168.1.17 icmp_seq=40 Destination Host Unreachable
From 192.168.1.17 icmp_seq=41 Destination Host Unreachable
64 bytes from 192.168.1.11: icmp_seq=42 ttl=64 time=0.107 ms
64 bytes from 192.168.1.11: icmp_seq=43 ttl=64 time=0.048 ms
64 bytes from 192.168.1.11: icmp_seq=44 ttl=64 time=0.070 ms.......................etc.
J'ai coupé, sinon ça continuait sans fin...

Une curiosité dans la connexion à la box

#13Messageil y a 1 mois

D'après ce que je vois tu as deux problèmes :
La sortie WLAN qui doit être la sortie filaire est associée à l'adresse terminant par .17 et elle n'arrive pas à accéder au réseau.
Il y a une adresse se terminant par .11 qui accède au réseau mais je ne l'a vois pas associée à la carte WIFI ( enp3s6).

Je dirais que ta config réseau est un peu bancale;
Essaie de la refaire avec NetworkManager ( et si possible avec un seul accès réseau au départ --> tu désactives le Wifi par ex et tu essaie de refaire la connexion filaire et inversement si çà marche)

Regardes les options de ifconfig ( tu dois avoir plus d'infos mais je ne les ai plus en tête)

Une curiosité dans la connexion à la box

#14Messageil y a 1 mois

:salut: patri-arch, merci pour les infos, je vais effectivement fouiller dans cette direction...

Une curiosité dans la connexion à la box

#15Messageil y a 1 mois

un retour de

nmcli 
et/ou 
nmcli show device 
est assez utile
tu te connecte en eth fixe ( câble ) ou par wifi ?

Une curiosité dans la connexion à la box

#16Messageil y a 1 mois

:bjr: stephane, en wifi... c'est apparamment un problème de double adressage que je n'arrive pas à corriger sinon la connexion filaire fonctionne. Comme je le disais dans le premier post, la curiosité est que la connexion wifi est possible:
si je démarre sur Manjaro d'abord et que je redémarre tout marche parfaitement, mais sinon le pc /arch se connecte en wifi à la box sans problème, est reconnu mais ne peut accéder à internet, nmcli renvoie d'ailleurs parfois 2 inet4 différents en même temps et je pense que l'un des deux met l'embrouille comme le disait patri-arch :wink: , celui qui est affiché ci-dessous d'ailleurs

wlan0: connecté to Livebox-glouglou 
        "Broadcom Limited BCM4306 802.11b/g (Broadcom 802.11b/g WLAN)"
        wifi (b43), "nanounana", hw, mtu 1500
        inet4 192.168.1.17/24
        route4 192.168.1.0/24
        route4 192.168.1.0/24
        inet6 fe80::"naninonno"/64
        route6 ff00::/8
        route6 fe80::/64
        route6 fe80::/64
Voilou, si tu as une idée... :bien

Une curiosité dans la connexion à la box

#17Messageil y a 2 semaines

J'avais des services connectés en conflit avec NetworkManager. Un petit "dmesg | grep wlan0" m'a mis la puce à l'oreille et "systemctl list-unit-files --type=service --all" me l'a confirmé : wpa_supplicant et dhcpc entre autres.
Donc, si comme moi, vous êtes connectés en wifi ( associé et authentifié ) à votre box ; mais que vous n'avez pas accès à internet sans le cable, alors il y a de grandes chances qu'un service démarré est en concurrence (en conflit) avec votre gestionnaire de connexion. :café:

Répondre