Tout ce qui concerne la notion de paquet et comment installer.
Répondre

Mise à jour AUR différente !?

#1Messageil y a 6 mois

Bonjour, :bjr:

Ce n'est pas très grave mais je me pose quand même la question.
Je n'ai pas le même retour de mise à jour AUR avec trizen et avec pamac.

Je n'ai rien avec trizen

[redhead@Manjaro ~]$ trizen -Syu
:: Pacman command: /usr/bin/sudo /usr/bin/pacman -Syu
:: Synchronisation des bases de données de paquets…
 core est à jour
 extra est à jour
 community est à jour
 multilib est à jour
:: Début de la mise à jour complète du système…
 il n’y a rien à faire
:: No AUR updates found...
Alors que dans pamac, j'ai une mise à jour..
Image

Comment ça se fait ?? :?

Mise à jour AUR différente !?

#2Messageil y a 6 mois

:salut:
Normal, avec les helpeurs aur : ils ne testent pas les "-git"
Avec pamac il y a une option dans la config pour avoir un comportement non standard

Mise à jour AUR différente !?

#3Messageil y a 6 mois

Ah oui !
Il y a l'option : Vérifier les mise à jour des paquets en cours de développement

Pourquoi ce n'est pas intégré dans les helpers ?
C'est dommage.

Mise à jour AUR différente !?

#4Messageil y a 6 mois

Ces fichiers n'ont pas de version ! Donc un helpeur doit télécharger le dépôt git pour vérifier la version - ce type de comportement prend du temps et de la bande passante

Mise à jour AUR différente !?

#5Messageil y a 6 mois

Bah si y'a une version..

[redhead@Manjaro ~]$ trizen caprice32
1 aur/caprice32-git 4.5.0.r230.g001bd66-1 [installed] [8+] [0.06%] [19 Mar 2021]
    An emulator of the Amstrad CPC 8bit home computer range (CPC 464, 664, 6128)
2 aur/libretro-cap32-git 287.fe54cbb-1 [1+] [0.00%] [5 Jan 2021]
    libretro implementation of Caprice32 (Amstrad CPC)

=>> Select packages to install
> 
[redhead@Manjaro ~]$ yay caprice32
2 aur/libretro-cap32-git 287.fe54cbb-1 (+1 0.00) 
    libretro implementation of Caprice32 (Amstrad CPC)
1 aur/caprice32-git 4.5.0.r230.g001bd66-1 (+8 0.06) (Installé : 4.5.0.r314.g34c37a7-1)
    An emulator of the Amstrad CPC 8bit home computer range (CPC 464, 664, 6128)
==> Paquets à installer (ex. 1 2 3, 1-3 or ^4)
==> 
 il n'y a rien à faire
[redhead@Manjaro ~]$ 
Juste, ils ne voient pas la dernière dans les dépôts..
Yay voit bien que ce que j'ai sur mon PC est différent de ce qu'il y a dans les dépôts..

Mise à jour AUR différente !?

#6Messageil y a 6 mois

Salut,
redhead a écrit : il y a 6 mois Bah si y'a une version..
Pas dans le sens où on l'entend normalement, la version git change à la moindre modification de programme de la part des développeurs, une version classique est fixe.

La dernière version "fixe" de Caprice32 est la 4.6.0 :
https://github.com/ColinPitrat/caprice3 ... tag/v4.6.0

Mise à jour AUR différente !?

#7Messageil y a 6 mois

@Smurf
Ok, merci de ta réponse.

Mais si une version git est une version de développement, comment ça se fait que la version git soit antérieur à la version "fixe" ?

Edit:
En fait la version de Caprice32 est bien 4.6.0
C'est donc les versions git qui ne correspondent à pas grand chose, apparemment..

Mise à jour AUR différente !?

#8Messageil y a 6 mois

papajoke a écrit : il y a 6 mois Ces fichiers n'ont pas de version
Oui, ils ont une version mais elle n'est pas significative ... Il ne faut donc pas en tenir compte. Elle est très souvent plus petite que l'officielle dans la page aur ... Pas grave car l'app est forcément du jour donc la dernière justement le helpeur re-calcule la version.

Mise à jour AUR différente !?

#9Messageil y a 6 mois

@Papajoke
Ok, merci pour la précision. :sourire:
Répondre