Problèmes et questions sur les applications multimédia.
Répondre

Installation driver Nvidia marche plus

#1Messageil y a 3 semaines

Bonjour,
Je voudrais installer mon driver nvidia mais j'y arrive plus

En mode fenêtres => Gestionnaire de paramètres de Manjaro puis je coche : video-hybrid-intel-nvidia-450xx-prime

Waiting for user input...
Starting
> Dependencies to install: video-modesetting
Proceed with installation? [Y/n]

Puis plus rien !!!

-------------------------------------------------------------------------

En mode console :

sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime ( rien ne se passe après avoir mis le mot de pass root)

Une astuce ?

Installation driver Nvidia marche plus

#2Messageil y a 3 semaines

Bonjour,

Je ne sais pas si cette commande est toujours d'actualité mais, perso j'essaierai : sudo mhwd -a pci nonfree 0300

Note : Cette commande installe le meilleur pilote recommandé pour ton GPU mais je pense que dans ton cas il faudra probablement blackliser le module graphique du CPU. A voir avec stephane s'il valide, ou pas. ;)

Installation driver Nvidia marche plus

#3Messageil y a 3 semaines

Installation driver Nvidia marche plus

#4Messageil y a 3 semaines

sudo mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
10
administration/modération

Installation driver Nvidia marche plus

#5Messageil y a 3 semaines

A chaque nouveau kernel, soit ma carte son n'est plus reconnue, soit ma carte vidéo intel/nvidia n'est pas vraiment reconnue non plus lol
Pourtant ca c'était calmé ces derniers mois ! Mais la çà recommence...
J'ai réglé le pb le son grâce à Stéphane car j'ai repris ces notes ;)
Mais pour la carte nvidia c'est encore la galère... pourtant il faut juste cocher : video-hybrid-intel-nvidia-450xx-prime

Installation driver Nvidia marche plus

#6Messageil y a 1 semaine

Bon ça marche... J'ai fais une petite procédure pour activer le driver nvidia sous xfce
Ca pourra peut être servir à quelqu'un

Allez dans :
Manjaro Gestionnaire de Paramètres =>> Configuration Matérielle ==> Vidéo-hybride-intel-nvidia-450xx-prime
puis bouton droit de la souris +Installer

Fonctionne avec le Linux Kernel 5.8.6-1

Ne fonctionne pas avec le Kernel Linux 5.9rc4.d0830.gf4d51df-1 car l'instalateur cité précédemment fait une erreur

-------------------------------------------------------------------------------------------------------------

Firstly, remove /etc/X11/xorg.conf.d/90-mhwd.conf and replace it with: 
Premièrement, renommer 90-mhwd.conf par 90-mhwd.conf.old qui est situé dans /etc/X11/xorg.conf.d/

-------------------------------------------------------------------------------------------------------------

créer un fichier nommé "optimus.conf" avec les lignes ci-dessous :

Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

Puis mettre le fichier optimus.conf dans /etc/X11/xorg.conf.d/

--------------------------------------------------------------------------------------------------------------

Dans un terminal lancer une par une les lignes ci-dessous :

ls /etc/modprobe.d/mhwd*
sudo rm /etc/modprobe.d/mhwd-gpu.conf
sudo rm /etc/modprobe.d/mhwd-nvidia.conf

--------------------------------------------------------------------------------------------------------------

Créer un fichier nommé "nvidia.conf" dans /etc/modprobe.d/nvidia.conf avec à l'intérieur les lignes ci-dessous :

blacklist nouveau
blacklist nvidiafb
blacklist rivafb

enable nvidia-drm.modeset

---------------------------------------------------------------------------------------------------------------

Créer un fichier nommé  "nvidia-drm.modeset" dans /etc/modprobe.d/ avec la ligne ci-dessous à l'intérieur :

options nvidia_drm modeset=1

--------------------------------------------------------------------------------------------------------------

Pour l'environnement Xfce

Créer un fichier nommé "optimus.sh" dans /usr/local/bin/ avec à l'intireur les lignes ci-dessous :

#!/bin/sh

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

Ne pas oublier de rendre exécutable le fichier optimus.sh

-------------------------------------------------------------------------------------------------------------

Ouvrir avec un editeur de text en root le fichier lightdm.conf situé dans /etc/lightdm/ puis mettre à l'intérieur de ce fichier la ligne ci-dessous :

display-setup-script=/usr/local/bin/optimus.sh

Mettre la ligne en dessous de la section [Seat:*] en retirant le # devant la ligne

------------------------------------------------------------------------------------------------------------

Terminé... Reboot

Après le redemarrage, vérifier ci la carte nvidia est bien active avec la commande suivante dans un terminal :

lspci | grep -E "VGA|3D" && glxinfo | grep -i vendor && glxinfo | grep "direct rendering"
Répondre