Problèmes et questions sur les applications multimédia.
Répondre

[AUR] Impossible d'installer 4kyoutubetomp3

#1Messageil y a 9 mois

Bonjour,
Je n'arrive pas à installer l'application 4kyoutubetomp3 (ni sa soeur 4kvideodownloader) depuis AUR, avec ce message d'erreur :

la satisfaction des dépendances a échoué:
impossible de satisfaire la dépendance « libdcadec.so » requise par ffmpeg2.8
impossible de satisfaire la dépendance « ffmpeg2.8 » requise par 4kyoutubetomp3
Je ne trouve pas ffmpeg2.8.
Merci de m'aider :sourire:

[AUR] Impossible d'installer 4kyoutubetomp3

#2Messageil y a 9 mois

:bjr: ffmpeg2.8 est un paquet aur :wink:

[AUR] Impossible d'installer 4kyoutubetomp3

#3Messageil y a 9 mois

Merci, mais

la satisfaction des dépendances a échoué:
impossible de satisfaire la dépendance « libdcadec.so » requise par ffmpeg2.8
Et j'ai bien cherché, libdcadec.so n'y est pas :saispas:

[AUR] Impossible d'installer 4kyoutubetomp3

#4Messageil y a 9 mois

Bonjour, d'après le dernier commentaire (17 août) il suffit d'éditer le PKGBUILD puis de rechercher et supprimer : 'libdcadec.so' dans la rubrique depends à la ligne 15 :
depends=
J'ai pas testé mais le paquet devrait se construire après cette modif. :wink:

[AUR] Impossible d'installer 4kyoutubetomp3

#5Messageil y a 9 mois

Salut, je me permet de me mêler à la discussion, car je suis aussi intéressé :siffle
il suffit d'éditer le PKGBUILD
Qu'est ce qu'il faut faire exactement ?

[AUR] Impossible d'installer 4kyoutubetomp3

#6Messageil y a 9 mois

sur aur il n'y a que des recettes pour faire automatiquement un paquet en local
Les recettes sont un fichier texte PKGBUILDconsultable sur le site aur.
Généralement les outils d'installation aur proposent d'éditer ce fichier (pour que l'utilisateur le controle un minimum)

Nous devrions toujours consulter la page AUR du paquet pour lire les commentaires - pour des raisons techniques mais aussi pour contrôler par nous même que cette recette est bien maintenue et sure
manjaro ne fait aucun support des paquets aur (il y en a 48000), c'est à la charge de chaque mainteneur de sa recette sur sa page aur

[AUR] Impossible d'installer 4kyoutubetomp3

#7Messageil y a 9 mois

Excusez mon ignorance, mais concrètement il faut faire quoi ?

[AUR] Impossible d'installer 4kyoutubetomp3

#8Messageil y a 9 mois

comme indiqué dans la page aur et Erwan

Installer ce paquet - lorsqu'il te demande de l'éditer, supprimer la dépendance

original:

depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
         ...
         'libass.so' 'libbluray.so' 'libdcadec.so' 'libfreetype.so' 'libva.so'
supprimer 'libdcadec.so'

----
comme Erwan, j'ai pas testé n'ai pas besoin de ce paquet

[AUR] Impossible d'installer 4kyoutubetomp3

#9Messageil y a 9 mois

Il me semble que youtube-dl fait bien le taf non ?

et ce sans se compliquer la vie. :sourire:

[AUR] Impossible d'installer 4kyoutubetomp3

#10Messageil y a 9 mois

Il me semble que youtube-dl fait bien le taf non ?

et ce sans se compliquer la vie. :sourire:
Oui, il y a aussi clipgrab, mais chacun a ses préférences, c'est toujours subjectif...
sur aur il n'y a que des recettes pour faire automatiquement un paquet en local
Les recettes sont un fichier texte PKGBUILD consultable sur le site aur.
Généralement les outils d'installation aur proposent d'éditer ce fichier (pour que l'utilisateur le controle un minimum)
Merci papajoke pour ton explication, mais je pense (n'hésite pas à me le dire sinon :wink: ) que nybac tout comme moi sommes un peu perdu et ne connaissons pas précisément le fonctionnement d'AUR.
A ce titre, je me permet de répondre à l'autre question de nybac en langage noob-Manjaro ...
Et surtout essayer de m'en sortir :siffle

Pour modifier le PKGBUILD, il faut lancer l'installation dans un terminal :

yaourt 4kvideodownloader

4kvideodownloader
1 aur/4kvideodownloader 4.4.7.2307-1 (Out of Date) (48) (1,54)
    Quickly download videos from YouTube in high-quality.
==> Numéro(s) des paquets à installer (ex: 1 2 3 ou 1-3)
==> ----------------------------------------------------
==> 1


==> Téléchargement du PKGBUILD de 4kvideodownloader depuis AUR...
x .SRCINFO
x 4kvideodownloader.desktop
x 4kvideodownloader.png
x PKGBUILD
karcher commented on 2018-07-10 11:42			 

nyilaslaszlo commented on 2018-07-15 07:54			 

karcher commented on 2018-07-23 14:13			 

dellamorte commented on 2018-07-25 09:20			 

Eschwartz commented on 2018-07-27 14:08			 

4kvideodownloader 4.4.7.2307-1  (2018-06-02 19:59)
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> n
C'est à ce moment là que 'on peux modifier le fichier PKGBUILD
En l’occurrence, avec 4kvideodownloader, le problème est plus loin
On ne modifie donc pas "n"

==> Dépendances de 4kvideodownloader :
 - qt5-script (déjà installé)
 - portaudio (déjà installé)
 - chrpath (déjà installé) [makedepend]
 - ffmpeg2.8 (compilation depuis AUR)
==> Lancer la compilation de 4kvideodownloader ? [O/n]
==> --------------------------------------------------
==> o
On lance la compilation en tapant 'o'

==> Construction et installation du paquet
==> Installation/compilation des dépendances manquantes pour 4kvideodownloader:

==> Téléchargement du PKGBUILD de ffmpeg2.8 depuis AUR...
x .SRCINFO
x PKGBUILD
superhdj commented on 2018-06-14 01:48			 

Pietro_Pizzi commented on 2018-06-21 22:17			 

dellamorte commented on 2018-07-25 09:22			 

DrNutz commented on 2018-08-12 01:21			 

WFV commented on 2018-08-17 13:32			 

ffmpeg2.8 2.8.15-1  (2018-07-17 17:59)
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> 

A ce moment là, on peut éditer le PKGBUILD

Taper O

# $Id$
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
# Contributor: Paul Mattal <paul@archlinux.org>

pkgname=ffmpeg2.8
pkgver=2.8.15
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video'
arch=('x86_64')
url='https://ffmpeg.org/'
license=('GPL3')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
         'jack' 'lame' 'libmodplug' 'libpulse' 'libsoxr' 'libssh' 'libtheora'
         'libvdpau' 'libwebp' 'libx11' 'libxcb' 'libxext' 'libxv'
         'opencore-amr' 'openjpeg' 'opus' 'schroedinger' 'sdl' 'speex'
         'v4l-utils' 'xz' 'zlib'
         'libass.so' 'libbluray.so' 'libdcadec.so' 'libfreetype.so' 'libva.so'
         'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
         'libx264.so' 'libx265.so' 'libxvidcore.so')
makedepends=('ladspa' 'yasm')
Grace à l'éditeur nano on va pouvoir modifier le fichier

CTRL-W pour chercher libdcadec.so
Supprimer 'libdcadec.so' avec la touche SUPP
CTRL-O pour sauvegarder
CTRL-X pour quitter

L'installation reprend

Dépendances de ffmpeg2.8 :
 - alsa-lib (déjà installé)
 - bzip2 (déjà installé)
 - fontconfig (déjà installé)
 - fribidi (déjà installé)
 - glibc (déjà installé)
 - gmp (déjà installé)
 - gnutls (déjà installé)
 - gsm (déjà installé)
 - jack (déjà installé)
 - lame (déjà installé)
 - libmodplug (déjà installé)
 - libpulse (déjà installé)
 - libsoxr (déjà installé)
 - libssh (déjà installé)
 - libtheora (déjà installé)
 - libvdpau (déjà installé)
 - libwebp (déjà installé)
 - libx11 (déjà installé)
 - libxcb (déjà installé)
 - libxext (déjà installé)
 - libxv (déjà installé)
 - opencore-amr (déjà installé)
 - openjpeg (déjà installé)
 - opus (déjà installé)
 - schroedinger (déjà installé)
 - sdl (déjà installé)
 - speex (déjà installé)
 - v4l-utils (déjà installé)
 - xz (déjà installé)
 - zlib (déjà installé)
 - libass.so (déjà installé)
 - libbluray.so (déjà installé)
 - libfreetype.so (déjà installé)
 - libva.so (déjà installé)
 - libvidstab.so (déjà installé)
 - libvorbisenc.so (déjà installé)
 - libvorbis.so (déjà installé)
 - libvpx.so (déjà installé)
 - libx264.so (déjà installé)
 - libx265.so (déjà installé)
 - libxvidcore.so (déjà installé)
 - ladspa (déjà installé) [makedepend]
 - yasm (déjà installé) [makedepend]


==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> 
On peux vérifier que tout est OK et si c'est le cas, répondre n


==> Lancer la compilation de ffmpeg2.8 ? [O/n]
==> ------------------------------------------
==> o

On peux passer à la compilation en répondant 'o'

==> Construction et installation du paquet
==> Création du paquet ffmpeg2.8 2.8.15-1 (lun. 20 août 2018 15:43:14 CEST)
==> Vérification des dépendances pour l’exécution…
==> Vérification des dépendances pour la compilation…
==> Récupération des sources…
  -> Téléchargement de ffmpeg-2.8.15.tar.xz…
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 7058k  100 7058k    0     0   329k      0  0:00:21  0:00:21 --:--:--  368k
  -> Téléchargement de ffmpeg-2.8.15.tar.xz.asc…
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   473  100   473    0     0   1455      0 --:--:-- --:--:-- --:--:--  1455
==> Validation des fichiers source avec sha256sums…
    ffmpeg-2.8.15.tar.xz ... Réussite
    ffmpeg-2.8.15.tar.xz.asc ... Ignoré
==> Vérification des signatures des fichiers sources grâce à gpg…
    ffmpeg-2.8.15.tar.xz ... ÉCHEC (Clé publique inconnue B4322F04D67658D8)
==> ERREUR : Une ou plusieurs signatures PGP n’ont pas pu être vérifiées.
==> ERREUR : Makepkg n'a pas pu construire ffmpeg2.8.
Et là par contre...Je ne sais pas :tetu!

:sos:

[AUR] Impossible d'installer 4kyoutubetomp3

#11Messageil y a 9 mois

dropforged a écrit :
il y a 9 mois

==> Vérification des signatures des fichiers sources grâce à gpg…
    ffmpeg-2.8.15.tar.xz ... ÉCHEC (Clé publique inconnue B4322F04D67658D8)
==> ERREUR : Une ou plusieurs signatures PGP n’ont pas pu être vérifiées.
Et là par contre...Je ne sais pas :tetu!
même réponse :
papajoke a écrit :
il y a 9 mois
Nous devrions toujours consulter la page AUR du paquet pour lire les commentaires
la page : https://aur.archlinux.org/packages/ffmpeg2.8
un commentaire bien en évidence :

Build don't work:
==> Verifying source file signatures with gpg...  
ffmpeg-2.8.14.tar.xz ... FAILED (unknown public key B4322F04D67658D8)  
==> ERROR: One or more PGP signatures could not be verified!  
==> ERROR: Makepkg was unable to build ffmpeg2.8. 

[AUR] Impossible d'installer 4kyoutubetomp3

#12Messageil y a 9 mois

Je y arriverai un jour, j'y arriverai... :mrgreen:

Merci papajoke :maître:

[AUR] Impossible d'installer 4kyoutubetomp3

#13Messageil y a 9 mois

On peut contourner le problème de clé GPG avec la commande :

yaourt --m-arg "--skippgpcheck" -S ffmpeg2.8
Mais ça finit encore par planter :

==> Lancer la compilation de ffmpeg2.8 ? [O/n]
==> ------------------------------------------
==> o

==> Construction et installation du paquet
==> Création du paquet ffmpeg2.8 2.8.15-1 (mar. 21 août 2018 12:38:49 CET)
==> Vérification des dépendances pour l’exécution…
==> Vérification des dépendances pour la compilation…
==> Récupération des sources…
  -> ffmpeg-2.8.15.tar.xz trouvé
  -> ffmpeg-2.8.15.tar.xz.asc trouvé
==> ATTENTION : Ignore la vérification des signatures PGP des fichiers sources.
==> Validation des fichiers source avec sha256sums…
    ffmpeg-2.8.15.tar.xz ... Réussite
    ffmpeg-2.8.15.tar.xz.asc ... Ignoré
==> Extraction des sources…
  -> Extraction de ffmpeg-2.8.15.tar.xz avec bsdtar
==> Suppression du répertoire $pkgdir/ existant…
==> Lancement de build()…
ERROR: dcadec not found using pkg-config

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.
==> ERREUR : Une erreur s’est produite dans build().
    Abandon…
==> ERREUR : Makepkg n'a pas pu construire ffmpeg2.8.
WTF ? :saispas:

[AUR] Impossible d'installer 4kyoutubetomp3

#14Messageil y a 9 mois

Bonjour.
Bien que ce soit possible, tu t'embarques vers de gros soucis potentiels à venir... Ffmpeg2.8 est sorti des dépôts officiels et est devenu incompatibles avec ffmpeg. Tôt ou tard, tu auras des conflits incontournables...
Je plussois pour youtube-dl. Il suffit de copier l'url de la vidéo et de faire youtube-dl "https://www.youtube.com/watch?v=DLzxrzFCyOs" par exemple :rigole:
Pour ne charger que l'audio, un alias à se faire avec youtube-dl -t -x --audio-format mp3 --audio-quality 0 "https://www.youtube.com/watch?v=DLzxrzFCyOs"

[AUR] Impossible d'installer 4kyoutubetomp3

#15Messageil y a 9 mois

Ou bien il suffit d'attendre que les mainteneurs des paquets en question corrigent le problème.

Répondre