Problèmes et questions sur les applications multimédia.
Répondre

installation webcamstudio impossible

#1Messageil y a 5 mois

bonjour, j'espere etre sur le bon forum car ma distribution n'est pas manjaro mais bluestar linux qui est aussi une arch
J'essaie d'installer webcamstudio avec yaourt mais cette erreur :

==> Lancer la compilation de gstreamer0.10 ? [O/n]
==> ----------------------------------------------
==> o

==> Construction et installation du paquet
==> Création du paquet gstreamer0.10 0.10.36-17 (jeu. 31 janv. 2019 15:26:50 CET)
==> Vérification des dépendances pour l’exécution…
==> Vérification des dépendances pour la compilation…
==> Récupération des sources…
  -> Téléchargement de gstreamer-0.10.36.tar.xz…
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 2954k  100 2954k    0     0   383k      0  0:00:07  0:00:07 --:--:--  382k
  -> tests-remove-silly-test_fail_abstract_new-check.patch trouvé
  -> bison3.patch trouvé
==> Validation des fichiers source avec sha256sums…
    gstreamer-0.10.36.tar.xz ... Réussite
    tests-remove-silly-test_fail_abstract_new-check.patch ... Réussite
    bison3.patch ... Réussite
==> Extraction des sources…
  -> Extraction de gstreamer-0.10.36.tar.xz avec bsdtar
==> Lancement de prepare()…
patching file tests/check/gst/gstobject.c
patching file gst/parse/grammar.y
Hunk #2 succeeded at 647 (offset -11 lines).
==> Lancement de build()…
fatal: ni ceci ni aucun de ses répertoires parents (jusqu'au point de montage /) n'est un dépôt git
Arrêt à la limite du système de fichiers (GIT_DISCOVERY_ACROSS_FILESYSTEM n'est pas défini).
ln: impossible de créer le lien symbolique '.git/hooks/pre-commit': Aucun fichier ou dossier de ce type
+ check for build tools
  checking for autoconf >= 2.60 ...   checking for autoconf270 >= 2.60 ...   checking for autoconf269 >= 2.60 ...   checking for autoconf268 >= 2.60 ...   checking for autoconf267 >= 2.60 ...   checking for autoconf266 >= 2.60 ...   checking for autoconf265 >= 2.60 ...   checking for autoconf264 >= 2.60 ...   checking for autoconf263 >= 2.60 ...   checking for autoconf262 >= 2.60 ...   checking for autoconf261 >= 2.60 ...   checking for autoconf260 >= 2.60 ... autoconf not found !
You must have autoconf installed to compile gstreamer.
Download the appropriate package for your distribution,
or get the source tarball at ftp://ftp.gnu.org/pub/gnu/autoconf/
  checking for automake >= 1.10 ...   checking for automake-1.11 >= 1.10 ...   checking for automake-1.10 >= 1.10 ... automake not found !
You must have automake installed to compile gstreamer.
Download the appropriate package for your distribution,
or get the source tarball at ftp://ftp.gnu.org/pub/gnu/automake/
  checking for autopoint >= 0.17 ... found 0.19.8.1, ok.
  checking for libtoolize >= 1.5.0 ... found 2.4.6.42-b88ce, ok.
  checking for pkg-config >= 0.8.0 ... found 1.6.0, ok.

- Please get the right tools before proceeding.
- Alternatively, if you're sure we're wrong, run with --nocheck.
==> ERREUR : Une erreur s’est produite dans build().
    Abandon…
==> ERREUR : Makepkg n'a pas pu construire gstreamer0.10.
==> Relancer la compilation de gstreamer0.10 ? [o/N]
Pouvez vous m'aider?
Merci à tous
==> ------------------------------------------------
==>

installation webcamstudio impossible

#2Messageil y a 5 mois

Bonjour,

Loin d'être un spécialiste, je dirai à vue de nez qu'autoconf et automake sont soit pas installés (ce qui me semble bizarre) soit pas Maj dans le pkbuild. Sauf erreur de ma part ces deux "logiciels" font parties du compilateur GCC. ?

Un autre point à voir concerne l'erreur :
GIT_DISCOVERY_ACROSS_FILESYSTEM
qui semble pas configuré. Je ne vois pas ce que cela peut-être. Git est-il installé ?

Je laisse soin aux pros de te répondre de manière plus approfondie. :maître:

installation webcamstudio impossible

#3Messageil y a 5 mois

Bonjour.
Tout d'abord, merci d'utiliser les balises codes. Je viens de le faire pour toi...
La bibliothèque gstreamer0.10 est obsolète depuis deux ans. Gstreamer fournit maintenant gst-plugins-base-libs et autres 'good' 'base' ....qui sont utilisés dans la plupart des utilitaires comme libpulse jack libsoup libdv libshout v4l-utils cairo libgudev speex libraw1394 lame mpg123 twolame etc....
Il faut reprendre les sources de ton paquet et là, vaste programme comme disait le Général....

installation webcamstudio impossible

#4Messageil y a 5 mois

bonjour et merci pour ces réponses; en fait je n'y connais pas grand chose et je suis un peu perdu
Si je comprends bien, ce n'est pas vraiment à ma portée?
Merci
cdlt

installation webcamstudio impossible

#5Messageil y a 5 mois

:bjr:
Salut pacorabano
Comme je suis curieux de tout je mes suis dit ...pourquoi ne pas essayer !!!
Comme j'ai une saveur Kde dont je me sers pour tester certaines choses ..... c'est parti !

yaourt webcamstudio
résultat :

jean@jean-kdetest ~]$ yaourt webcamstudio
1 aur/webcamstudio-git 20170108-2 (0) (0,00)
    Webcam desktop recording suite for producing professional looking broadcasts
2 aur/webcamstudio-module 0.12.0-1 (0) (0,00)
    Kernel module for webcam studio's virtual webcam device
==> Numéro(s) des paquets à installer (ex: 1 2 3 ou 1-3)
==> ----------------------------------------------------
==> 
là j'ai choisi (1) et roule ma poule !
Voilà 10 bonnes minutes que ça compile "because" tous les gstreamer0.10 une bonne douzaine environ , mais tout se passe bien ! Pas de soucis ! je pense vu comme c'est parti que ça va aller au bout ! Juste un peu de patience je crois .
Alors ok je ne suis pas avec " bluestar linux " mais si c'est une Arch tu dois aussi avoir Yaourt qui permet d'installer des softs "AUR" !!
C'est ce qui est en cours sur mon PC.
je te tiens au courant de l'issue de cette installation .
:salut:

installation webcamstudio impossible

#6Messageil y a 5 mois

et bien voila !
30 minutes environ (au moins,voir plus ) plus tard :
Image

Mission accomplie !
:clap:clap

installation webcamstudio impossible

#7Messageil y a 5 mois

bonjour,
merci mais sur bluestar ça ne s'installe pas avec yaourt

message d'erreur suivant :

==> ERREUR : Une erreur s’est produite dans build().
    Abandon…
==> ERREUR : Makepkg n'a pas pu construire gstreamer0.10.
==> Relancer la compilation de gstreamer0.10 ? [o/N]
==> ------------------------------------------------
==> 
merci
Dernière modification par Erwan le 02 Fév 2019, 16:51, modifié 1 fois.
Raison :ajout balises code

installation webcamstudio impossible

#8Messageil y a 5 mois

:saispas::saispas:
donc .... là. :-x:-x
Il ne reste que la solution @lemust83 :
" Il faut reprendre les sources de ton paquet et là, vaste programme comme disait le Général.... "
ce qui est équivalent de :
- Impossible a installer sous "bluestar linux " sans la reprise des sources ou du pkgbuild !
pour qui que ce soit sous bluestar

Désolé :
:desole::desole:

installation webcamstudio impossible

#9Messageil y a 5 mois

MAIS ....
tu devrais vérifier aussi ce que te dis @Cenwen un peu plus haut :
je dirai à vue de nez qu'autoconf et automake sont soit pas installé[/quote]
en effet on peut lire dans ton premier message :
... checking for autoconf260 >= 2.60 ... autoconf not found !
You must have autoconf installed to compile gstreamer.
Download the appropriate package for your distribution,

... checking for automake-1.10 >= 1.10 ... automake not found !
You must have automake installed to compile gstreamer.
Download the appropriate package for your distribution,
Autrement dit :
vérification de autoconf260> = 2,60 ... autoconf introuvable!
Vous devez avoir installé autoconf pour compiler gstreamer.
Téléchargez le paquet approprié pour votre distribution,
... en recherchant automake-1.10> = 1.10 ... automake introuvable!
Vous devez avoir installé automake pour compiler gstreamer.
Téléchargez le package correspondant à votre distribution,
donc vérifie que ces 2 paquets soient installés.
Si ils ne le sont pas, installe les et recommence ton installation de Webcamstudio .
C'est ta dernière chance !
:gsourire:

installation webcamstudio impossible

#10Messageil y a 5 mois

bonjour,
j'ai installé autoconf et automake
Toujours meme erreur et installation impossible
Merci pour votre suivi

Répondre