Problèmes et questions sur les applications multimédia.
Répondre

remplacer ffmpeg dépôt par compile perso

#1Messageil y a 4 mois

Bonjour a tous.

Depuis quelques jours, je cherche a remplacer ffmepg qui est installé par défaut pour gnome par une version compilé par moi même pour avoir l'HEVC.
seul soucis c'est que supprimer la version dépôt me supprime gnome (une partie) et j'ai pas vraiment envie donc comment faire?

Besoin pour handbrake (2160@60fps)

merci a tous.

EDIT:
résolut en lisant un article de chez Phoronix (https://www.phoronix.com/scan.php?page= ... AMF-Vulkan)
j'ai installé amf-amdgpu-pro avec ses dépendances et je pensais a mal qu'en compilant ffmpeg avec ce support cela fonctionnerai.
je n'ai pas encore rebooté mais il semblerai que cela ne remplace pas amdgpu par amdgpu-pro donc c'est nickel (besoin pour steam)
Par contre, je suis surpris de voir le cpu travailler a fond quand même (cpu only=35min, cpu+gpu=6min)
Dernière modification par beuzil y a 4 mois, modifié au total 2 fois.

remplacer ffmpeg dépôt par compile perso

#2Messageil y a 4 mois

bonjour et bienvenue,

oui, c'est possible
  • reprendre le pkgbuild du paquet (et patch)
  • changer le nom (pkgname) et sources en local / ou options compilation
  • ajouter replace = ( ancienpaquet ) et ajouter la même valeur dans provides=(...) et conflicts=(..)
  • créer le paquet depuis ce fichier et installer
c'est ce que fait le paquet aur ffmpeg-get :wink:

remplacer ffmpeg dépôt par compile perso

#3Messageil y a 4 mois

Bonjour, ah ok, je n'avais pas vu que ça se faisait comme ça, pas évident de trouver la réponse avec les bons mots clés.

Par contre, après la convertion, la vidéo est illisible pour tout les lecteurs y compris vlc et le poid de la vidéo change a chaque test de convertion et je ne sais pas d'ou vient le problème car sur une autre machine (bi-opteron/gtx1060) avec handbrake-nvenc ça passe crème et vu le contenu du pkgbuild, ça diffère pas beaucoup de la métode manuelle.

pour nvidia= ./configure --prefix=/usr --enable-nvenc (AUR)
pour amd= ./configure --prefix=/usr --enable-vce (à la main via git)

Par contre, dans les deux cas, gpu a 20/30% d'utilisation et CPU a fond, je pensais que cela soulagerai le cpu mais non.

vidéo d'origine en x265-10bits, convertion en x265 ou h264.

Donc, problème pas si résolu que ça :tetu!
Répondre