Problèmes et questions concernant l'édition XFCE.
Répondre

Thunar: Pas d'option pour lancer un script facilement dans Thunar?

#1Messageil y a 4 mois

Cette fonction a probablement été retirée ces dernières années pour des raison de sécurité. Elle existait jadis. J'ai trouvé ça tout-à-fait par hasard.
Comment la rétablir?

1. Fermer toutes les instances de Thunar en tapant dans un terminal

thunar -q

2. Ouvrir l'éditeur de paramètres

$ xfce4-settings-editor

Attention! Il se lance sans sudo, ce qui pourrait être dangereux.

Image


3. Dans la colonne "canal" sélectionner "thunar" puis nouveau
Dans la case "propriétés" collez ceci (n'oubliez pas le "slash"!); Type booléen et valeur: TRUE puis "Enregistrer"

/misc-exec-shell-scripts-by-default

Puis fermez l'éditeur de paramètres

[Edit] on peut également le faire en ligne de commande (mais je n'ai pas essayé) et c'est bien plus élégant!

xfconf-query --channel thunar --property /misc-exec-shell-scripts-by-default --create --type bool --set true

Capture:
Image

Désormais, quand vous ferez un clic droit sur un script, vous aurez la possibilité de le lancer
Image

Sources:
https://forums.linuxmint.com/viewtopic.php?t=202303
http://practicalrambler.blogspot.com/20 ... -from.html

Thunar: Pas d'option pour lancer un script facilement dans Thunar?

#2Messageil y a 4 mois

Bonjour,

J'ai bien appliqué cette solution :

xfconf-query --channel thunar --property /misc-exec-shell-scripts-by-default --create --type bool --set true
mais l'entrée de menu lance un shell "invisible", ça n'est pratique que pour les scripts invoquant des boîtes de dialogue Zenity ou Yad, pas pour les scripts qui affiche du texte en console.

Mes scripts portant tous le suffixe .sh pour être reconnus comme tels par les éditeurs de texte, la solution que j'ai retenue est la suivante :
Dans Thunar, menu Édition -> Configurer les action personnalisées,
J'ai rajouté l'action "Exécuter dans un terminal" avec les paramètres de réglages suivants :

Image

Image

Les guillemets autour du %f sont nécessaires si votre script invoque des fonctions récursives et se trouve dans un chemin comportant des espaces...
J'ai utilisé l'instruction exo-open --launch TerminalEmulator "%f" afin d'invoquer l'émulateur de terminal favori de l'environnement de bureau.
Attention l'entrée de menu "Exécuter dans un terminal" apparaît vers le bas du menu contextuel.

Il ne vous reste plus qu'à choisir une belle icône pour décorer cette entrée de menu. :sourire:

P.-S. : j'ai failli oublier ; cette méthode referme le script dès qu'il est fini, c'est pourquoi je rajoute à la fin de mes scripts qui affichent des sorties texte en console les deux lignes suivantes pour avoir tout le loisir de lire les sorties :

echo "Appuyer sur Entrée pour quitter..."
read a
Adapté de la source suivante (mais qui ne fonctionnait pas chez moi) :
https://forum-francophone-linuxmint.fr/ ... 518#p81430

Thunar: Pas d'option pour lancer un script facilement dans Thunar?

#3Messageil y a 3 mois

Très intéressant. Désolé de ma réponse tardive mais je ne reçois que rarement des notifications par email quand une réponse est donnée.

Testé avec ce script très simple qui vérifie le temps de démarrage de votre système:

#! /bin/bash
systemd-analyze
echo "Appuyer sur Entrée pour quitter..."
read a

On peut aussi créer un lanceur dans le "Tableau de Bord" XFCE
Dernière modification par Nettlebay le 18 Mai 2019, 21:41, modifié 1 fois.

Thunar: Pas d'option pour lancer un script facilement dans Thunar?

#4Messageil y a 3 mois

Nettlebay a écrit :
il y a 3 mois
Très intéressant. Désolé de ma réponse tardive mais je ne reçois que rarement des notifications par email quand une réponse est donnée.
Bonjour.
Un problème aléatoire qui fait que les FAI nous considèrent parfois comme des spammeurs. Les rejets arrivent dans notre boite et nous traitons les demandes les plus urgentes (Inscriptions , perte de MP etc...) Nous avons suivi les procédures indiquées par les fournisseurs pour ne plus figurer dans leur liste noire . Certains nous proposent même des solutions payantes :twisted:
Désolé pour le désagrément, mais la fonction mail de masse de notre fournisseur est correcte .

Thunar: Pas d'option pour lancer un script facilement dans Thunar?

#5Messageil y a 3 mois

Merci de ta réponse. J'ai connu ça aussi sur d'autres forums. C'est récurrent.

Thunar: Pas d'option pour lancer un script facilement dans Thunar?

#6Messageil y a 2 mois

Une petite amélioration de l'action personnalisée : au lieu de mettre simplement *.sh dans le champ "Motif de fichier" de l'onglet "Conditions d'apparition" dans la boîte de dialogue "Éditer l'action", j'ai mis *.sh;*.pl pour que les script perl soient également traités. Par contre pour les programmes python en *.py ça ne marche pas... Il faudrait à mon avis une autre action personnalisée appelant explicitement l'interpréteur python. Je me pencherai dessus quand j'aurai le temps.

Thunar: Pas d'option pour lancer un script facilement dans Thunar?

#7Messageil y a 2 mois

Ça dépend peut être si ton script est pour python2 ou python3, parce par défaut c'est python3 qui est utilisé.

Thunar: Pas d'option pour lancer un script facilement dans Thunar?

#8Messageil y a 2 mois

Smurf a écrit :
il y a 2 mois
Ça dépend peut être si ton script est pour python2 ou python3, parce par défaut c'est python3 qui est utilisé.
En fait j'ai testé tout à l'heure. Il n'est pas nécessaire de créer une nouvelle action.
On peut rajouter l'extension *.py dans la liste des motifs de fichier de l'action, mais il faut non seulement cocher "Autres fichiers" mais également "Fichiers texte" dans l'onglet "Conditions d'apparition" de la boîte de dialogue "Éditer l'action". Et là ça fonctionne aussi pour les fichier Python !

Répondre