Problèmes et questions concernant l'édition XFCE.
Répondre

Problèmes mise-à-jour ou pacman

#1Messageil y a 10 mois

:triste: Bonjour, me revoilà... Je n'avais pas eu de difficultés depuis plusieurs mois mais voilà que j'ai à nouveau un problème de mise-à-jour ou avec pacman ou pamac... C'est quand j'ai voulu installer aurman que c'est apparu ainsi qu'en essayant d'autres. Voici la sortie Terminal:
:triste:

$ git clone https://aur.archlinux.org/aurman.git
fatal: le chemin de destination 'aurman' existe déjà et n'est pas un répertoire vide.
$ cd aurman
$ makepkg -si
==> Création du paquet aurman 2.17.8-1 (jeu. 16 août 2018 15:56:46 AST)
==> Vérification des dépendances pour l’exécution…
==> Installation des dépendances manquantes… 
[sudo] Mot de passe de user :           
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (5) python-sgmllib-5.2.1-2  expac-9-1  python-dateutil-2.7.3-1
            python-feedparser-5.2.1-2  python-regex-2018.07.11-1

Taille totale installée :  2,77 MiB

:: Procéder à l’installation ? [O/n] 
(5/5) vérification des clés dans le trousseau      [######################] 100%
(5/5) vérification de l’intégrité des paquets      [######################] 100%
(5/5) chargement des fichiers des paquets          [######################] 100%
(5/5) analyse des conflits entre fichiers          [######################] 100%
erreur : la validation de la transaction a échoué (conflit de fichiers)
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__init__.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/__init__.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/_common.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/easter.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/relativedelta.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/rrule.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/tzwin.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/_common.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/easter.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/relativedelta.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/rrule.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__init__.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__pycache__/__init__.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__pycache__/_common.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__pycache__/tz.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__pycache__/win.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/_common.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/tz.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/win.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tzwin.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/__init__.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/__pycache__/__init__.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/__pycache__/rebuild.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/dateutil-zoneinfo.tar.gz est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/rebuild.py est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
==> ERREUR : « pacman » n’a pas pu installer les dépendances manquantes.

Any idea?
Je vais continuer de chercher...
À noter que je viens de réinstaller en test mousepad sans problème.

Problèmes mise-à-jour ou pacman

#2Messageil y a 10 mois

Bonjour .
Normalement, le paquet a du être compilé dans ton dossier git.
Essaye

sudo pacman -U --overwrite "*" chemin-du_paquet_aurman-x64.tar.gz
Jamais essayé....

Problèmes mise-à-jour ou pacman

#3Messageil y a 10 mois

Bonjour,
je trouve plusieurs dossiers git notamment dans .cargo (c'est quoi?) mais rien concernant Aurman. J'avais un dossier aurman dans mon /home mais je l'ai supprimé. Le seule en rapport: /tmp/yaourt-tmp-user/aur-aurman mais je viens de le supprimer aussi.
J'ai testé à partir du dépôt AUR (sans Git). Même résultat:

[user@user ~]$ yaourt -S aurman

==> Téléchargement du PKGBUILD de aurman depuis AUR...
x .SRCINFO
x PKGBUILD
dawcek commented on 2018-07-09 16:54			 

Eschwartz commented on 2018-07-09 17:15			 

Akrai commented on 2018-07-20 17:41			 

mprom commented on 2018-08-07 06:32			 

francoism90 commented on 2018-08-07 07:50			 

aurman 2.17.9-1  (2018-08-16 21:31)
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> n

==> Dépendances de aurman :
 - python (déjà installé)
 - python-requests (déjà installé)
 - git (déjà installé)
 - pyalpm (déjà installé)
 - expac (paquet trouvé)
 - python-regex (paquet trouvé)
 - python-dateutil (paquet trouvé)
 - python-feedparser (paquet trouvé)


==> Lancer la compilation de aurman ? [O/n]
==> ---------------------------------------
==> o

==> Construction et installation du paquet
==> Installation/compilation des dépendances manquantes pour aurman:
[sudo] Mot de passe de user :           
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (5) python-sgmllib-5.2.1-2  expac-9-1  python-dateutil-2.7.3-1
            python-feedparser-5.2.1-2  python-regex-2018.07.11-1

Taille totale installée :  2,77 MiB

:: Procéder à l’installation ? [O/n] 
(5/5) vérification des clés dans le trousseau      [######################] 100%
(5/5) vérification de l’intégrité des paquets      [######################] 100%
(5/5) chargement des fichiers des paquets          [######################] 100%
(5/5) analyse des conflits entre fichiers          [######################] 100%
erreur : la validation de la transaction a échoué (conflit de fichiers)
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__init__.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/__init__.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/_common.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/easter.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/relativedelta.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/rrule.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/__pycache__/tzwin.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/_common.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/easter.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/relativedelta.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/rrule.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__init__.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__pycache__/__init__.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__pycache__/_common.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__pycache__/tz.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/__pycache__/win.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/_common.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/tz.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tz/win.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/tzwin.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/__init__.py est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/__pycache__/__init__.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/__pycache__/rebuild.cpython-36.pyc est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/dateutil-zoneinfo.tar.gz est déjà présent dans le système de fichiers
python-dateutil : /usr/lib/python3.6/site-packages/dateutil/zoneinfo/rebuild.py est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
==> Relancer la compilation de aurman ? [o/N]
==> -----------------------------------------
==> n
[user@user ~]$ 

En relation avec les commentaires signalés: https://aur.archlinux.org/packages/aurman/

Je vais essayer de supprimer les éléments de type dateutil-xxx pour voir

Edit: j'ai essayé d'éditer PKGBUILD en supprimant dateutil. Ça semblait aller mieux mais au final, j'ai eu:

....................................................................................
==> Validation des fichiers source avec md5sums…
    aurman_sources ... Ignoré
==> Vérification des signatures des fichiers sources grâce à gpg…
    aurman_sources git repo ... ÉCHEC (Clé publique inconnue 465022E743D71E39)
==> ERREUR : Une ou plusieurs signatures PGP n’ont pas pu être vérifiées.
==> ERREUR : Makepkg n'a pas pu construire aurman.
..................................................................................

Edit: j'ai supprimé (plutôt renommé) les fichier incriminés et même chose que précédemment: problème de signature à la fin. Je vais essayer de résoudre ce problème maintenant.
RÉSOLU!

OK! Done! Ça fonctionne!

Répondre