Problèmes et questions concernant l'édition XFCE.
Répondre

Médias amovibles ne sont pas montés à la connexion

#1Messageil y a 1 mois

Bien qu'ayant épluchées toutes les pages de la section XFCE, une vingtaine tout de même, et n'ayant pas trouvée de solution, je fais appel aux experts! :sos:
Xfce fraîchement installé me donne déjà quelques soucis. :roll:
Même en ayant cochées toutes les cases dans "disques et médias amovibles", ceux-ci ne sont pas montés après le boot. J'ai bien tentées les diverses solutions proposées dans les anciens fils, mais ceux-ci datant de plus de trois ans, ne m'ont rien apporté.
Y aurait-il une astuce cachée quelque part?

Médias amovibles ne sont pas montés à la connexion

#2Messageil y a 1 mois

:salut: alkiros, attention, les médias amovibles ne sont montés automatiquement, que, et uniquement, à la connexion sur une session ouverte. Jamais au boot avec clé ou disque inséré. :wink:

Médias amovibles ne sont pas montés à la connexion

#3Messageil y a 1 mois

Bonjour erwan,
Je ne parle pas des clés ou disques externes, mais des différentes partitions de mes disques internes.
Sous KDE, je n'ai pas connu ce souci depuis un bon moment, mais là, avec XFCE, je suis obligé de les lancer un par un à la mano. Pas très pratiques, d'autant que j'utilise une partition que j'ai nommée "données", pour y renvoyer, via des raccourcis tous ce qui va dans "/home/alkiros".
Du coup, si je ferme l'ordi avec Firefox et Thunderbird restés ouverts, au boot suivant je me retrouve avec une fenêtre qui me dis que ces derniers ne peuvent être lancés! :oops:
Connais-tu une solution pour remédier à ça?

Médias amovibles ne sont pas montés à la connexion

#4Messageil y a 1 mois

bonjour,

jamais manjaro ne monte automatiquement toutes les partitions de notre(nos) disque dur !
Si nous voulons monter une partition automatiquement alors on l'ajoute dans fstab ; cela a toujours été le cas même avec une partition "de données" comme dans ton cas

voir le 3°) :
45648

Médias amovibles ne sont pas montés à la connexion

#5Messageil y a 1 mois

:bjr: Bien résumé plus haut par papajoke. De plus, il ne s'agit pas de ce que l'on nomme communément des médias amovibles (clés, disques externes etc...) mais bien de médias fixes reliés à la carte mère en permanence. Donc oui il faut identifier les disques ou partitions et renseigner le fstab en conséquence. :wink:

Médias amovibles ne sont pas montés à la connexion

#6Messageil y a 1 mois

papajoke a écrit :
il y a 1 mois
bonjour,

jamais manjaro ne monte automatiquement toutes les partitions de notre(nos) disque dur !
Si nous voulons monter une partition automatiquement alors on l'ajoute dans fstab ; cela a toujours été le cas même avec une partition "de données" comme dans ton cas

voir le 3°) :
45648
Bonjour papajoke,

Désolé de te contredire, mais avec KDE, je n'ai jamais eu besoin de modifier "fstab", juste cocher les bonnes cases dans le centre de configuration de kde.
Et ça ne date pas d'hier!
Mais bon, s'il faut en passer par là pour pouvoir utiliser XFCE à ma guise, je vais le faire. :wink:

Médias amovibles ne sont pas montés à la connexion

#7Messageil y a 1 mois

alkiros a écrit :
il y a 1 mois
avec KDE, je n'ai jamais eu besoin de modifier "fstab"
Tout à fait :bien c'est une fonctionnalité kde uniquement mais extrêmement limitée par rapport à fstab (pas uuid, pas options ni le chemin de montage)

Médias amovibles ne sont pas montés à la connexion

#8Messageil y a 1 mois

papajoke a écrit :
il y a 1 mois
alkiros a écrit :
il y a 1 mois
avec KDE, je n'ai jamais eu besoin de modifier "fstab"
Tout à fait :bien c'est une fonctionnalité kde uniquement mais extrêmement limitée par rapport à fstab (pas uuid, pas options ni le chemin de montage)
Bon ben avant de retourner sur kde, je vais tenter la modif du fstab!

Médias amovibles ne sont pas montés à la connexion

#9Messageil y a 1 mois

:bjr: papajoke

Bon, je ne sais pas où y'a un loup, mais après plusieurs tentatives, vérification, re-vérification de la syntaxe, ça marche pas! :desole:
Voici le contenu de mon fstab modifié en suivant tes conseils:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=4035ac9b-cbcd-4fdd-9e0c-60b73619a6bc /              ext4    defaults,noatime,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
# donnees /dev/sdd1
UUID=24e96f9e-149e-441b-9975-7e148cfefe01 /home/donnees ext4 defaults     0     2
Au reboot, non seulement la partition n'est pas montée, mais elle n'apparait même plus dans la liste de mes périphériques!
Y'a-t'il quelque chose que j'aurais loupé?

Médias amovibles ne sont pas montés à la connexion

#10Messageil y a 1 mois

Bonjour, l'option "discard" est-elle vraiment nécessaire ?
Perso j'aurai fait comme ceci :

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=4035ac9b-cbcd-4fdd-9e0c-60b73619a6bc /              ext4    defaults,noatime,discard 0 1
UUID=24e96f9e-149e-441b-9975-7e148cfefe01 /donnees       ext4    defaults,noatime,        0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=17 7 0 0
Quel retour de blkid ?

Médias amovibles ne sont pas montés à la connexion

#11Messageil y a 1 mois

il faut bien sur que le répertoire de destination existe :wink:

Médias amovibles ne sont pas montés à la connexion

#12Messageil y a 1 mois

Eureka! :pompom:
En fait, le problème venait du chemin indiqué; j'ai modifié la ligne "/donnees" par "/run/media/alkiros/donnees", et ça marche.
:merci::maître:

Répondre