Problèmes et questions concernant l'édition XFCE.

Tableau de bord réinitialisé à chaque démarrage

#21Messageil y a 3 mois

Autant pour moi! J'ai confondu avec .config :oops:
Par ailleurs, Il semble que les éléments/lanceurs seraient depuis quelques temps à l'origine de crashes du panel. Car il s'agit bien d'un crash comme j'ai pu le constater ce matin au moment où j'essayais de créer un lanceur Chromium. Du coup, je n'ose plus en créer d'autres et laisse mes 2 lanceurs Opera & Chromium sur le Bureau (j'aime pas, ça fait cra-cra style Windows) Je vais tout-de-même tester avec des lanceurs comme Thunar, Leafpad ou autres pour voir si c'est l'élément lanceur qui pose problème ou Chromium.

EDIT (14 h loc): il y a effectivement un problème avec les lanceurs (pas seulement avec Chromium). Pour tester, j'ai créé un lanceur pour le terminal XFCE + le lanceur des paramètres de ce même terminal. Au reboot, le lanceur (le contenant en fait) était toujours là mais avait perdu son contenu (icône point d'interrogation). Par contre, le panel est toujours là (cette fois).

EDIT (15:03): voici le log de mes mises-à-jour la veille du début du problème (6 jan). Le problème a commencé le 7 dès le premier instant.

[2019-01-06 11:54] [ALPM] running 'systemd-update.hook'...
[2019-01-06 11:54] [ALPM] transaction completed
[2019-01-06 11:54] [ALPM] installed tabbed (0.6-3)
[2019-01-06 11:54] [ALPM-SCRIPTLET] -- and rebuild package if you want to change settings.
[2019-01-06 11:54] [ALPM-SCRIPTLET] -- Edit config.h in PKGBUILD's directory (generally /var/abs/community/tabbed/)
[2019-01-06 11:54] [ALPM] transaction started
[2019-01-06 11:54] [PACMAN] Running 'pacman -S tabbed'
[2019-01-06 08:06] [ALPM] running 'update-desktop-database.hook'...
[2019-01-06 08:06] [ALPM] running 'systemd-update.hook'...
[2019-01-06 08:06] [ALPM] running 'systemd-daemon-reload.hook'...
[2019-01-06 08:06] [ALPM] transaction completed
[2019-01-06 08:06] [ALPM] upgraded dropbox (63.4.107-1 -> 63.4.107-3)
[2019-01-06 08:06] [ALPM] transaction started
[2019-01-06 08:01] [ALPM] running 'update-mime-database.hook'...
[2019-01-06 08:01] [ALPM] running 'update-desktop-database.hook'...
[2019-01-06 08:01] [ALPM] running 'texinfo-install.hook'...
[2019-01-06 08:01] [ALPM] running 'systemd-update.hook'...
[2019-01-06 08:01] [ALPM] running 'systemd-daemon-reload.hook'...
[2019-01-06 08:01] [ALPM] running 'gtk-update-icon-cache.hook'...
[2019-01-06 08:01] [ALPM] transaction completed
[2019-01-06 08:01] [ALPM] upgraded thunar (1.8.2-1 -> 1.8.2-2)
[2019-01-06 08:01] [ALPM] upgraded rhash (1.3.6-1 -> 1.3.7-1)
[2019-01-06 08:01] [ALPM] upgraded re2 (20181001-1 -> 20190101-1)
[2019-01-06 08:01] [ALPM] upgraded python-lockfile (0.12.2-3 -> 0.12.2-4)
[2019-01-06 08:01] [ALPM] upgraded pamac (7.3.3-1 -> 7.3.4-1)
[2019-01-06 08:01] [ALPM] warning: /etc/pamac.conf installed as /etc/pamac.conf.pacnew
[2019-01-06 08:01] [ALPM] upgraded pacman (5.1.1-3 -> 5.1.2-1)
[2019-01-06 08:01] [ALPM] upgraded libsecret (0.18.6-1 -> 0.18.7-1)
[2019-01-06 08:01] [ALPM] upgraded lib32-harfbuzz (2.2.0-1 -> 2.3.0-1)
[2019-01-06 08:01] [ALPM] upgraded harfbuzz-icu (2.2.0-1 -> 2.3.0-1)
[2019-01-06 08:01] [ALPM] upgraded gzip (1.9-2 -> 1.10-1)
[2019-01-06 08:01] [ALPM] upgraded diffutils (3.6-2 -> 3.7-1)
[2019-01-06 08:01] [ALPM] upgraded cpupower (4.19-1 -> 4.20-1)
[2019-01-06 08:01] [ALPM] upgraded audacious (3.10-1 -> 3.10.1-1)
[2019-01-06 08:01] [ALPM] upgraded pango (1.42.4-1 -> 1.43.0-1)
[2019-01-06 08:01] [ALPM] upgraded harfbuzz (2.2.0-1 -> 2.3.0-1)
[2019-01-06 08:01] [ALPM] upgraded tzdata (2018g-1 -> 2018i-1)
[2019-01-06 08:01] [ALPM] upgraded audacious-plugins (3.10-1 -> 3.10.1-1)
[2019-01-06 08:01] [ALPM] transaction started
[2019-01-06 08:00] [ALPM] running 'systemd-update.hook'...
[2019-01-06 08:00] [ALPM] transaction completed
[2019-01-06 08:00] [ALPM] upgraded manjaro-system (20180828-2 -> 20190105-2)
[2019-01-06 08:00] [ALPM] transaction started
[2019-01-06 08:00] [PAMAC] synchronizing package lists


Tableau de bord réinitialisé à chaque démarrage

#22Messageil y a 3 mois

Pour être sur de ta configuration Tableaux de bord/Lanceurs :

-Click droit sur le TB-->Tableau de bord-->Préférences du tableau de bord
-Vérifie le numéro de TB, "Tableau de bord 3" par exemple
-Ouvre $HOME/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml avec un éditeur de texte
-Trouve la ligne <property name="panel-3" type="empty"> (3 correspondant au numéro trouvé plus haut)
Tu devrais trouver des lignes en dessous ressemblant à ceci :

<property name="plugin-ids" type="array">
        <value type="int" value="12"/>
        <value type="int" value="16"/>
        <value type="int" value="22"/>
        <value type="int" value="17"/>
        <value type="int" value="18"/>
        <value type="int" value="19"/>
        <value type="int" value="20"/>
        <value type="int" value="21"/>
        <value type="int" value="23"/>
        <value type="int" value="1"/>
      </property>

Chaque lanceur est identifié par un numéro (value) que tu vas retrouver dans $HOME/.config/xfce4/panel/ sous la forme d'un répertoire, si c'est un lanceur que tu as créé, ou d'un fichier .rc, si c'est un élément de bureau.

Dans mon exemple, value="12" correspond au fichier whiskermenu-12.rc, value="16" correspond au répertoire launcher-16 dans lequel se trouve un fichier .desktop contenant les données du lanceur.

Tableau de bord réinitialisé à chaque démarrage

#23Messageil y a 3 mois

OK! Bien reçu... Je vais voir ça dès que possible...
Edit: 13:23

<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-panel" version="1.0">
  <property name="panels" type="uint" value="1">
    <property name="panel-0" type="empty">
      <property name="position" type="string" value="p=8;x=720;y=884"/>
      <property name="length" type="uint" value="100"/>
      <property name="position-locked" type="bool" value="false"/>
      <property name="plugin-ids" type="array">
        <value type="int" value="8"/>
        <value type="int" value="1"/>
        <value type="int" value="3"/>
        <value type="int" value="7"/>
        <value type="int" value="6"/>
        <value type="int" value="10"/>
        <value type="int" value="5"/>
        <value type="int" value="11"/>
        <value type="int" value="2"/>
        <value type="int" value="9"/>
      </property>
      <property name="role" type="string" value="xfce4-panel-12965750720"/>
      <property name="length-adjust" type="bool" value="true"/>
      <property name="background-style" type="uint" value="0"/>
      <property name="size" type="uint" value="27"/>
      <property name="mode" type="uint" value="0"/>
      <property name="autohide-behavior" type="uint" value="0"/>
    </property>
  </property>
  <property name="plugins" type="empty">
    <property name="plugin-2" type="string" value="actions">
      <property name="appearance" type="uint" value="1"/>
      <property name="invert-orientation" type="bool" value="true"/>
      <property name="items" type="array">
        <value type="string" value="-logout-dialog"/>
        <value type="string" value="-switch-user"/>
        <value type="string" value="-separator"/>
        <value type="string" value="+logout"/>
        <value type="string" value="-lock-screen"/>
        <value type="string" value="-hibernate"/>
        <value type="string" value="-suspend"/>
        <value type="string" value="-restart"/>
        <value type="string" value="-shutdown"/>
      </property>
    </property>
    <property name="plugin-6" type="string" value="systray">
      <property name="names-visible" type="array">
        <value type="string" value="pnmixer"/>
        <value type="string" value="manjaro-settings-manager-daemon"/>
        <value type="string" value="networkmanager applet"/>
        <value type="string" value="orage"/>
        <value type="string" value="pamac-tray"/>
        <value type="string" value="blueman-applet"/>
        <value type="string" value="clipman"/>
        <value type="string" value="xfce4-power-manager"/>
        <value type="string" value="xnoise"/>
      </property>
    </property>
    <property name="plugin-3" type="string" value="tasklist">
      <property name="grouping" type="uint" value="1"/>
    </property>
    <property name="plugin-7" type="string" value="separator">
      <property name="expand" type="bool" value="true"/>
      <property name="style" type="uint" value="1"/>
    </property>
    <property name="plugin-5" type="string" value="clock">
      <property name="mode" type="uint" value="2"/>
    </property>
    <property name="plugin-1" type="string" value="showdesktop"/>
    <property name="plugin-8" type="string" value="whiskermenu"/>
    <property name="plugin-10" type="string" value="notification-plugin"/>
    <property name="plugin-11" type="string" value="xfce4-timer-plugin"/>
    <property name="plugin-9" type="string" value="launcher"/>
  </property>
  <property name="configver" type="int" value="2"/>
</channel>

Dans les péférences, mon tableau de bord est 0 (zéro)
J'ai <property name="panel-0" type="empty">

<property name="plugin-ids" type="array">
        <value type="int" value="8"/>
        <value type="int" value="1"/>
        <value type="int" value="3"/>
        <value type="int" value="7"/>
        <value type="int" value="6"/>
        <value type="int" value="10"/>
        <value type="int" value="5"/>
        <value type="int" value="11"/>
        <value type="int" value="2"/>
        <value type="int" value="9"/>
      </property>
      
      
Pour le contenu de $HOME/.config/xfce4/panel/:

Image

Ça n'a pas grand-chose à voir...
Dans les dossiers de lanceurs, ce sont les lanceurs (essentiellement) de Terminal, en fait des restes d'essais.
Launcher-8 est "Liste des Applications" que j'avais essayé (xfce4-appfinder). Note: les 2 minuteurs sont normaux, j'en affiche en effet 2 simultanément (pour la cuisine principalement) voire 3 parfois...

Petit truc pour ceux qui ne le connaîtraient pas: quand on se retrouve avec des fichiers desktop au nom indéchiffrable, il suffit de faire un clic droit sur le ou les fichiers (dans Thunar par exemple) > Propriétés > Permissions > "autoriser ce fichier à être exécuté comme un programme". Ainsi, leur vrai nom apparaît et même leur icône. On peut sélectionner plusieurs fichiers à la fois.

EDIT: 14:54
Je viens de rajouter un lanceur (Audacity), il est apparu immédiatement dans Launcher-9. Pas de problème donc à ce niveau. Je vais redémarrer pour voir s'il s'y trouve encore après un reboot.
EDIT: 15:01
Il a évidemment disparu du lanceur dans le panel mais se trouve toujours dans /.config/xfce4/panel/launcher-9/

Tableau de bord réinitialisé à chaque démarrage

#24Messageil y a 3 mois

Ça a quand même quelque chose à voir, ça permet de vérifier que ses lanceurs sont bien sauvegardés correctement.

Dans la dernière mise à jour, on trouvait xfce4-panel-gtk3 et xfdesktop-gtk3, dans le doute, je ferais une réinstallation de ces deux paquets.

Tableau de bord réinitialisé à chaque démarrage

#25Messageil y a 3 mois

Bonjour Smurf.
Dans la dernière mise à jour, on trouvait xfce4-panel-gtk3 et xfdesktop-gtk3, dans le doute, je ferais une réinstallation de ces deux paquets.
Mais j'ai xfce4-panel et xfdesktop simplement. Faut-il que j'installe xfce4-panel-gtk3 et xfdesktop-gtk3 ? N'y a-t-il pas un risque de conflit + peut-être même une réinitialisation de mon environnement? J'ai déjà expérimenté des problèmes avec par exemple thunar-archive-plugin-gtk3.

EDIT 11:27 (loc): je viens de réinstaller xfce4-panel et xfdesktop à tous hasards...Pas de changements: mon lanceur a redisparu au reboot.

EDIT 16:25: Nouveau! L'élément "bouton d'action" disparaît en apparence mais il est toujours là dans les préférences mais invisible.

Tableau de bord réinitialisé à chaque démarrage

#26Messageil y a 3 mois

:clap OLÉÉÉ! RÉSOLU!!! :pompom:
J'ai continué à faire le ménage dans mes fichiers XFCE et me suis rendu-compte qu'il y en avait encore 4 de type gtk3:

exo-gtk3
xfconf-gtk3
libxfce4ui-gtk3
libxfce4util-gtk3

à remplacer par:

exo
xfconf
libxfce4ui
libxfce4util

Note: xfconf-gtk3 doit être impérativement désinstallé avant libxfce4util-gtk3 sinon on a droit à un message d'erreur.

Tout est rentré dans l'ordre après 2 redémarrages, càd maintenant mes lanceurs ne disparaissent plus... Bon, OK! c'est pas bien... je devrait tout remettre sous gtk3 mais malheureusement, certains plugins ne seraient pas encore parfaitement au point..

Merci Smurf pour le déclic :gsourire:
Dans la dernière mise à jour, on trouvait xfce4-panel-gtk3 et xfdesktop-gtk3, dans le doute, je ferais une réinstallation de ces deux paquets.

Répondre