Problèmes et questions concernant l'édition XFCE.
Répondre

Goodvibes/Conky

#1Messageil y a 3 mois

:salut: tous le monde,

Je voudrais afficher la radio qui passe dans GVibes dans mon conky.
J'ai trouvé sur le site de Gvibes un conky :
${if_match "${execi 10 qdbus org.mpris.MediaPlayer2.Goodvibes /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.PlaybackStatus}" == "Playing"}\
Goodvibes Info
Station:${execpi 10 qdbus org.mpris.MediaPlayer2.Goodvibes /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Metadata | grep "^goodvibes:station:" | cut -d':' -f3-}
Artist - Track:${execpi 10 qdbus org.mpris.MediaPlayer2.Goodvibes /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Metadata | grep "^xesam:title:" | cut -d':' -f3-}\
${else}\
Goodvibes is not playing\
${endif}
Mais ça ne fonctionnne pas

Goodvibes/Conky

#2Messageil y a 3 mois

:salut:

pour que cette ligne fonctionne (a tester)

qdbus org.mpris.MediaPlayer2.Goodvibes /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Metadata 
il faut que l'application "Goodvibes" soit installée et sans doute lancée
De plus qdbus et un utilitaire qt, je suppose qu'avec xfce on utilise plutôt gdbus (qui a une syntaxe différente)

Goodvibes/Conky

#3Messageil y a 3 mois

${if_match "${execi 10 qdbus org.mpris.MediaPlayer2.Goodvibes /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.PlaybackStatus}" == "Playing"}\
Goodvibes Info
Station:${execpi 10 qdbus org.mpris.MediaPlayer2.Goodvibes /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Metadata | grep "^goodvibes:station:" | cut -d':' -f3-}
Artist - Track:${execpi 10 qdbus org.mpris.MediaPlayer2.Goodvibes /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Metadata | grep "^xesam:title:" | cut -d':' -f3-}\
${else}\
Goodvibes is not playing\
Pas mieux

Gvides est bien installé et tourne

De plus qdbus et un utilitaire qt
Interface de communication pour les applications qt. OK et ?

Goodvibes/Conky

#4Messageil y a 3 mois

papajoke a écrit : il y a 3 mois (a tester)
testé ? quel est l'erreur ?
comme dit plus haut, si c'est qtbus (l'erreur), c'est qu'il n'est pas installé (qt5-tools)
xfce et vibes c'est du gtk et pas du qt donc normalement tu ne devrais pas utiliser qtbus mais gdbus qui est l'utilitaire proche mais fait pour gtk (mais il faut ré-écrire tout ton code)

Goodvibes/Conky

#5Messageil y a 3 mois

Bon ça fonctionne j'ai installé tous les qt5-tools (2)
Merci beaucoup :maître::wink:

Par contre les artiste/titre ne fonctionne pas, mais je vais essayé tous seul et partagerais le conky une fois fonctionnel

Goodvibes/Conky

#6Messageil y a 3 mois

Une autre question :
Pourquoi le thème sombre ne fonctionne pas chez moi ?

Goodvibes/Conky

#7Messageil y a 3 mois

Tu parles de ton application goodvibes ?
Elle est gtk, mais existe gtk2 et gkt3, il me semble que se sont 2 piles graphiques différentes qui utilisent un thème différent

Goodvibes/Conky

#8Messageil y a 3 mois

oui l'application on peut modifier mais chez moi ça ne fait rien

Goodvibes 0.6.3
GTK 3.24.21

Goodvibes/Conky

#9Messageil y a 3 mois

:salut:
Une petite idée de comment mettre Goodvibes en mode "sombre" l'option es dispo dans les préférences mais ne fonctionne pas.

Goodvibes/Conky

#10Messageil y a 3 mois

Résolu en installant le paquet AUR à la place du Flatpak
Répondre