Problèmes et questions concernant l'édition KDE.
Répondre

Recadrer le bureau?

#1Messageil y a 3 ans

Bonjour,

J'essaye afficher l'écran manjaro sur une TV funai LT6-M19WB (en HDMI) et désactiver l'écran de mon PC portable. Dans System Settings je configure la résolution (1920x1080), primary display: HDMI1, je désactive laptop screen. A ce moment la, plasma suis tant bien que mal, je retrouve le tableau de bord, mais au moins 2cm en dehors de l'écran. D’où ma question: est-il possible de définir les bordures de l'écran depuis KDE (la TV n'est pas réglable--'). Le bureau déborde d'au moins 2cm de tous les côtés.

Merci d'avance

Recadrer le bureau?

#2Messageil y a 3 ans

Bonsoir,

Je commencerais par diminuer la résolution et regarder ce qui se passe. Ça ne risque rien.

JLB

Recadrer le bureau?

#3Messageil y a 3 ans

Bonjour,
C'est bien la bonne résolution, si je diminue, le bureau est mal proportionné, ou trop gros, et il y a toujours un débordement!

Recadrer le bureau?

#4Messageil y a 3 ans


Recadrer le bureau?

#5Messageil y a 3 ans

la résolution 1440*900 n'est pas proposé dans le system settings. J'ai donc créer ma résolution, paramétré mon écran avec xrandr:

$ cvt -v 1440 900
$ xrandr --newmode "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
$ xrandr --addmode HDMI1 1440x900_60.00
$ xrandr --output HDMI1 --mode 1440x900_60.00


(http://www.delafond.org/traducmanfr/X11/man1/xrandr.1x.htmlhttps://wiki.archlinux.org/index.php/Xrandr)

Résultat: écran noir avec le message "format incompatible" sur la TV.

Le résultat visuel est bon avec une résolution de 1920x1080, à part les bordures.

J'ai aussi essayé les paramètres --pos, --size et --panning sans résultat..

Recadrer le bureau?

#6Messageil y a 3 ans


Recadrer le bureau?

#7Messageil y a 3 ans

Alors je ne sais pas si ça va aider ou non, chez moi la TV (Samsung) fait ça avec la PS3, il y a une option à la noix à sélectionner quand tu choisis l'entrée image HDMI de ta télé, il faut la configurer en tant qu'entrée de type PC pour qu'elle mette l'intégralité de l'image... C'est débile, je ne sais pas pourquoi, mais ça marche...

Recadrer le bureau?

#8Messageil y a 3 ans

Bonjour,

les seuls paramètres de cette :censure: de TV sont contraste/luminosité/teinte --'

J'ai branché une PS3 en HDMI, résultat image parfaitement ajusté avec la config auto: 1080i 25Hz

D'après wikipédia : https://fr.wikipedia.org/wiki/D%C3%A9finition_d%27%C3%A9cran et https://fr.wikipedia.org/wiki/1080i
le 1080i donne du 1920x1080 entrelacé ratio 16:9

J'ai testé cette config sur windobe. Résultat, c'est l'effet inverse, il y a des bordures noires.
Après ajustement avec utilitaire du pilote intel, la bonne config est: 1920x1080 25Hz échelle horizontale 55% échelle verticale 55%
Reste à configurer la même chose sur manjaro^^

Recadrer le bureau?

#9Messageil y a 3 ans

Impossible de voir mon tableau de bord. J'ai testé toutes les résolutions possibles: la résolution 1920x1080 proposé d'office dans le system settings est bonne. Je pense que le problème viens de l'origine de l'écran qui est en haut à gauche en dehors de la TV. Lorsque je modifie la taille de l'écran avec xrandr --scale, l'écran est réduit par la droite et le bas. Alors que sur windows l'écran est réduit de 25% à gauche et 25% à droite si ont ajuste de 50% sur la largeur. L'origine de l'écran est au centre sur windows.
Il faudrait donc trouver un moyen de déplacer mon origine :? L'option --pos de xrandr ne marche pas lorsqu'il y a un seul écran d'activé.

Recadrer le bureau?

#10Messageil y a 3 ans

J'ai également eu le même problème avec mythbuntu sur ma télé samsung, et c'est bien un réglage de la télé que j'ai du changé, je l'avais déjà fait une fois et est eu la monstre peine à le retrouver la deuxième fois que j'ai du le faire.

Recadrer le bureau?

#11Messageil y a 1 mois

Je fais un déterrage dans les règles mais étant confronté au même problème je me suis penché sur la question et est trouvé la solution :
Présentation du pb en image avec une solus et mon vieux plasma de 42 pouces Hitachi Platara 9700

Quand j'installe n'importe quelle distribution avec pour écran mon vieux plasm, l'affichage qui "déborde" de la dalle que ce soit en FHD (1920 x 1080) ou HD (1280x720) voir photo 1 ci-dessous
https://framapic.org/FmqoCVuWR2rE/yosOEJs1OmXX.JPG

Si je coche le bouton "Ajust For TV" j'ai un affichage recadré qui affiche 100% du bureau ... un zoom arrière
Voir photo 2 le trait en rouge délimite le bureau de la solus
https://framapic.org/JZ8BTWGkXMuv/lmySYwrHBsKC.JPG

La solution est plutôt enfantine quand on la trouvé, en l’occurrence la solution est dans le WIki d'Arch :
"Correction of overscan tv resolutions via the underscan property"
... appliquer "underscan" pour changer la valeur des bordures. Pour se faire utilise la commande underscan vborder et underscan hborder values, ces 2 valeurs peuvent être différente ... a vous de faire le réglage de façon empirique

exemple
HDMI-1 ma sortie vidéo
25 la taille de la bordure vertical (réduction de la largeur du bureau plus le chiffre est grand plus ça réduit)
30 la taille de la bordure horizontale (réduction de la hauteur du bureau plus le chiffre est grand plus ça réduit)

xrandr --output HDMI-1 --set underscan on --set "underscan vborder" 25 --set "underscan hborder" 30
je vous l'avais dit c'est fastoche !! :bien
maintenant pour que ce réglage soit "en dur" au démarrage j'ai besoin de votre aide

Répondre