Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#61Messageil y a 2 semaines

Bonjour à tous et surtout excellente nouvelle année ..!!

Et bien moi cet M.A.J sonne la fin de ma carte vidéo je pense.
c'est une Nvidia GEForce 510 et pilote 390xxx, mais j'ai les processeurs a 50% et Kwins a 20% plus d'effets de bureau et Plamashell au plafond aussi ..!
Pourtant ca fonctionne mais moins bien .. voila , ai je raté quelque chose ..?
Merci

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#62Messageil y a 2 semaines

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#63Messageil y a 2 semaines

Merci Stéphane , je regarde ça de suite , je te tiens au courant içi .

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#64Messageil y a 2 semaines

Bon, j'ai bien tenté de suivre notre collègue anglais mais j'ai perdu l'interface graphique, j'ai remis les fichiers Xorg comme avant .
Mais je sens que la pîste est bonne ..
Merci quand même.

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#65Messageil y a 2 semaines

Tout est revenu comme avant grâce a cette solution.
Merci encore.

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#66Messageil y a 1 semaine

J'ai eu le même souci avec mes pilotes nvidia 390 : les applis utilisant opengl ne faisaient pas appel à ma carte graphique mais utilisaient à la place llvmpipe (donc avec des performances très médiocres)

résolu en rédigeant ce fichier :
/usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf
de la sorte (comme indiqué sur une page du forum anglais)

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"
EndSection
Je vais donc conserver ma vielle carte nvidia GT 430 encore quelques temps :)

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#67Messageil y a 1 semaine

Ouf ..! moi aussi ma vieille GE510 fonctionne parfaitement avec cette modif
Encore un grand merci a Stéphane ..!

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#68Messageil y a 1 semaine

Bonjour,

MAJ de Deepin.

J'ai récupéré l'interface graphique. :pompom:

Toutefois, il y a encore quelques bogues:
  • impossible de l'arreter avec le bouton (rien ne se passe) mais par contre cela fonctionne (outre la console) avec cairo dock
  • gele du bureau si on veut changer le papier peint
Un autre problème liè à la maj, il n'a pas reconnu (au niveau du choix du système) le windaube que j'avais installé pour faire du reverse engenering il y a 2 ans.
J'ai été obligé de faire :
  • sudo update-grub
puis
  • sudo grub-mkconfig -o /boot/grub/grub.cfg
puis
  • sudo update-grub
De mémoire. :pappy:

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#69Messageil y a 1 semaine

MAJ de 695 paquets sous Cinnamon. :siffle

redémarrage => pas ras. :tetu!:tetu!
Pas d'accés au noyau 5.9.
Mais au noyau 5.4 LTS.
Test avec le 5.10 même resultat que le 5.9 que je me suis empressé de désinstaller. J'ai aussi (après test de suppression du 5.9) desisntaller le 5.10. On voit qu'il essait de se lancer avec la ligne concernant ma partition de boot puis un tiret et plus rien. :tetu!:furieux::censure:

2eme surprise plus d'accés à internet. Et j'ai pourtant le module broadcom-wl pour chaque noyau. Mais ma carte pci n'est plus reconnue (notification wifi) :o:shock::saispas::saispas:
POUR CEUX ET CELLES QUI ONT UNE PUCE WIFI PCI OU USB BROADCOM BCM 43142 ET CONSEUR,
un nouveau meta paquet à été crée en fin d'année par Phil; il se nomme

broadcom-wl-dkms
Il est à installer et remplacera/desinstallera l'ancien/les anciens module lié au noyau.
Pour moi c'était linux54-broadcom-wl // linux419-broadcom-wl//etc.
Au redémarrage suivant tout rentre dans l'ordre. :bon::biere:

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#70Messageil y a 1 semaine

stephane a écrit : il y a 2 semaines tus as installé en btrfs ?
Bonjour Stephane et bonne année à tous! Que veux-tu dire par btrfs...? Parce que je suis en fs et j'ai le même problème de dédoublement et certains Kernels ne marchent plus d'ailleurs... ou en initranf seulement..? :roll:
Je réédite mon message car j'ai un "failed to start light display manager" et ce quel que soit le noyau maintenant...! :pleure:
Heureusement si je me mets en tty et que je fais un startx il démarre, mais c'est un peu balot... :dormir:
Avant la maj je me souviens avoir installé rebuild-detector mais ne suis plus sûr d'avoir lancé la commande "pamac -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-package")" :pappy:
Est-ce que ça pourrait venir de là? Autre bizzarerie... certaines touches multimedia provoquent le gel du système en 5.10... :confus:

journalctl -b0 -p3 me donnent de nouvelles erreurs...

journalctl -b0 -p3
-- Journal begins at Thu 2020-11-19 21:50:46 CET, ends at Wed 2021-01-13 10:47:59 CET. --
déc. 16 18:55:18 rch kernel: __common_interrupt: 1.55 No irq handler for vector
déc. 16 18:55:21 rch kernel: wdat_wdt wdat_wdt: can't request region for resource [mem 0xfec000f0-0xfec000f3]
janv. 13 10:21:15 rch kernel: kvm: disabled by bios
janv. 13 10:21:16 rch kernel: kvm: disabled by bios
janv. 13 10:21:16 rch systemd[1]: Failed to start Light Display Manager.
janv. 13 10:21:18 rch systemd-backlight[636]: Failed to get backlight or LED device 'backlight:acpi_video0': >
janv. 13 10:21:18 rch systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_vid>
janv. 13 10:22:04 rch pulseaudio[1543]: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit: Unit>
lines 1-9/9 (END)
Bon finalement, après moult prises de tête :tetu! , j'ai compris dans le verbiage des retours d'erreur qu'il vaudrait mieux que j'installe smartctl et tout est rentré dans l'ordre!
Bonne soirée à tous

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#71Messageil y a 5 jours

hi !

nickel pour moi aussi cette maj :merci:

ps : petite question, fsync est il activé dans tous les noyaux manjaro ? car cela avait été précisé pour les 5.7 mais ce n'est plus mentionné

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#72Messageil y a 5 jours

Linkall a écrit : il y a 5 jours hi !

nickel pour moi aussi cette maj :merci:

ps : petite question, fsync est il activé dans tous les noyaux manjaro ? car cela avait été précisé pour les 5.7 mais ce n'est plus mentionné
Bonjour.
Apparemment, ce n'est plus une fonction nécessaire avec l'évolution des HFS.
https://linux.developpez.com/actu/31121 ... immediate/

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#73Messageil y a 5 jours

Merci pour cet article qui résume bien les nouveautés du 5.10

Mais je parlais de la fonctionnalité Fsync/futex de valve j'aurais du être plus précis my bad :?

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#74Messageil y a 5 jours

:bjr: Sympa le lien, je n'y comprend pas grand chose... mais j'ai bien aimé leur humour:
L’équipe continue toujours d’étudier des alternatives pour résoudre le problème de l’an 2038, censé ramener les systèmes Unix en 1901. Pour ce faire, Darrick J. Wong, le responsable du système de fichiers XFS, a soumis des correctifs pour XFS pour Linux 5.10 qui devraient retarder le problème de l'an 2038 pour XFS de 448 années supplémentaires. Cela devrait être suffisant pour trouver une véritable solution à long terme.
:rigole:

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#75Messageil y a 5 jours

Grain de sable a écrit : il y a 1 semaine [

Bonjour Stephane et bonne année à tous! [
Je réédite mon message car j'ai un "failed to start light display manager" et ce quel que soit le noyau maintenant...! :pleure:
Heureusement si je me mets en tty et que je fais un startx il démarre, mais c'est un peu balot... :dormir:
Avant la maj je me souviens avoir installé rebuild-detector mais ne suis plus sûr d'avoir lancé la commande "pamac -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-package")" :pappy:
Est-ce que ça pourrait venir de là? Autre bizzarerie... certaines touches multimedia provoquent le gel du système en 5.10... :confus:

journalctl -b0 -p3 me donnent de nouvelles erreurs...

journalctl -b0 -p3
-- Journal begins at Thu 2020-11-19 21:50:46 CET, ends at Wed 2021-01-13 10:47:59 CET. --
déc. 16 18:55:18 rch kernel: __common_interrupt: 1.55 No irq handler for vector
déc. 16 18:55:21 rch kernel: wdat_wdt wdat_wdt: can't request region for resource [mem 0xfec000f0-0xfec000f3]
janv. 13 10:21:15 rch kernel: kvm: disabled by bios
janv. 13 10:21:16 rch kernel: kvm: disabled by bios
janv. 13 10:21:16 rch systemd[1]: Failed to start Light Display Manager.
janv. 13 10:21:18 rch systemd-backlight[636]: Failed to get backlight or LED device 'backlight:acpi_video0': >
janv. 13 10:21:18 rch systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_vid>
janv. 13 10:22:04 rch pulseaudio[1543]: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit: Unit>
lines 1-9/9 (END)
Bon finalement, après moult prises de tête :tetu! , j'ai compris dans le verbiage des retours d'erreur qu'il vaudrait mieux que j'installe smartctl et tout est rentré dans l'ordre!
Bonne soirée à tous
bonjour
peux tu nous fournir

inxi -Fza
sudo ls /sys/class/backlight
sudo systemctl status  systemd-backlight@backlight:acpi_video0.service
sudo mhwd-kernel -li
sudo mhwd -li
sudo ls /etc/mkinitcpio.d/*.preset
sudo ls /usr/bin/modules/
Dernière modification par stephaneil y a 4 jours, modifié au total 1 fois.

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#76Messageil y a 4 jours

:bjr: Stephane, je n'ai plus eu de problèmes (voir edit de fin de post) depuis installation de smartctl et sa mise / enable... mais, oui bien sûr!

[jc@rch ~]$ inxi -Fza
System:    Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=fccab429-9e35-41b6-9a68-c00f83ec2513 
           rw quiet resume=UUID=ea8e7b80-3fe0-44d9-8535-aa20a89eb753 
           Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel, cairo-dock, tint2 wm: Compiz 0.9.14.1 
           dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Packard Bell product: ENLE11BZ v: V2.11 serial: <filter> 
           Mobo: Packard Bell model: EG70_BZ serial: <filter> UEFI: Insyde v: 2.11 date: 12/13/2012 
Battery:   ID-1: BAT0 charge: 44.0 Wh condition: 44.0/48.4 Wh (91%) volts: 11.8/10.8 model: AS10D41 
           type: Li-ion serial: N/A status: Full 
CPU:       Info: Dual Core model: AMD E1-1200 APU with Radeon HD Graphics bits: 64 type: MCP arch: Bobcat 
           family: 14 (20) model-id: 2 stepping: N/A microcode: 5000119 L2 cache: 512 KiB 
           flags: lm nx pae sse sse2 sse3 sse4a ssse3 svm bogomips: 5592 
           Speed: 784 MHz min/max: 777/1400 MHz Core speeds (MHz): 1: 784 2: 777 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Wrestler [Radeon HD 7310] vendor: Acer Incorporated ALI driver: radeon v: kernel 
           bus ID: 00:01.0 chip ID: 1002:9809 
           Device-2: Chicony HD WebCam type: USB driver: uvcvideo bus ID: 4-4:2 chip ID: 04f2:b374 
           Display: x11 server: X.Org 1.20.10 compositor: compiz v: 0.9.14.1 driver: ati,radeon 
           unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 screens: 1 
           Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") s-diag: 485mm (19.1") 
           Monitor-1: LVDS res: 1600x900 hz: 60 dpi: 106 size: 382x215mm (15.0x8.5") diag: 438mm (17.3") 
           OpenGL: renderer: AMD PALM (DRM 2.50.0 / 5.10.2-2-MANJARO LLVM 11.0.0) v: 3.3 Mesa 20.3.1 
           compat-v: 3.1 direct render: Yes 
Audio:     Device-1: AMD Wrestler HDMI Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:01.1 chip ID: 1002:1314 
           Device-2: AMD FCH Azalia vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1022:780d 
           Sound Server: ALSA v: k5.10.2-2-MANJARO 
Network:   Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Wistron NeWeb driver: ath9k 
           v: kernel port: 3100 bus ID: 03:00.0 chip ID: 168c:0032 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: atl1c v: kernel port: 2000 bus ID: 04:00.0 chip ID: 1969:1083 
           IF: enp4s0 state: down mac: <filter> 
Drives:    Local Storage: total: 447.13 GiB used: 199.32 GiB (44.6%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT480BX500SSD1 size: 447.13 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: R022 
Partition: ID-1: / raw size: 439.29 GiB size: 431.39 GiB (98.20%) used: 199.32 GiB (46.2%) fs: ext4 
           dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 288 KiB (0.1%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 7.55 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
           maj-min: 8:3 
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A gpu: radeon temp: 65.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 157 Uptime: 5h 35m wakeups: 1 Memory: 7.35 GiB used: 1.35 GiB (18.3%) Init: systemd 
           v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1973 lib: 522 flatpak: 0 Shell: Bash v: 5.1.0 
           running in: xfce4-terminal inxi: 3.2.01 
- ensuite pour sudo ls /sys/class/backlight, la réponse est : radeon_bl0
- pour sudo systemctl status systemd-backlight@backlight:acpi_video0.service

sudo systemctl status  systemd-backlight@backlight:acpi_video0.service
● systemd-backlight@backlight:acpi_video0.service - Load/Save Screen Backlight Brightness of backlight:acpi_v>
     Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static)
     Active: failed (Result: exit-code) since Thu 2021-01-14 22:10:38 CET; 17h ago
       Docs: man:systemd-backlight@.service(8)
    Process: 631 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:acpi_video0 (code=exited, status>
   Main PID: 631 (code=exited, status=1/FAILURE)

janv. 14 22:10:38 rch systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:acpi_video0...
janv. 14 22:10:38 rch systemd-backlight[631]: Failed to get backlight or LED device 'backlight:acpi_video0': >
janv. 14 22:10:38 rch systemd[1]: systemd-backlight@backlight:acpi_video0.service: Main process exited, code=>
janv. 14 22:10:38 rch systemd[1]: systemd-backlight@backlight:acpi_video0.service: Failed with result 'exit-c>
janv. 14 22:10:38 rch systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_vid>
lines 1-12/12 (END)

sudo mhwd-kernel -li

Currently running: 5.10.2-2-MANJARO (linux510)
The following kernels are installed in your system:
   * linux419
   * linux510
   * linux54
sudo mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!
Ensuite pour sudo ls /etc/mkinitcio.d/*.preset:
ls: impossible d'accéder à '/etc/mkinitcio.d/*.preset': Aucun fichier ou dossier de ce type
et pareil pour sudo ls /usr/lib/modules/ :ls: impossible d'accéder à '/usr/bin/modules/': Aucun fichier ou dossier de ce type

4.19.163-1-MANJARO  5.4.85-1-MANJARO	       extramodules-5.10-MANJARO
5.10.2-2-MANJARO    extramodules-4.19-MANJARO  extramodules-5.4-MANJARO
Avec tout ça il redémarre normalement...! :siffle Je ne vais pas me plaindre... encore merci!
Dernière modification par Grain de sableil y a 4 jours, modifié au total 1 fois.

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#77Messageil y a 4 jours

Grain de sable a écrit : il y a 4 jours et pareil pour sudo ls /usr/bin/modules/ :ls: impossible d'accéder à '/usr/bin/modules/': Aucun fichier ou dossier de ce type
pour celle-là, il y a une coquille, c'est ls /usr/lib/modules

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#78Messageil y a 4 jours

fbe a écrit : il y a 4 jours pour celle-là, il y a une coquille, c'est ls /usr/lib/modules
Exact, du coup j'édite mon message!
Merci et en passant, sympa ton avatar :bien

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#79Messageil y a 4 jours

erreur de typo

sudo ls /etc/mkinitcpio.d/*.preset
tout est correct de côté là , il reste le point backlight a résoudre

[Stable] Mise à jour 30/12/2020 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

#80Messageil y a 4 jours

Ok... encore merci de te pencher sur mon cas :wink:

/etc/mkinitcpio.d/linux419.preset  /etc/mkinitcpio.d/linux510.preset  /etc/mkinitcpio.d/linux54.preset
et bonne soirée Stéphane!
Répondre