Actualités & Annonces de l'équipe de développement et des administrateurs du forum.
Répondre

[Stable] Mise à jour 02/09/2018 - Deepin, Pamac, Linux419, Firefox-Dev, Upower

#1Messageil y a 4 mois

Bonjour à toutes et à tous :bjr:

Une nouvelle mise à jour est (déjà) annoncée.

Bienvenue à une autre mise à jour stable. Alors, qu'est-ce qu'on a avec celle-ci ?
  • De nouveaux paquets Deepin ont été ajoutés
  • Nous avons publié pamac v7.0
  • Un nouveau snapshot de linux419 et firefox-developer a été ajouté.
  • Nous avons travaillé sur une régression de upower.
  • Suppression de la modification des limites fd-limites dans steam-manjaro
  • Les habituels reconstructions/mises à jour en amont.
Nous espérons qu'avec tous ces changements, Manjaro sera plus efficace pour vous tous.

Pour plus d'informations sur L1TF, veuillez regarder cette vidéo :
Traduit avec www.DeepL.com/Translator

N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.


-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman-mirrors -f0 && sudo pacman -Syyu && yaourt -Sua
-------------------------------------------------------------------------------------


État des miroirs actuellement :

Noyaux pris en charge :
  • linux316 3.16.57
  • linux318 3.18.120 [EOL] En fin de vie
  • linux44 4.4.153
  • linux49 4.9.124
  • linux414 4.14.67
  • linux417 4.17.19 [EOL] En fin de vie
  • linux418 4.18.5
  • linux419 4.19-rc1 (expérimental)
  • linux414-rt 4.14.63_rt40
  • linux416-rt 4.16.18_rt11
Les changements en détail :
  • community x86_64: 177 nouveaux et 168 paquets retirés
  • core x86_64: 3 nouveaux et 3 paquets retirés
  • extra x86_64: 30 nouveaux et 35 paquets retirés
  • multilib x86_64: 3 nouveaux et 3 paquets retirés
6 nouveaux paquets (retour de amarok):

amarok:  The powerful music player for KDE - GIT version
deepin-turbo:  A daemon that helps to launch applications faster
iio-sensor-proxy:  IIO accelerometer sensor to input device proxy
lollypop-portal:  Flatpak portal for lollypop
pspp:  Statistical analysis program. Free replacement for SPSS.
shotcut:  Cross-platform Qt based Video Editor

-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/events/thinkpad-radiosw est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S --force tlp
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés
Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

[Stable] Mise à jour 02/09/2018 - Deepin, Pamac, Linux419, Firefox-Dev, Upower

#2Messageil y a 4 mois

Bonjour,
J'ai zappé la mise à jour du 28/08.
Mon noyau actuel est un noyau RT (j'ai installé mon petit home studio récemment, et choisis ce noyau en conséquence)
(4.16.18-rt12)
Mais la mise à jour plante dès la recherche de conflits de dépendance :

résolution des dépendances…
recherche des conflits entre paquets…
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: l’installation de nvidia-390xx-utils (390.87-1) casse la dépendance « nvidia-390xx-utils=390.77 » requise par linux416-nvidia-390xx
J'ai regardé dans la liste des noyaux dispos. Le seul noyau RT auquel j'ai accès pour le moment est le 4.14. Si j'essaie d'installer le 4.14, j'ai le même message lié à l'impossibilité de mettre à jour le driver nvidia.
Que me conseilleriez-vous ?
Attendre qu'un noyau RT plus récent sorte ?
Essayer de faire marcher mes applis audio (qui sont toutes commandées par cadence, jack etc..) avec un noyau classique récent (ce qui ne devrait pas poser trop de problème en fait) ?
Autre ??

[Stable] Mise à jour 02/09/2018 - Deepin, Pamac, Linux419, Firefox-Dev, Upower

#3Messageil y a 4 mois

Bonjour.
Je suppose que tu as un noyau classique en secours. Le module du pilote graphique est différent en Real Time et la mixité semble difficile.
J'avais eu un problème identique il y a pas mal de temps et j'en ai conclu que les RT cohabitent mal avec les noyaux courants.
L' idéal reste une installation dédiée en RT. Cela-dit, les RT ne sont réellement utiles que pour la diffusion en live mais ne sont guère indispensables pour de la post-prod comme avec Ardour par exemple.

[Stable] Mise à jour 02/09/2018 - Deepin, Pamac, Linux419, Firefox-Dev, Upower

#4Messageil y a 4 mois

lemust83 a écrit :
il y a 4 mois
Bonjour.
Je suppose que tu as un noyau classique en secours. Le module du pilote graphique est différent en Real Time et la mixité semble difficile.
J'avais eu un problème identique il y a pas mal de temps et j'en ai conclu que les RT cohabitent mal avec les noyaux courants.
L' idéal reste une installation dédiée en RT. Cela-dit, les RT ne sont réellement utiles que pour la diffusion en live mais ne sont guère indispensables pour de la post-prod comme avec Ardour par exemple.
Merci. Oui, le noyau RT n'a pas vraiment d'utilité dans mon cas.
Par contre, mes histoires de noyaux n'avancent guère. J'ai booté sur le 4.14, mais quand je veux tenter la mise à jour, le même message concernant nvidia-390xx-utils apparaît.
J'ai réussi à installer le 4.18, plus récent, mais les modules nvidia ne veulent pas s'installer (donc "kernel module failed" etc..).
Ce genre de problème me rappelle quelque chose, mais je dois avoir oublié comment le résoudre.

[Stable] Mise à jour 02/09/2018 - Deepin, Pamac, Linux419, Firefox-Dev, Upower

#5Messageil y a 4 mois

Essaye de virer tous les autres noyaux que le 4.18 , puis essaye sudo mhwd -a -f pci nonfree 0300 ensuite remet 4.14 en passant par sudo mhwd-kernel -i linux414.

[Stable] Mise à jour 02/09/2018 - Deepin, Pamac, Linux419, Firefox-Dev, Upower

#6Messageil y a 4 mois

lemust83 a écrit :
il y a 4 mois
Essaye de virer tous les autres noyaux que le 4.18 , puis essaye sudo mhwd -a -f pci nonfree 0300 ensuite remet 4.14 en passant par sudo mhwd-kernel -i linux414.
Merci beaucoup de l'aide. J'ai suivi grosso modo tes conseils (la première commande passait ainsi : sudo mhwd -f -a pci nonfree 0300, -f devant -a donc). Avant de pouvoir réinstaller un autre noyau, le prompt me demandait de mettre à jour le système, ce que j'ai fait. Ensuite, reboot en échec sur 4.18 aussi bien que sur 4.14. Failed to start load kernel modules. Par contre pas de problème pour ouvrir une console (ALT F2), dans laquelle j'ai repassé la commande sudo mhwd -f -a pci nonfree 0300, et là c'était bon (pour le 4.18). je vais vérifier si c'est bon aussi pour le 4.14. La version installée de nvidia est désormais bien 390.87-1. Merci en tous cas !

Répondre