Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#1Messageil y a 8 mois

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée et une autre le 21
Bonjour la communauté, Bienvenue dans une autre mise à jour stable .
Comme cette mise à jour est énorme, nous vous recommandons de l’installer à partir d’un terminal : pamac upgrade ou sudo pacman -Syu

Qu’a-t-on avec celle-ci?
Nous nous sommes principalement concentrés sur l'environnement de bureau Kde. Dans Plasma, un nouveau widget Configuration d’affichage pour la gestion d’écran. Le widget Volume audio possède désormais une fonctionnalité de test de haut-parleur intégrée. Le widget réseau fonctionne désormais à nouveau pour les tunnels SSH VPN. Pour le gestionnaire de fenêtres, le copier-coller entre les applications GTK et non-GTK sur Wayland a été corrigé.
De plus, de nombreux bogues ont été corrigés: les arrière-plans flous derrière les menus contextuels du bureau ne sont plus visuellement corrompus et il n'est plus possible de glisser-déposer accidentellement des boutons du gestionnaire de tâches dans les fenêtres d'application.

Ensuite, nous avons travaillé sur notre expérience de démarrage avec grub-quiet . Le menu devrait maintenant rester caché comme il se doit. S'il vous plaît signalez les problèmes que vous pouvez encore avoir avec. Calamares a acquis la fonctionnalité de définir comment nous pouvons utiliser le swap.

Autres changements dans un bref aperçu:
Nous avons mis à jour la plupart de nos noyaux ( linux419 utilise maintenant BFQ v9 comme planificateur par défaut )
Nous avons ajouté KDE Plasma 5.14.1 , Apps 18.08.2 et Framework 5.51.0
Xorg-Server est maintenant à 1.20.2
Mesa est maintenant à 18.2.3
Virtualbox a une nouvelle version
Les pilotes Nvidia font maintenant partie de la nouvelle série 410 LTS
glibc et mkinitcpio ont eu quelques corrections.
Deepin et Gnome ont mis à jour des paquets
Nous avons corrigé grub-boot-success pour grub-quiet
Nous avons travaillé sur nos thèmes
Nous avons mis à jour Firefox-Dev en version 64
PHP est maintenant à 7.2.11 et JDK8 à 8.u192
Mise à jour de Pamac vers v7.2-rc
Les corrections habituelles en amont incl. haskell
kde, kernels, mesa, xorg, virtualbox, libssh, manjaro-documentation-fr

N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.


-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman-mirrors -f0 && sudo pacman -Syyu && yaourt -Sua
-------------------------------------------------------------------------------------

Noyaux pris en charge :
  • linux316 3.16.59
  • linux318 3.18.124 [EOL] En fin de vie
  • linux44 4.4.161
  • linux49 4.9.134
  • linux414 4.14.77
  • linux417 4.17.19 [EOL] En fin de vie
  • linux418 4.18.15
  • linux419 4.19-rc8 (expérimental)
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt12
  • linux418-rt 4.18.12_rt7
Les changements en détail :
  • stable community x86_64: 1226 nouveaux et 1201 paquets retirés
  • stable core x86_64: 28 nouveaux et 27 paquets retirés
  • stable extra x86_64: 651 nouveaux et 707 paquets retirés
  • stable multilib x86_64: 22 nouveaux et 15 paquets retirés
Voir la liste des paquets pour les détails
- 2 paquets supprimés:

profont vim-systemd 
-31 nouveaux paquets :

manjaro-awesome-settings-18.0:  Manjaro Linux budgie settings
advancecomp:  Recompression utilities for .zip .png .mng and .gz files using the 7-zip algorithm
ghi:  GitHub Issues on the command line
haskell-githash:  Some handy Template Haskell splices for including the current git hash and branch in the code of your project
haskell-heaps:  Asymptotically optimal Brodal/Okasaki heaps
haskell-libyaml:  Low-level, streaming YAML interface.
hq:  HTML processor inspired by jq
jslinux:  RISC-V system emulator
jsmol:  a JavaScript 3D viewer for chemical structures
lib32-libidn11:  Implementation of the Stringprep, Punycode and IDNA specifications
lib32-libva1-intel-driver:  VA-API implementation for Intel G45 and HD Graphics family
libidn11:  Implementation of the Stringprep, Punycode and IDNA specifications
libqb:  Library for providing high performance, reusable features for client-server architecture
libva1-intel-driver:  VA-API implementation for Intel G45 and HD Graphics family
modest:  Fast HTML renderer implemented as a pure C99 library with no outside dependencies
pegtl:  Parsing Expression Grammar Template Library
perl-cgi-formbuilder:  Easily generate and process stateful forms
python2-filelock:  A platform independent file lock
python2-pycosat:  Python 2 bindings to picosat (a SAT solver)
python2-uhashring:  Full featured consistent hashing python library compatible with ketama
python-biscuits:  Fast and tasty cookies handling
python-filelock:  A platform independent file lock
python-grpcio:  HTTP/2-based RPC framework
python-pycosat:  Python 3 bindings to picosat (a SAT solver)
python-tensorflow-serving-api:  Flexible, high-performance serving system for machine learning models
python-uhashring:  Full featured consistent hashing python library compatible with ketama
rust-bindgen:  Automatically generates Rust FFI bindings to C (and some C++) libraries
teamspeak3-server:  TeamSpeak software for quality voice communication via Internet (server)
usbguard:  Software framework for implementing USB device authorization policies
usbguard-qt:  Software framework for implementing USB device authorization policies - Qt frontend
-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/events/thinkpad-radiosw est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S --overwrite '/etc/acpi/events/thinkpad-radiosw'
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés
Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#2Messageil y a 8 mois

:bjr: et :merci:
Tout est ok, comme d'hab :bien
Image
Merci à toute l'équipe Manjaro :clap

Edit : modifié hébergeur image
Dernière modification par kilimand22 le 21 Oct 2018, 01:47, modifié 3 fois.

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#3Messageil y a 8 mois

Mise à jour effectuée sur mon fixe et mon portable et RAS après redémarrage :bien

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#4Messageil y a 8 mois

mise a jour effectué RAS

nb : je reste sur Grub , la proposition Grub-quiet ne devrait concerner que les nouvelles versions
pour la suite

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#5Messageil y a 8 mois

Bonjour,
82 paquets sur xfce et tout va bien pour l'ordi de ma fille (2ème de la signature).
Merci.

NB : @Stephane, ça veut dire quoi je reste sur "grub" ? ça m'intéresse parce que je suis aussi sur "manjaro-grub" dans mon menu bios et grub, sur les deux machines...
Ou alors ça n'a rien à avoir ?

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#6Messageil y a 8 mois

hackoeur a écrit :
il y a 8 mois
NB : @Stephane, ça veut dire quoi je reste sur "grub" ? ça m'intéresse parce que je suis aussi sur "manjaro-grub" dans mon menu bios et grub, sur les deux machines...
Ou alors ça n'a rien à avoir ?
Bonjour :bjr:

Voir ici l'annonce de lemust83 : 115882

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#7Messageil y a 8 mois

Plus de 220 paquets et RAS au démarrage. :bien

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#8Messageil y a 8 mois

bonjour.

mise à jour de plus de 900mo de faite sur mon portable, tout semble aller bien, vbox aucun problème et nouvelle version donc zou c'est bon ça :)

stéphane2

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#9Messageil y a 8 mois

80 paquets pour ma machine et ràs, tout va bien.
Merci à vous.

Bonjour Erwan et merci
Erwan a écrit :
il y a 8 mois
Voir ici l'annonce de lemust83 : 115882
En effet, c'est pas ça... :desole:

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#10Messageil y a 8 mois

hop mise à jour de ma tour, 1.3go pour 192 paquets, tout roule :)

merci à toute l'équipe.

stéphane

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#11Messageil y a 8 mois

Bonsoir tout le monde
275 paquets pour Kde et toujours "poweroff" pour un redémarrage sans problème !
Gros boulot apparemment de toutes les équipes.
:clap et :merci:
Michel

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#12Messageil y a 8 mois

Mise à jour via Pamac
Vautrage comme la dernière fois :

[...]
Début de la mise à jour complète du système...
La validation de la transaction a échoué:
transaction non préparée
On dirait qu'il tente de mettre à jour une seconde fois :saispas:

Par contre, xfce4-displays-settings , il ne veut rien savoir : toujours en erreur de segmentation, même après avoir réinstallé et supprimé le fichier ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml
Tiens d'ailleurs, quand je scrute ce fichier, il me dit qu'un affichage est désactivé ... :?

<?xml version="1.0" encoding="UTF-8"?>

<channel name="displays" version="1.0">
  <property name="Default" type="empty">
    <property name="LVDS1" type="string" value="Portable">
      <property name="Active" type="bool" value="false"/>
      <property name="EDID" type="string" value="f889f344a6826726d7376784b8a06a63c912564c"/>
    </property>
  </property>
</channel>
Dernière modification par monsieur Q le 21 Oct 2018, 08:17, modifié 1 fois.

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#13Messageil y a 8 mois

J'ai eu une notification bizarre à l'allumage ce matin:
Image
Mais sans conséquence puisque tout fonctionne... :confus:

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#14Messageil y a 8 mois

Bonjour,

Mise à jour de 215 paquets pour KDE et redémarrage OK, RAS pour le moment.
Merci à toute l'équipe :clap

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#15Messageil y a 8 mois

Salut,

Je viens de faire une petite mise à jour complémentaire de 16 paquets, dont les noyaux, mhwd-db et gtk3.

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#16Messageil y a 8 mois

:bjr:
Bon, c'est un peu la misère chez moi. Mon portable a freezé vers la fin de la mise à jour, et bien sûr, pas de sauvegarde système ou d'image disque. Bref :

[toto@toto-pc ~]$ sudo ldconfig
ldconfig: Fichier /usr/lib/libhpdiscovery.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libhpipp.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libKF5KDcraw.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgwenviewlib.so.4.97.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libhpdiscovery.so.0.0.1 est vide, n'a pas été vérifié.
Et il y en a un paquet comme ça.
Bon, j'ai bien essayé de reconstituer les librairies partagées, mais je crois que le référentiel est cassé, ce qui fait que je suis un peu coincé...

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#17Messageil y a 8 mois

Vois si tu peux installer pacui, son option "Fix Pacman Errors" peut être efficace parfois.

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#18Messageil y a 8 mois

Merci Smurf, je ne connaissais pas pacui.
Malheureusement, ça n'a pas marché. En fait, quand j'essaye d'identifier un paquet à coups de pactree, la commande ne trouve rien. Et il m'est impossible d'installer ou de supprimer la plupart des paquets que j'estime touchés, même avec --overwrite.
Bon, pas grave, les données sont sauves... :wink: Je sens que je vais passer direct à la 18 rc2...

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#19Messageil y a 8 mois

Un complément à cette mise à jour a été aussi annoncé.
Bienvenue à une autre mise à jour stable.

Alors, qu'est-ce qu'on a avec celle-ci ?
  • Nous avons mis à jour certains de nos thèmes
  • La plupart de nos noyaux ont été mis à jour
  • Quelques corrections à mhwd en ce qui concerne la Virtualbox
  • Pamac est maintenant à v7.2.0-rc1
  • Le scintillement au survol de la souris dans gtk3 est maintenant corrigé
Nous espérons qu'avec tous ces changements, Manjaro sera plus efficace pour vous tous.

Traduit avec www.DeepL.com/Translator
Voir le premier message de ce fil.
116197

[Stable] Mise à jour 19-21/10/2018 - kde, kernels, mesa

#20Messageil y a 8 mois

Oui, merci, en effet, 14 paquets et ràs sur les 2 bécanes xfce.
Bonne journée. :bjr:

Répondre