Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#21Messageil y a 3 mois

Oui, j'ai vu passer le message à l'inter.
Cala dit, j'ai aussi testé polo et je n'ai pas eu de conflit. Il faut dire que pacman -Ql polo ne donne pas de ligne usr/share/dbus....

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#22Messageil y a 3 mois

il est simple à vérifier si il va avoir conflit - sous ma arch, rien:

pacman -Fs org.freedesktop.FileManager1.service
extra/nautilus 3.30.5-1
    usr/share/dbus-1/services/org.freedesktop.FileManager1.service
mais avec manjaro, qui est en avance, nous avons aussi ce fichier dans thunar-gtk3

---

Avec dolphin il s’appelle org.kde.dolphin.FileManager1.service il serait donc plus "normal" de le renommer dans le PKGBUILD de thunar :saispas:
EDIT: Fait, une nouvelle version avec nouveau non de fichier

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#23Messageil y a 3 mois

Même schéma que lemus83 avec polo en binôme et aucune erreur ni attente en fin d'update. La raison ? Peut-être ce bon vieux extra/thunar 1.8.2-2 (xfce4) [installed] installé sur ma machine. :sourire: Pour préciser, il s'agit de systemd-240.275-1 sur la branche "unstable" de Manjaro. Vive gtk3 ! :siffle

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#24Messageil y a 3 mois

Perso j'ai vu plein de message d'erreur mais au moment de reboot tout va bien. J'espère juste que quand elle va passer en stable il y aura moins d'erreur lors de l'installation.

De mon coté pas d'erreur avec polo et dolphin

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#25Messageil y a 3 mois

[Stable] Mise à jour 19/01/2019 - Security update to Systemd v239 series

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée Comme elle concerne surtout une mise à jour de sécurité de systemd, nous la publions à la suite de celle du 17/01/19

Bienvenue à notre troisième mise à jour stable de 2019. Alors, qu'est-ce qu'on a avec celle-ci ?

Nous avons abordé les questions de sécurité suivantes dans la série systemd v239 :
  • CVE-2018-15686 : Une vulnérabilité dans unit_deserialize de systemd permet à un attaquant de fournir un état arbitraire à travers la ré-exécution de systemd via NotifyAccess.
  • CVE-2018-15687 : Une condition de course dans chown_one() de systemd permet à un attaquant d'amener systemd à définir des permissions arbitraires sur des fichiers arbitraires.
  • CVE-2018-6954_2 : fichiers systemd-tmp dans systemd à travers 239 liens symboliques mishandles présents dans des composants de chemins non terminaux.
  • CVE-2018-16864 : Une allocation de mémoire sans limites, qui pourrait entraîner un conflit entre la pile et une autre région de mémoire, a été découverte dans systemd-journald lorsqu'un programme avec de longs arguments en ligne de commande appelle syslog.
  • CVE-2018-16865 : Une allocation de mémoire sans limites, qui pourrait entraîner un conflit entre la pile et une autre région de mémoire, a été découverte dans systemd-journald lorsque de nombreuses entrées sont envoyées à la socket journal.
  • CVE-2018-16866 : Une lecture hors limites a été découverte dans systemd-journald dans la façon dont il analyse les messages de log qui se terminent par deux points ':'.
Ceci est également traité avec la v239.6-4 dans notre branche testing et avec la v240.275-1 dans notre branche unstable.

Nous espérons qu'avec tous ces changements, Manjaro sera plus efficace pour vous tous.

Traduit avec www.DeepL.com/Translator

Dans l'annonce inter stable d'aujourd'hui:
pilm a écrit :systemd fourni avec les packages de la version 239.3XX-X est vulnérable, à au moins plusieurs défauts présentés précédemment dans cette annonce. Pour être pleinement protégé contre les vulnérabilités détaillées dans cette annonce, vous devez rétrograder les packages systemd vers la version 239.6-2.2.

Pour ce faire, utilisez l'une des méthodes présentées ci-dessous (ou l'équivalent):

sudo pacman -Syyuu

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#26Messageil y a 3 mois

tests et codages de saguin systemd
cela ne m'etonne pas vue le nombre d'anomalies sur systemd et leurs versions

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#27Messageil y a 3 mois

Pour la maj de systemd ont doit quand même la faire si ont a l'autre version de la dernière fois avec les avertissement lors de chaque installe ?

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#28Messageil y a 3 mois

quel avertissement as tu ?

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#29Messageil y a 3 mois

Comme toi aussi tu a dit que tu gardais cette version la

Avertissement: lib32-systemd : la version locale (240.275-1) est plus récente que multilib (239.6-4)
Avertissement: libsystemd : la version locale (240.275-1) est plus récente que core (239.6-4)
Avertissement: systemd : la version locale (240.275-1) est plus récente que core (239.6-4)
Avertissement: systemd-sysvcompat : la version locale (240.275-1) est plus récente que core (239.6-4)

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#30Messageil y a 3 mois

@Cyberdr3am tu n'es pas en stable toi ?
En stable, pour moi c'est 239.303-1 -> 239.6-2.2 ?

:confus: c'est confus aussi pour moi - pour la prochaine mise à jour stable dans une semaine, (pour l'instant) il faudra absolument faire la rétrogradation avec un -Suuy
aujourd'hui :saispas:


Pour ceux qui sont en testing, il faut absolument récupérer la version du dépot 239.6-4 avec un uu

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#31Messageil y a 3 mois

Sisi je suis en stable mais je ne sais pas si tu te souviens de la maj qu'il y a eu a un moment avec ces alertes et stephane qui avait dit qu'il allais rester la dessus ( La j'écris depuis ma vm pour faire des tests mais j'ai la même chose en dur stable ( peut être pas exactement la même version mais le même message )

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#32Messageil y a 3 mois

:confus: pourtant tu copies une alerte avec des versions qui ne sont pas encore dans stable
pour vérifier:

pacman-conf | grep Server -m 1
je suis en stable et j'ai le message 239.303-1 -> 239.6-2.2, en effet je suis en avance avec la version 303 sur les dépôts actuels stable depuis quelques mises à jours

EDIT: ok dans tes précédents messages tu étais bien en stable contrairement à ton message il y a 2 posts...
Il faut absolument rétrograder en testing comme en stable

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#33Messageil y a 3 mois

Je parle de cette maj

viewtopic.php?p=117864#p117864

ou

viewtopic.php?p=117983#p117983

Edit :

Voilà le message sur mon installe en dur

Avertissement: lib32-systemd : la version locale (239.303-1) est plus récente que multilib (239.6-2)
Avertissement: libsystemd : la version locale (239.303-1) est plus récente que core (239.6-2)
Avertissement: systemd : la version locale (239.303-1) est plus récente que core (239.6-2)
Avertissement: systemd-sysvcompat : la version locale (239.303-1) est plus récente que core (239.6-2)
Du coup je fait quoi avec cette maj de systemd ? je doit la faire ? et si oui comment

Edit 2 : Oui je suis en stable pour mon installe en dur après sur vb je suis en testing pour voir ce que vont donner les majs

edit 3 :

L'équipe de manjaro dit qu'il faut downgrade

    Run sudo pacman -Syyuu in a terminal.
    Run pamac update --enable-downgrade in a terminal.
    Open Pamac GUI, go in Preferences, check “Enable downgrade” and close the Preferences window. Once this is done, force Pamac to refresh package databases. Once the package databases will be refreshed, Pamac will allow you to downgrade packages; click on Commit to confirm the downgrade. Once it is done, you may disable “Enable downgrade” if you do not want to keep this option turned on.
Modifié en dernier par Cyberdr3am le 20 Jan 2019, 00:25, modifié 1 fois.

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#34Messageil y a 3 mois

Dans l'annonce inter stable d'aujourd'hui:
pilm a écrit :systemd fourni avec les packages de la version 239.3XX-X est vulnérable, à au moins plusieurs défauts présentés précédemment dans cette annonce. Pour être pleinement protégé contre les vulnérabilités détaillées dans cette annonce, vous devez rétrograder les packages systemd vers la version 239.6-2.2.

Pour ce faire, utilisez l'une des méthodes présentées ci-dessous (ou l'équivalent):

sudo pacman -Syyuu
---
Attention à ton test testing : la maj stable est prévue dans une semaine, donc tout ce qui est fait/conseillé en testing sera sans doute obsolète dans une semaine. cette branche est justement là pour prendre le temps de corriger le tir en cas de problème.

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#35Messageil y a 3 mois

Haha je viens d'éditer mon poste au même moment que tu a écris le tiens.

Si je fait un

sudo pacman -Syyuu
et que j'ai des majs en plus du downgrade a faire il va me les faire ? ou alors je fait les majs en premier puis le downgrade. ( je parle de l'installe en dur la )

Edit : Lors du downgrade, il ne va pas me rétrograder un autre paquet que systemd par hasard ? ( En -Syyuu )

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#36Messageil y a 3 mois

bon, je viens de rééditer les annonces #1 et #25 de ce sujet , c'est de ma faute, je n'avais pas suivi la mise à jour d'aujourd'hui.

Avec uu, nous faisons uniquement les mises à jours mais nos versions seront toutes exactement les mêmes que les dépôts officiels - il n'y a pas véritablement 2 opérations avec uu

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#37Messageil y a 3 mois

Ok merci beaucoup je comprend mieux. J'étais un peut perdu, je savais pas trop quoi faire lol.

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#38Messageil y a 3 mois

Bon dimanche à vous,

La màj du 17, 71 paquets sous Xfce, nickel sur les deux pc.
La mmàj du 17, 5 paquets nickel aussi.

Merci et allez, voguez, volez loin les manjariennes et manjariens. :bjr:

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#39Messageil y a 3 mois

Bonjour à tous et toutes.

hop une nouvelle mise à jour de systemD ce matin, pas de blème apparent
après reboot.
très bonne journée à tous !

stéphane

[Stable] Mise à jour 17 et 19/01/2019 - Systemd, Kernels, KDE Apps et Plasma, Deepin, Firefox, Calamares, XFCE

#40Messageil y a 3 mois

Bonjour tout le monde,

De mon côté , pas de problèmes remarqués après ce downgrade si ce n'est l'avertissement les permissions pour le répertoire /usr/share/polkit-1/rules.d/ sont différentes, système de fichiers : 755, paquet : 750.
Du coup, j'ai juste dû executé sudo chmod 750 /usr/share/polkit-1/rules.d/
.

Passez une bonne journée :sourire:

Répondre