Actualités & Annonces de l'équipe de développement et des administrateurs du forum.
Répondre

mettre à jour le wiki ???

#1Messageil y a 1 mois

par exemple


Pacman et yaourt
Utiliser le terminal pour mettre à jour, installer et supprimer des logiciels.

TOUT FAUX

mais dire que il ne faut plus utiliser yaourt
que pacman fait très bien le boulot en activant AUR
vous sélectionnez le soft dont vous avez besoin qui ne ce trouve que sur AUR et vous pouvez refermer AUR
afin de rester cohérent avec Manjaro (bien-sur je ne vous dit pas d'installer libre-office , mais un soft par exemple de dev des trucs qui bouge peu ..... plutôt que de vous servir de yaourt et qui vas semer la pagaille ( pour l'avoir fait garanti sur mesure ) avec la nouvelle version de Pacman pas de dangers surtout avec la version 9.0.2-2

mettre à jour le wiki ???

#2Messageil y a 1 mois

bonjour

le wiki fr n'est plus du tout actualisé depuis au moins 2016... voir même avant
cela n'est pas pareil sur la partie en , par contre ce que je déteste dans ces wiki , c'est de trouver la date de derniere mise à jour , c'est assez utile

on se referre la plupart du temps sur le wiki archlinux qui est bien mis à jour

ps : cela demande à avoir les droits sur le wiki et cela ne peut pas être proposé à l'extérieur de l'équipe manjaro team ,
idem sur le forum , suivant nos interventions , nous avons un grade qui permet ou pas de pouvoir intervenir sur le wiki manjaro en

mettre à jour le wiki ???

#3Messageil y a 1 mois

Bonjour,

ps: merci de ne pas confondre pamac/pacman :sourire:

Je touche au wiki une fois tous les 6 mois, mais juste pour faire de minimes corrections. J'avais rajouté sur le wiki que justement yaourt n'est plus recommandé et qu'il existe maintenant yay et d'autres.
Mais tu désires peut être que je change le titre (pacman et yay) ? ... perso je suis tout à fait pour que "yaourt" disparaisse mais quel soft mettre ? yay est celui qui est donné à 90% sur le forum inter, pamac cli est beaucoup trop limité pour être le principal.

j'avais aussi ajouté une section pamac
Mais il n'y a pas grand chose à dire, si la section existe c'est justement que pamac fait le boulot comme tu dis
JPlaroche a écrit :
il y a 1 mois
Utiliser le terminal pour mettre à jour, installer et supprimer des logiciels.
TOUT FAUX
C'est ou cela, pas vu dans cette page wiki. Et hors contexte il n'y a surement rien de faux là dedans
plutôt que de vous servir de yaourt et qui vas semer la pagaille ( pour l'avoir fait garanti sur mesure ) avec la nouvelle version de Pacman pas de dangers surtout avec la version 9.0.2-2
On a aucune idée de si tu parles de gui ou cli ?
yaourt n'a jamais semé la pagaille : même ces nombreux détracteurs ne lui ont jamais reproché cela (uniquement un manque de sécurité)
Tu prends donc une mauvaise expérience personnelle pour en faire une généralité ?
Tu as l'air de dire que pamac est beaucoup plus sûr que yaourt (yay pour moi puisque yaourt n'existe plus); mais sur quoi repose cette affirmation ?
Tu es dev , regarde le code source !!!!!
- pamac n'a même pas de tests alors que yay, comme tout bon code en est pourvu
- pamac utilise dbus : une couche fragile ; combien de fois certains utilisateurs se sont retrouvés avec un deamon pamac bloqué et donc obligé de rebooter (en cours de maj !!!) pour reprendre la mise à jour (en espérant pouvoir rebooter)
Au moins , je te donnes 2 raisons pour lesquelles je pense qu'un soft comme yay,pikaur,... me parait au contraire bien plus sûr qu'un pamac cli (et encore plus qu'un pamac gui) - 2 raisons non contractuelles , on peut en discuter...

---
Si tu nous parlais de pamac-gtk (ici c'est une page cli), tu peux faire une page mais les nouveaux se débrouillent normalement très bien.

mettre à jour le wiki ???

#4Messageil y a 3 jours

désolé pour le retard...(pris par le développement)

je ne suis pas un novice sur Manjaro j'ai tenu plus de 5 ans sans avoir à refaire le system
aujourd'hui je veux rendre cela professionnel soit en Bureautique ou poste de développeur et mettre au garage ubuntu


voilà pourquoi j'ai utilisé yaourt pour installer un logiciel pour développer en C du web....
je l'avais sur XUBUNTU mais pas dans Manjaro ....
pas grave je me dis je prends yaourt et j'installe ..... cela ma dégringoler un tas de truc non demandés ...

en plus pour récupérer le tout grrrr OK je suis un peu tatillon sur le system pour qu'il reste propre ....

enfin de compte comme j'étais dans une installation professionnel en TEST et que je me devais de savoir réinstaller avec un script ..... ne pouvant pas récupérer j'ai réinstallé.... et comme j'avais toujours besoin de ce soft je m'y suis pris autrement et je redis en utilisant le manager de paquets de Manjaro il gère très biens AUR et de plus ce n'est pas un paquets dont j'ai besoin au dernier cris , il ne charge que le paquet et a partir des sources et le recompile .... MOI cela me vas parfaitement c'est d'ailleurs le seul paquet
donc j'ai ouvert AUR avec le manager de paquet (pamac-manager)
sudo pacman -S cgicc ..... ou avec pamac-manager GUI c'est pareil
et j'ai refermer AUR
pas de problèmes orphelin ni le reste .... et toute l'installation des softs sont en script (console).....
et j'ai fait le contrôle avec pamac-manager ou avec (pacman en console) tout est correct

tu peux essayer avec yaourt ... pour voir par toi même

je suis retourner sur le wiki fr je ne retrouve plus la page avec yaourt (tant mieux)
ps je ne cherche pas a avoir raison c'était pour signaler je me doute que la maintenance du site n'est pas aussi simple ....
si je n'ai pas été assez clair je m'en excuse ....

en relisant ce que tu dis peut-être suis je rester sur yaourt parce-que vieux reflex je vais voir yay histoire de ne pas rester ignorant ;) de même je vais avoir besoin d'une solution ADA et comme je reçois encore les mises à jour par mail de arch .... j'ai intérêt à bien consulter yay...

dans tous les cas merci d'avoir répondu.....

mettre à jour le wiki ???

#5Messageil y a 3 jours

la page wiki avec yaourt

yaourt, pamac, yay, ... font tous exactement la même chose : un git clone + makepkg PKGBUILD
Donc tout dépend du contenu du PKGBUILD et c'est makepkg qui l'interprète pas le helpeur aur !

Avec ton paquet, aucune dépendance, sauf une seule pour la compilation "doxygen" (donc on supprime après). yay après installation va proposer de supprimer doxygen, alors qu'il me semble (dans mes souvenirs) que yaourt ne le propose pas ... mais un pacman -Rsn doxygen n'est pas trop compliqué ou, on supprime les orphelins ce qui revient au même

yay, triezen, pikaur rien de compliqué, c'est pratiquement les mêmes options que yaourt pour faire les mêmes choses. Seul pamac cli est bien différent

mettre à jour le wiki ???

#6Messageil y a 2 jours

merci pour la réponse et désolé pour avoir laissé cela en suspend ....

je suis en ce moment sur des modules permettant de traiter des mantisses de 38 chiffres significatif , afin de traiter les dérives des traitement de masse .... et d'autre module de ce genre en langage NIM-lang , je fait mes dépots sur github AS400JPLPC pour ceux que cela intéresse .... il y a du C++ et NIM
Nim est un langage prometteur enfin ce n'est que mon avis ....

je travail désormais sur Manjaro , car les lib GTK et C/C++ postgresql .... non pas de retard dut au mode de fonctionnement de cette distribution .... et quant on veux rester sur la brèche ou sur le haut de la vague il faut des distributions comme Manjaro ....

mettre à jour le wiki ???

#7Messageil y a 2 jours

Personnellement, ce qui m'interpelle, c'est pamac-gui.

Je ne parviens pas à faire une mise à jour via ce procédé. À chaque fois, j'ai une impossibilité de mise à jour ou d'installation à la fin.

Par contre, si j'exécute la même commande par pacman pour les dépôts Manjaro ou yay pour les dépôts AUR, je n'ai presque pas de problèmes. Dans 99 % des cas, tout va bien.

Cherchez l'erreur.

Je ne me sers plus de pamac-gui que pour rechercher la dénomination exacte du paquet que je veux installer, puis j'emploie pamac ou yay suivant le dépôt du paquet.

Pour la désinstallation, je ne sais si je fais bien, mais j'emploie toujours la même commande sudo pamac -Rsn nom_du_paquet.

mettre à jour le wiki ???

#8Messageil y a 2 jours

Bonjour.
Il y a un souci de destination du dossier de construction . Il faut regarder dans /etc/pamac.conf si:

## AUR build directory:
BuildDirectory = /var/tmp

mettre à jour le wiki ???

#9Messageil y a 2 jours

obelix1502 a écrit :
il y a 2 jours
Personnellement, ce qui m'interpelle, c'est pamac-gui.

Je ne parviens pas à faire une mise à jour via ce procédé. À chaque fois, j'ai une impossibilité de mise à jour ou d'installation à la fin.

Par contre, si j'exécute la même commande par pacman pour les dépôts Manjaro ou yay pour les dépôts AUR, je n'ai presque pas de problèmes. Dans 99 % des cas, tout va bien.

Cherchez l'erreur.

Je ne me sers plus de pamac-gui que pour rechercher la dénomination exacte du paquet que je veux installer, puis j'emploie pamac ou yay suivant le dépôt du paquet.

Pour la désinstallation, je ne sais si je fais bien, mais j'emploie toujours la même commande sudo pamac -Rsn nom_du_paquet.

perso: sudo pacman -Rsn le_paquet
je n'ai pas eu de problème jusqu'à ce jour

Répondre