Trouvez ici les démarches courantes à faire en cas d'écran noir.
Répondre

Panique générale [plus de login]

#1Messageil y a 9 mois

Pas d'écran noir... mais panique générale tout de même!
Plus de mot de passe reconnu, que ce soit sous sddm ou en console.
Et je ne sais que faire, à part réinstaller bêtement

S'il y a un tuto quelque part, je suis preneur et remercieur!

Panique générale [plus de login]

#2Messageil y a 9 mois

Bonjour.
La première chose a voir est l'état actif ou non de ton pavé numérique si ton MP contient des chiffres.
Sinon, il y a des solutions sans réinstallation notamment en bootant en console . Je te laisse voir de ton côté et on t'aidera plus tard si tu n'y arrives pas.
75745

Panique générale [plus de login]

#3Messageil y a 9 mois

bonjour,

Tester le clavier est la première chose à faire (entrer le mot de passe sans valider dans la zone login permet de voir si tu es bien en fr)
il faut aussi tester le mot de passe root (en console uniquement)


Si le pass root ne passe plus aussi : ne pas réinstaller mais faire un manjaro-chroot depuis une iso : tu seras en root donc avec la possibilité de changer tous les mots de passe de ta manjaro

Panique générale [plus de login]

#4Messageil y a 9 mois

Mon clavier marche, la preuve! je suis sur une iso.
Booter en console? certes, mais pour faire quoi?
"faire un manjaro-chroot depuis une iso": certes, mais compte tenu de mes connaissances en la matière, me tenir par la main ne serait pas un luxe!

Panique générale [plus de login]

#5Messageil y a 9 mois

Pour changer un mot de passe, c'est passwd toto toto étant ton username. Pour changer root, ce sera passwd root. En chroot, tu es connecté en root, donc pas besoin de de sudo .
Prends bien soin de noter consciencieusement tes MP . Idéalement, il faudrait en choisir un qui soit compatible QWERTY/AZERTY, à moins d'être à l'aise avec les deux variantes.
Par contre , si tu as crypté tes disques à l'installation, c'est mort, mais vu que tu t'es connecté déjà en chroot, ça devrait passer.

Panique générale [plus de login]

#6Messageil y a 9 mois

alex666 a écrit :
il y a 9 mois
Mon clavier marche, la preuve! je suis sur une iso.
en fait non :wink: si ta manjaro est (mal) configurée, comme un clavier en querty ou un mauvais clavier physique de configuré

Panique générale [plus de login]

#7Messageil y a 9 mois

tenté chroot.
Avec sddm, j'ai pu voir que mon password affiché en clair était le bon, et ne marchait pas...
ni en user, ni en root, ni en console, ni avec sddm.

Panique générale [plus de login]

#8Messageil y a 9 mois

Essaye de renommer ~/.Xauthority en ~/.Xauthority.old et reconnecte toi.
Sinon, passe en tty, connecte toi et lance startx.

Panique générale [plus de login]

#9Messageil y a 9 mois

passe en tty, connecte toi et lance startx.
ci-dessus: impossible de me connecter en tty!

Panique générale [plus de login]

#10Messageil y a 9 mois

si j'ai bien compris, tu as bien modifié temporairement ton mot de passe avec un chroot depuis ton iso du type "toto".
Mais tu as toujours le même problème en tty ?

ps: avec sddm, cela ne vient pas obligatoirement d'un problème de mot de passe, cela peut être un plantage de sddm ou de ton bureau qui retourne à ton gestionnaire de connexion

Tu peux essayer d'avoir plus d'infos en regardant les logs depuis ton iso, après le manjaro-chroot -a

journalctl -b-1 -p3

Panique générale [plus de login]

#11Messageil y a 9 mois

Toujours le mme pb en tty.
Et sddm me précise "échec de la connexion" sans planter le - du monde!

Panique générale [plus de login]

#12Messageil y a 9 mois

Peux-tu te connecter en root en TTY. Si oui, attention de ne pas lancer d'interface graphique, c'est juste pour voir si une session est possible sans chroot.

Panique générale [plus de login]

#13Messageil y a 9 mois

Ben non, ni en user, ni root, ni biroot ni en tty, ni en graphique, ni avant chroot, ni après.

Panique générale [plus de login]

#14Messageil y a 9 mois

papajoke a écrit :
il y a 9 mois
si j'ai bien compris, tu as bien modifié temporairement ton mot de passe avec un chroot depuis ton iso du type "toto".
Mais tu as toujours le même problème en tty ?

ps: avec sddm, cela ne vient pas obligatoirement d'un problème de mot de passe, cela peut être un plantage de sddm ou de ton bureau qui retourne à ton gestionnaire de connexion

Tu peux essayer d'avoir plus d'infos en regardant les logs depuis ton iso, après le manjaro-chroot -a

journalctl -b-1 -p3

-- Logs begin at Sun 2019-02-10 17:07:38 CET, end at Thu 2019-02-28 21:09:43 CET. --
févr. 28 20:50:49 xyz kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
févr. 28 20:50:49 xyz kernel: kvm: disabled by bios
févr. 28 20:50:50 xyz NetworkManager[625]: <error> [1551383450.0419] session-monitor: failed to create systemd-logind monitor: -2
févr. 28 20:50:52 xyz systemd[1]: Failed to start MariaDB 10.3.12 database server.
févr. 28 20:51:21 xyz sddm-helper[1068]: pam_shells(sddm:auth): /etc/shells is either world writable or not a normal file


Panique générale [plus de login]

#15Messageil y a 9 mois

Alors, ton fichier /etc/shadow et/ou /etc/passwd sont endommagés. Il faut recommencer l'opération passwd root puis passwd toto en chroot ou en console avec un mp simple sans chiffre et sans Majuscule genre roro.
Si tu peux te connecter, tu pourras le modifier après.

Panique générale [plus de login]

#16Messageil y a 9 mois

et faire un ls -l /etc/shells dans ton chroot pour voir si le fichier à les bons droits "-rw-r--r--" "644" (lecture pour tous) et non vide je suppose que le problème vient de là ???? (chmod 644 /etc/shells pour corriger )

et si tu fais un cat tu devrais avoir (en gros)

# Pathnames of valid login shells.
# See shells(5) for details.

/bin/sh
/bin/bash

Panique générale [plus de login]

#17Messageil y a 9 mois

Fait.
Redémarrer, bricoler pour redémarrer en normal au lieu de clé usb, etc...
Merci en attendant pour votre patience!!!

Panique générale [plus de login]

#18Messageil y a 9 mois

Yeah! je dirais même plus: alleluia!
écrit depuis ma session normale!

Mercis (oui, au pluriel!) et bravos!
Bonne (fin de) soirée

Répondre