Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

kernel panic lors de l'installation

#1Messageil y a 2 mois

Bonjour, après avoir utilisé fedora je voulais passer à manjaro kde.
J'ai suivi le guide d'installation et via une clé USB en désactivant le secure boot du UEFI, j'ai fait un nouveau partitionnement GPT sur mon disque dur puis j'ai découpé mon /boot/efi, mon / et mon /home.
Ensuite, l'installation se passe sans erreur, je clique sur redémarrer puis j'appuis sur echap pour arriver sur grub. Tout me semble correct alors je boot manjaro, mais là, j'ai une erreur que j'ai prise en photo ci-dessous :
Image
J'ai réessayé l'installation plusieurs fois (sans partitionnement manuel) mais rien y fait.
J'imagine que c'est une compatibilité matérielle et kernel d'arch, mais vu que cela se produit lors de l'installation je l'ai poster dans ce forum. Merci d'avance pour votre aide.

kernel panic lors de l'installation

#2Messageil y a 2 mois

Bonjour.
Ça ressemble à un souci de micro-code non chargé au boot primaire.
As tu installé Grub ou conserver celui de Fedora?
Regarde ici: Il va falloir éditer à chaud Grub comme expliqué.
95169

kernel panic lors de l'installation

#3Messageil y a 2 mois

vérifie sous le live iso manjaro
ouvre le terminal

sudo gparted
( si il est manquant , sudo pacman -S gparted )
et regarde état de ton disque s'il présente des verrous

==> pb bios qui verrouille complètement le disque et toutes les partitions
vérifie aussi que tu as bien les disques en
-tous en AHCI
- pas de secure boot
- option full efi uniquement ( non windows )
- pas de fast boot
- pas de CSM
- pas de legacy
- pas d'optane / RST
Message remonté car à faire avant celui de papajoke
administration/modération
Dernière modification par stephaneil y a 2 mois, modifié au total 1 fois.

kernel panic lors de l'installation

#4Messageil y a 2 mois

bonjour et bienvenue

Ton erreur UUID ...
Une partition n'est pas trouvée :saispas:

Tu as une partition swap existante avant install ?
vérifier dans /etc/default/grub si tu as un mauvais UUID dans la ligne "GRUB_CMDLINE_LINUX_DEFAULT="

Sinon regarder dans /etc/fstab

pour avoir les UUID dispo, depuis ton iso :

lsblk -o "NAME,UUID,LABEL,SIZE,FSTYPE,PARTTYPE,MOUNTPOINT"

kernel panic lors de l'installation

#5Messageil y a 2 mois

Merci pour vos réponses.
Ça ressemble à un souci de micro-code non chargé au boot primaire.
As tu installé Grub ou conserver celui de Fedora?
Regarde ici: Il va falloir éditer à chaud Grub comme expliqué.
J'ai installé un nouveau grub. J'ai regardé les options de grub mais ma ligne initrd était déjà correct.
regarde état de ton disque s'il présente des verrous
==> pb bios qui verrouille complètement le disque et toutes les partitions
verifie aussi que tu as bien les disques en
-tous en AHCI
- pas de secure boot
- option full efi uniquement ( non windows )
- pas de fastboot
- pas de CSM
- pas de legacy
- pas d'otane / RST
En effet mes partitions ont des verrous. Mon uefi à moi est bien moche et vérifier ses options, je ne sais pas faire mais je sais que j'ai désactivé le secure boot.
Tu as une partition swap existante avant install ?
vérifier dans /etc/default/grub si tu as un mauvais UUID dans la ligne "GRUB_CMDLINE_LINUX_DEFAULT="
Sinon regarder dans /etc/fstab
Je n'ai pas de partition swap. Ma ligne du fichier /etc/default/grub est étrange :

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""
ici c'est /etc/fstab :

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=A31F-1C61                            /boot/efi      vfat    umask=0077 0 2
UUID=990a3504-c4f3-40e6-94bf-7ff8ea44c4fc /              ext4    defaults,noatime 0 1
UUID=5b092786-c7a0-413e-8087-7b81eab13110 /home          ext4    defaults,noatime 0 2
Enfin la commande que tu ma donner me revoie :

NAME        UUID LABEL   SIZE FSTYPE PARTTYPE MOUNTPOINT
loop0                     26M                 
loop1                  389.9M                 
loop2                    1.6G                 
loop3                  731.7M                 
sda                     57.6G                 
|-sda1                  57.6G                 
| `-ventoy               2.7G                 
`-sda2                    32M                 
nvme0n1                476.9G                 
|-nvme0n1p1              960M                 /boot/efi
|-nvme0n1p2              350G                 /
`-nvme0n1p3              126G                 /home
Voilà si vous avez besoin de plus d'infos pour m'aider, vous me dites.

kernel panic lors de l'installation

#6Messageil y a 2 mois

J'ai désactiver une option du uefi qui se nommais intel VMD controller. elle me cachais l'otions du disque AHCI que j'ai pu régler bref problème résolu tout fonctionne niquel merci :sourire:
Répondre