Questions sur l'installation et la configuration de Manjaro Linux.

Problème login avec lxdm

#1Messageil y a 7 ans

Bonsoir à tous.

Je viens de réinstaller mon PC de bureau avec une Manjaro XFCE 0.8.10 64 bits.

J'ai voulu changé mdm par lxdm. Le souci est qu'au démarrage j'arrive sur le tty1 et quand je bascule sur le tty7 (graphique) pour me loguer, j'entre mes login/mdp mais je boucle sur la fenêtre de login.... Je dois me loguer sur le tty1 et lancer startx pour lancer ma session...

Voici mon lxdm.conf (qui fonctionne parfaitement sur un autre PC, je l'ai d'ailleurs récupéré de là):

[base]
## uncomment and set autologin username to enable autologin
#autologin=frederic

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

## default session or desktop used when no systemwide config
session=/usr/bin/startxfce4

## uncomment and set to set numlock on your keyboard
numlock=1

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

# not ask password for users who have empty password
# skip_password=1

## greeter used to welcome the user
greeter=/usr/lib/lxdm/lxdm-greeter-gtk

[server]
## arg used to start xserver, not fully function
#arg=/usr/bin/X -background vt1
# uncomment this if you really want xserver listen to tcp
# tcp_listen=1
# uncoment this if you want reset the xserver after logou
# reset=1

[display]
## gtk theme used by greeter
gtk_theme=Adwaita-Manjaro-dark

## background of the greeter
# bg=/usr/share/backgrounds/default.png

## if show bottom pane
bottom_pane=1

## if show language select control
lang=1

## if show keyboard layout select control
keyboard=0

## the theme of greeter
#theme=Industrial
theme=Archlinux

bg=#000000000000

[input]

[userlist]
## if disable the user list control at greeter
disable=0

## whitelist user
white=

## blacklist user
black=


Puvez-vous m'aider à résoudre mon souci?

Problème login avec lxdm

#2Messageil y a 7 ans

Salut,
Que dit :

sudo systemctl status mdm
sudo systemctl status lxdm

Problème login avec lxdm

#3Messageil y a 7 ans

Voilà:

[frederic@PC-bureau ~]$ sudo systemctl status mdm
[sudo] password for frederic:
● mdm.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
[frederic@PC-bureau ~]$ sudo systemctl status lxdm
● lxdm.service - LXDE Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lxdm.service; enabled)
   Active: active (running) since ven. 2014-06-13 20:55:30 CEST; 1min 43s ago
 Main PID: 957 (lxdm-binary)
   CGroup: /system.slice/lxdm.service
           ├─ 957 /usr/bin/lxdm-binary
           └─1068 /usr/bin/X -background none :0 vt07 -nolisten tcp -novtswitch

juin 13 20:55:30 PC-bureau systemd[1]: Starting LXDE Display Manager...
juin 13 20:55:30 PC-bureau systemd[1]: Started LXDE Display Manager.
[frederic@PC-bureau ~]$

Problème login avec lxdm

#4Messageil y a 7 ans

que dit :

sudo gedit /etc/mdm/mdm.conf

et

sudo gedit /etc/lxdm/lxdm.conf

--------------------------------------------------------------------

ton mdm est mort :
(( Active: inactive (dead) ))

ton lxdm est vivant .. il bouge .. ;)
(( Active: active (running) ))

;)

Problème login avec lxdm

#5Messageil y a 7 ans

moi , j'essayerais de decommander enlever le # du debut (( #autologin=frederic )) dans ton lxdm.conf

pour :

autologin=frederic

Problème login avec lxdm

#6Messageil y a 7 ans

m_n15 a écrit :que dit :

sudo gedit /etc/mdm/mdm.conf

et

sudo gedit /etc/lxdm/lxdm.conf

--------------------------------------------------------------------

ton mdm est mort :
(( Active: inactive (dead) ))

ton lxdm est vivant .. il bouge .. ;)
(( Active: active (running) ))

;)


mdm.conf n'existe plus:

[frederic@PC-bureau ~]$ sudo mousepad /etc/m
machine-id       makepkg.conf     manjaro-release  mime.types       mkinitcpio.conf  modprobe.d/      motd             
mail.rc          man_db.conf      mdadm.conf       mke2fs.conf      mkinitcpio.d/    modules-load.d/  mtab             
[frederic@PC-bureau ~]$ sudo mousepad /etc/m


Et re-voici lxdm:

[base]
## uncomment and set autologin username to enable autologin
#autologin=frederic

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

## default session or desktop used when no systemwide config
session=/usr/bin/startxfce4

## uncomment and set to set numlock on your keyboard
numlock=1

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

# not ask password for users who have empty password
# skip_password=1

## greeter used to welcome the user
greeter=/usr/lib/lxdm/lxdm-greeter-gtk

[server]
## arg used to start xserver, not fully function
#arg=/usr/bin/X -background vt1
# uncomment this if you really want xserver listen to tcp
# tcp_listen=1
# uncoment this if you want reset the xserver after logou
# reset=1

[display]
## gtk theme used by greeter
gtk_theme=Adwaita-Manjaro-dark

## background of the greeter
# bg=/usr/share/backgrounds/default.png

## if show bottom pane
bottom_pane=1

## if show language select control
lang=1

## if show keyboard layout select control
keyboard=0

## the theme of greeter
#theme=Industrial
theme=Archlinux

bg=#000000000000

[input]

[userlist]
## if disable the user list control at greeter
disable=0

## whitelist user
white=

## blacklist user
black=

Problème login avec lxdm

#7Messageil y a 7 ans

m_n15 a écrit :moi , j'essayerais de decommander enlever le # du debut (( #autologin=frederic )) dans ton lxdm.conf

pour :

autologin=frederic


Pas mieux :desole:

Problème login avec lxdm

#8Messageil y a 7 ans

Voici peut être une piste grâce aux logs de lxdm:

sudo mousepad /var/log/lxdm.log


** Message: found plymouth running

** Message: find greeter (nil)

** Message: find idle (nil)

** Message: 1402694112: add xserver watch


X.Org X Server 1.15.1
Release Date: 2014-04-13
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.14.0-4-ARCH x86_64
Current Operating System: Linux PC-bureau 3.14.7-1-MANJARO #1 SMP PREEMPT Thu Jun 12 06:45:07 UTC 2014 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-314-x86_64 root=UUID=c663cfa2-c3e2-4cc4-b837-4984679164fa rw resume=UUID=2efa04e6-f9ed-4385-af5c-e75ea3e0d162 quiet splash
Build Date: 14 April 2014  08:39:09AM
 
Current version of pixman: 0.32.4
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 13 23:15:12 2014
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
(II) [KMS] Kernel modesetting enabled.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
** Message: 1402694117: start xserver in 1 retry
** Message: add 0x1e13cd0

** Message: prepare greeter on :0

** Message: start greeter on :0

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Compat map for group 2 redefined
>                   Using new definition
> Warning:          Compat map for group 3 redefined
>                   Using new definition
> Warning:          Compat map for group 4 redefined
>                   Using new definition
Errors from xkbcomp are not fatal to the X server

(lxdm-greeter-gtk:790): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(lxdm-greeter-gtk:790): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(lxdm-greeter-gtk:790): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(lxdm-greeter-gtk:790): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(lxdm-greeter-gtk:790): Gtk-CRITICAL **: IA__gtk_widget_get_visible: assertion 'GTK_IS_WIDGET (widget)' failed
** Message: find greeter (nil)

** Message: find idle 0x1e13cd0

** Message: add 0x1e13cd0

** Message: prepare greeter on :0

** Message: start greeter on :0


(lxdm-greeter-gtk:858): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(lxdm-greeter-gtk:858): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(lxdm-greeter-gtk:858): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(lxdm-greeter-gtk:858): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
kill 835 836 840 853
(II) AIGLX: Suspending AIGLX clients for VT switch

Problème login avec lxdm

#9Messageil y a 7 ans

Problème login avec lxdm

#10Messageil y a 7 ans

Bonsoir
Essayes en désactivant mdm:

sudo systemctl disable mdm.service

Puis on réactive lxdm:

sudo systemctl enable lxdm.service

et tu te relogues.

Problème login avec lxdm

#11Messageil y a 7 ans

@m_n15 je n'ai pas "login window"

@lemust83 merci pour la suggestion, mais pas mieux :tetu!

Ca fait comme un flash, et ça retourne directement sur la fenêtre de login.

Install fraiche, drivers libres, j'ai comparé la config lxdm avec mon autre PC qui lui fonctionne parfaitement, pas de différence visible.....

Je ne vois plus ou regarder....

[frederic@PC-bureau lxdm]$ pacman -Qi lxdm
Nom                   : lxdm
Version               : 0.4.1.r178.gbf90ec7-1
Description           : Lightweight X11 Display Manager
Architecture          : x86_64
URL                   : http://blog.lxde.org/?p=531
Licences              : GPL
Groupes               : lxde
Fournit               : lxdm
Dépend de             : cairo  dbus-core  gdk-pixbuf2  glib2  gtk2  libx11  libxcb  pango
Dépendances opt.      : lxpolkit: to run lxdm-config directly from menu[installé]
                        gtk-engines: default GTK+ theme[installé]
                        librsvg: display the default background[installé]
Requis par            : archlinux-lxdm-theme
Optionnel pour : --
Est en conflit avec   : lxdm  lxdm-svn
Remplace              : --
Taille installé : 783,00 KiB
Paqueteur             : Philip Müller <philm|manjaro|org>
Compilé le            : dim. 27 avril 2014 14:20:48 CEST
Installé le           : ven. 13 juin 2014 19:22:22 CEST
Motif d'installation  : Explicitement installé
Script d'installation : Oui
Validé par : Signature

[frederic@PC-bureau lxdm]$

Problème login avec lxdm

#12Messageil y a 7 ans

Salut,

J'irais voir dans ~/.xinitrc ou /etc/X11/init.d/xinitrc si il y a des trâces d'un startxfce4 ou quelque chose comme ça...

Problème login avec lxdm

#13Messageil y a 7 ans

@ Coubi64: as-tu essayé de décommenter la fameuse ligne qui t'avait posé problème dans un autre sujet ?

arg=/usr/bin/X -background vt1

autre question: c'est une installation propre sur des partitions vierges, ou tu as conservé le home ?

Problème login avec lxdm

#14Messageil y a 7 ans

fassil a écrit :Salut,

J'irais voir dans ~/.xinitrc ou /etc/X11/init.d/xinitrc si il y a des trâces d'un startxfce4 ou quelque chose comme ça...


Voilà mon .xinitrc:

#!/bin/sh

#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

DEFAULT_SESSION=xfce4-session
case $1 in
  xfce) exec dbus-launch xfce4-session ;;
  *) exec dbus-launch  $DEFAULT_SESSION ;;
esac


et mon "sudo mousepad /etc/X11/xinit/xinitrc":

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs
if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login


Sinon, pour avancer un peu:

1) j'étais branché en DVI, j'ai testé en VGA, pas mieux....
2) je suis en testing
3) j'ai essayé avec le noyau 3.12, pas mieux non plus
4) comme le conseille Loubrix, j'ai décommenter la ligne "arg=/usr/bin/X -background vt1", ça n'a pas résolu mon souci non plus.
5) Installation faite en supprimant le disque entier (option proposée par défaut) avec option home séparé

Image

Problème login avec lxdm

#15Messageil y a 7 ans

dans la photo de (( configuration de LXDM )

tu n'a pas coché ( Connexion automatique ) ..

Problème login avec lxdm

#16Messageil y a 7 ans

:salut:

sudo systemctl enable lxdm.service -f

Puis reboote

Problème login avec lxdm

#17Messageil y a 7 ans

@m_n15 oui c'est normal car je ne veux pas me connecter automatiquement, mais saisir un login et mot de passe pour pouvoir me loguer

@Gilxunil merci, mais toujours pareil :triste:

Problème login avec lxdm

#18Messageil y a 7 ans

En cherchant sur le net et en faisant différents essais, j'ai tenté de modifier mon ".dmrc":

J'ai mis:

[Desktop]
Session=xfce


au lieu de

[Desktop]
Session=Default


Et là je me suis logué :bien

Par contre, je démarre toujours sur le tty1(console) au lieu du tty7(graphique), c'est assez gênant, je dois basculer manuellement sur le tty7 à chaque démarrage..... Quelle en est la cause?

Problème login avec lxdm

#19Messageil y a 7 ans

Apparemment tu as décommenté

arg=/usr/bin/X -background vt1

essaye en le recommentant

Problème login avec lxdm

#20Messageil y a 7 ans

Gilxunil a écrit :Apparemment tu as décommenté

arg=/usr/bin/X -background vt1

essaye en le recommentant


non, cela fonctionne mais en décommentant cette ligne :bien

Par contre mon verrouillage numérique qui s'active bien au login (j'ai installé le paquet numlockx) se désactive ensuite quand j'arrive sur le bureau...... :tetu!

Je reste très perplexe quand à 2 configs "identiques" (xfce 64bits avec lxdm), dont il faut décommenter la ligne "arg=...." et l'autre la décommenter. Et ce pb de verrouillage numérique qui différe aussi sur les 2 versions (aucun souci avec mon autre PC) :saispas:
Répondre