Problèmes et questions concernant le noyau et le support matériel.
Répondre

Jouer un son avec udev

#1Messageil y a 1 semaine

Bonjour a tous.

je cherche un moyen simple d’émettre un son au moment d’insérer une clé usb.

Etant sous gnome, je n'ai pas trouvé de possibilité de faire ça (deconf, logiciel tiers...), par contre j'ai vu qu'avec udev, il était possible de le faire (je suppose) mais je n'y arrive pas, certainement un problème de syntaxe et donc j'aurai besoin de vos lumières pour ajuster ça.

ACTION=="add", KERNEL=="sd[e-z]", RUN+="mplayer /home/user/Documents/musique.ogg"
j'utilise mplayer mais une solution encore plus simple est bonne a prendre comme utiliser la même chose que les simple notification système.

je pense que la ligne RUN n'est pas bonne car il ne se passe rien a part un "error code 1" dans journalctl -f

merci pour l'aide :sourire:

Jouer un son avec udev

#2Messageil y a 1 semaine

Salut,
beuz a écrit : il y a 1 semaine certainement un problème de syntaxe et donc j'aurai besoin de vos lumières pour ajuster ça.

ACTION=="add", KERNEL=="sd[e-z]", RUN+="mplayer /home/user/Documents/musique.ogg"
Normalement, il faut le chemin complet vers le programme à exécuter :

ACTION=="add", KERNEL=="sd[e-z]", RUN+="/usr/bin/mplayer /home/user/Documents/musique.ogg"
Tu peux aussi détecter la déconnexion de la clé par ACTION=="remove".

Jouer un son avec udev

#3Messageil y a 1 semaine

bonjour,

après avoir complété le chemin complet, ça ne marche pas. (après reboot)

j'ai bien une petite notification sonore mais pas celle que je souhaites et c'est assez étrange car je devrais trouver cette info dans dconf mais rien...

Jouer un son avec udev

#4Messageil y a 1 semaine

Bonjour
Essaye de passer par aplay au lieu de mplayer.
Par exemple, j'ai créé un fichier audio de 2 secondes à partir du célèbre "Highway to hell" d'AC/DC que j'ai renommé courtement sans espace histoire de n'avoir que les 3 premiers accords.
Idéal pour un Jingle :gsourire:

$ ffmpeg -i higway.mp3 -ss 00:00:00 -t 00:00:02 cuthigway.mp3
Ensuite il faut renseigner le fichier dans son chemin absolu, sinon on entend que du souffle (bruit blanc).
Là, je suis sur un volume monté dans /run.

$ aplay -c 2 '/run/media/steph/wwwwyyyyyzzz/cuthigway.mp3'
Il est possible de préciser l’échantillonnage, le nombre de canaux etc.... Voir man aplay
Je n'ai pas essayé la commande udev, mais il n'y a pas de raison que ça ne marche pas.

Edit: il y a cette page qui pourrait t'aider

Jouer un son avec udev

#5Messageil y a 1 semaine

Bonjour,
bon j'ai trouvé mais pas encore parfait et c'était bien un problème de syntaxe,

ACTION=="add", KERNEL=="sd[e-z]", RUN+="/usr/bin/mplayer '/home/user/Documents/musique.ogg' "
les deux apostrophes du chemin complet, et c'est lemust83 qui m'a mis la puce a l’oreille avec le chemin absolu.

donc ça fonctionne mais j'ai toujours le son d'origine en plus du mien et je ne trouve pas ou il est pour le remplacer/supprimer.

Jouer un son avec udev

#6Messageil y a 1 semaine

re, j'ai trouvé le répertoire des sons système:

/usr/share/sounds/freedesktop/stereo
j'ai mv bak les sons d'origine et mv mes deux sons avec les noms d'origines (device-added.oga et device-removed.oga) et ça fonctionne a merveille, au final très simple a faire et pas besoin de règles udev ou autre.

Jouer un son avec udev

#7Messageil y a 1 semaine

:salut:
beuz a écrit : il y a 1 semaine re, j'ai trouvé le répertoire des sons système:
device-added.oga appartient au paquet sound-theme-freedesktop donc a la mise à jour de ce paquet, les modifications sont perdues :pleure:

Puisque ton bureau gère déjà cet événement, autant juste remplacer le fichier son
Je n'ai pas xfce/gnome pour tester mais pour moi, il me semble que le plus simple est de créer/installer un thème de son dans notre home ~/.local/share/sounds/monthemeperso/ (avec un seul son car peut hériter)

http://0pointer.de/public/sound-theme-spec.html#example
https://github.com/maxjf1/yk-sound
https://github.com/rtlewis88/rtl88-Them ... /Enchanted
Répondre